Closed Bug 620849 Opened 9 years ago Closed Last year

Holding Ctrl+Enter for too long sends multiple e-mails

Categories

(Thunderbird :: Message Compose Window, defect)

x86_64
Linux
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 620853

People

(Reporter: a.nielsen, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: qawanted)

User-Agent:       Mozilla/5.0 (X11; Linux i686 on x86_64; rv:2.0b7) Gecko/20100101 Firefox/4.0b7
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-GB; rv:1.8.1.23) Gecko/20091130 Thunderbird/2.0.0.23 Mnenhy/0.7.5.0

If you accidentally hold down Ctrl+Enter and Thunderbird takes a little too long to respond, multiple Ctrl+Enter events are sent.  Thunderbird responds by sending the message multiple times, with the second and subsequent messages returning a popup error about being unable to move the message into the sent items folder (presumably as I am using IMAP and the first sent message moved it out of Drafts into Sent, so subsequent send attempts couldn't find it.)

Reproducible: Always

Steps to Reproduce:
1. Compose a message, better on a slow PC or when Thunderbird is acting sluggish
2. Hold Ctrl+Enter (better with a fast keyboard repeat rate, or if you can press the keys multiple times very quickly)

Actual Results:  
Same message will be sent multiple times.

Expected Results:  
Message only got sent once.

On my platform, Ctrl+Enter also dismisses the warning popup, so holding Ctrl+Enter can result in a warning popup, the popup going away, then another warning popup appearing.

I am not sure whether the problem lies in multiple Ctrl+Enter events arriving up front and being processed in parallel, or many Ctrl+Enter events arriving and being processed sequentially.
Adam does this also happen in safe mode?
 https://support.mozillamessaging.com/en-US/kb/Safe+Mode
 (I doubt it will help, but worth trying)
Keywords: qawanted
Yes I can confirm that not only does it happen in safe mode, but at least in my attempt it crashed Thunderbird.

In safe mode TB was much more responsive so holding Ctrl+Enter down didn't work (it had sent and closed the compose window before the autorepeat kicked in) so I had to fake it my pressing Ctrl+Enter twice really fast.

Interestingly I only received one confirmation popup, one mail was sent without warning.  When I agreed to send the second mail and dismissed the error about being unable to copy the message to Sent Items, a 'copying' window was left on the screen.  Clicking cancel on that caused a crash.

I guess the crash was related to two separate threads operating on the same message/IMAP connection, so I imagine the crash will go away if the original problem is fixed by preventing the same message from being sent multiple times.
Sorry I didn't get a crash reporter window appearing - it never used to work under 64-bit so I think this is the reason.  I can't seem to get a GDB backtrace either as Thunderbird is launched by a rather complex looking shell script.

You might be able to reproduce the problem by composing an e-mail to yourself, holding Ctrl and rapidly pressing Enter as fast as you can at least five or six times, regardless of the popups appearing on-screen.
This is essentially bug 620853
Status: UNCONFIRMED → RESOLVED
Closed: Last year
Resolution: --- → DUPLICATE
Duplicate of bug: 620853
You need to log in before you can comment on or make changes to this bug.