Status

()

defect
RESOLVED DUPLICATE of bug 446444
9 years ago
9 months ago

People

(Reporter: mixedpuppy, Unassigned)

Tracking

(Blocks 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments, 1 obsolete attachment)

Reporter

Description

9 years ago
I have a small set of patches to the core sync addon that allows me to add support for other applications (ie thunderbird) without further additions to the sync addon.

There are three primary patches:

- allow registration of engine instances in addition to classes
- modify prefs to allow for overlays
- a small amount of abstraction to allow an app to specify how to open prefs and how to discover the primary window

Some of this work originated from Bug 446444
Reporter

Comment 1

9 years ago
Attachment #499547 - Flags: review?(philipp)
Reporter

Comment 2

9 years ago
Posted patch prefs overlay (obsolete) — Splinter Review
Attachment #499548 - Flags: review?(philipp)
Reporter

Comment 3

9 years ago
Attachment #499549 - Flags: review?(philipp)
Reporter

Comment 4

9 years ago
Attachment #499551 - Flags: review?(philipp)
Blocks: 446444
Comment on attachment 499547 [details] [diff] [review]
engine instance registration

This looks very reasonable, though it'd be good to amend the unit tests to test the added code path.
Attachment #499547 - Flags: review?(philipp) → review+
Comment on attachment 499548 [details] [diff] [review]
prefs overlay

>   get prefArray() {
>-    return ["engine.bookmarks", "engine.passwords", "engine.prefs",
>-      "engine.tabs", "engine.history"];
>+    let prefList = document.getElementById('weavePreferences');
>+    var prefArray = [];
>+    for (let i = 0; i < prefList.childNodes.length; ++i)
>+      prefArray.push(prefList.childNodes[i].getAttribute('id'));
>+    delete this.prefArray;
>+    return this.prefArray = prefArray;

Can we add a comment above this stanza pointing out why we're doing this?
Attachment #499548 - Flags: review?(philipp) → review+
Reporter

Comment 7

9 years ago
Posted patch prefs overlaySplinter Review
added comment
Attachment #499548 - Attachment is obsolete: true
Attachment #499569 - Flags: review?(philipp)
Reporter

Updated

8 years ago
Attachment #499569 - Flags: review?(philipp)
Reporter

Updated

8 years ago
Attachment #499551 - Flags: review?(philipp)
Reporter

Updated

8 years ago
Attachment #499549 - Flags: review?(philipp)
Blocks: 652631
OS: Mac OS X → All
Hardware: x86 → All
Summary: thunderbird support → Sync support for Thunderbird
did this ever land?
(In reply to :Ally Naaktgeboren from comment #8)
> did this ever land?

Pretty sure it didn't, otherwise it would be RESOLVED/FIXED.
Shane, any update on this?
I'm pretty sure Shane isn't working on this.
Assignee: mixedpuppy → nobody

Comment 12

7 years ago
Like CardDAV this will never happen
Duplicate of this bug: 765324
sync triage: given the decision to stop development on thunderbird, is this bug still valid?
yes, hopefully someone will still pick it up
Duplicate of this bug: 813665
Duplicate of this bug: 821569

Comment 18

6 years ago
I think it is useful to sync Thunderbirds'
* preferences
* extensions
* filter rules
* account information
* tags
with Sync.

Comment 19

6 years ago
Is there a thunderbird-sync.xpi planned?
There is no non-critical investment planned in the Sync codebase. I don't know if the Identity team plans to address Thunderbird in PICL, or if the Thunderbird folks want to run with this, but we won't be.
Comment on attachment 499549 [details] [diff] [review]
app specific support

So, how many hours is that away from having at least some basic Thunderbird prefs on Mozilla Sync?
Shane, could you be so kind and package this sketch for continuing work?
That patch was written for the Weave/Sync add-on in 2010.

Since that patch was written, Sync was integrated into mozilla-central (targeted at Firefox), was stable for a couple of years, and then was semi-EOLed -- it's in the process of being replaced by a new auth system (Firefox Account) and, eventually, a new implementation that doesn't carry Sync's legacy flaws.

None of the patches on this bug are likely to be significant timesavers; moreover, any effort you put in now to the auth/login part will very soon be entirely obsoleted.

Work done on the TB core -- mail accounts, for example -- to make them more syncable is not likely to be wasted effort, so I'd encourage you to begin laying groundwork rather than hacking up something that will soon be thrown away.

Comment 23

5 years ago
Should this be closed (as dup of bug #446444)?

Comment 24

5 years ago
Any news for adding this feature?
Or never because Thunderbird is (or will be) discontinued?
Feel free to work on it. AFAIK nobody has stepped up and provided a patch yet. (the wip patches in this bug are likely junk at this point)
Might as well dupe this over to the TB-side bug.

Sync for Thunderbird has nobody driving it, as far as I know.

Sync itself isn't under heavy development.

My personal opinion is that new services should be new services: if you want to somehow share state between different Thunderbird instances, do that through a specialized service. Then you can back up/version account settings, use a specialized representation for tags, etc. etc., rather than trying to jam it into Sync's data model and constraints.

This is now much easier due to FxA -- an account system exists that you can use.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 446444
Component: Firefox Sync: UI → Sync
Product: Cloud Services → Firefox
You need to log in before you can comment on or make changes to this bug.