Password invalid/server authentication failed for Windows Live Hotmail with long password (>16 chars)

RESOLVED WONTFIX

Status

Thunderbird
General
--
major
RESOLVED WONTFIX
8 years ago
6 years ago

People

(Reporter: tom_inthewall, Unassigned)

Tracking

x86
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [closeme 2011-02-21])

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-GB; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-GB; rv:1.9.2.13) Gecko/20101207 Thunderbird/3.1.7

Attempt to setup account for a Windows Live Hotmail account with a long password (17 characters or more) fails.

During automatic account configuration the diaglogue box reads:
User name or password invalid
Configuration could not be verified - is the user name and password wrong?
Detected servers were
Incoming: pop3.live.com POP  995 SSL/TLS
Outgoing: smtp.live.com SMTP 587 STARTTLS

Using a manually configured account (same settings as automatic configuration), attempt to Get Mail gives the following error:
Sending of password did not succeed. Mail server pop3.live.com responded: authentication failed.

Access via Hotmail website works as normal with a long password.

Problem can be worked around for Thunderbird by shortening account password using Hotmail website.

Lots of other users reporting this in forums - please try to fix or update error messages to suggest this workaround.

Reproducible: Always

Steps to Reproduce:
1. Tools/Account Settings/Account Actions/Add Mail Account
2. Enter details for Windows Live Hotmail account (username@hotmail.com) with >16 character password
3. Continue
Actual Results:  
Password invalid

Expected Results:  
Account created successfully

Passwords with <17 characters work.
(Reporter)

Updated

8 years ago
Version: unspecified → 3.1
As for existent account of Gmail IMAP(SSL) defined in Tb 3.1.7, long password like abcd12345678901234567890(24 chars>16chars), works very well.
It's merely that Web interface of Windows Live mail supports longer than 16 char password but POP3 or SMTP doesn't support yet, isn't it?
Does longer than 16 char password work very well with Windows Live's POP3 or SMTP if any other mailer than Thunderbird or SeaMonkey?
Tb only problem and problem when "longer than 16 chars with special chars or non-ascii chars"?

Comment 2

8 years ago
Tom....

> It's merely that Web interface of Windows Live mail supports longer than 16
> char password but POP3 or SMTP doesn't support yet, isn't it?

> Does longer than 16 char password work very well with Windows Live's POP3 or
> SMTP if any other mailer than Thunderbird or SeaMonkey?

> Tb only problem and problem when "longer than 16 chars with special chars or
> non-ascii chars"?
Whiteboard: [closeme 2011-02-21]
RESOLVED INCOMPLETE due to lack of response to last question. If you feel this change was made in error, please respond to this bug with your reasons why.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INCOMPLETE

Comment 4

7 years ago
bonjour/hello

je viens de faire des essais et au delà de 11 caractères TB refuse le mot de passe (messagerie hotmail.fr)

I have to experiment.
TB refuses a password over 11 characters (hotmail.fr email)

Comment 5

7 years ago
Nouveau essais après lecture des post ci dessus!!!
Maintenant TB accepte 16 caractères maxi !! 


New test after reading the post above!
TB now accepts 16 characters max!

Comment 6

7 years ago
(In reply to J2m06 from comment #5)
> Nouveau essais après lecture des post ci dessus!!!
> Maintenant TB accepte 16 caractères maxi !! :-(
> 
> 
> New test after reading the post above!
> TB now accepts 16 characters max!

Comment 7

7 years ago
(In reply to J2m06 from comment #4)
> bonjour/hello
> 
> je viens de faire des essais et au delà de 11 caractères TB refuse le mot de
> passe (messagerie hotmail.fr)
> 
> I have to experiment.
> TB refuses a password over 11 characters (hotmail.fr email)!!!
(Reporter)

Comment 8

7 years ago
(In reply to J2m06 from comment #5)
> Nouveau essais après lecture des post ci dessus!!!
> Maintenant TB accepte 16 caractères maxi !! 
> 
> 
> New test after reading the post above!
> TB now accepts 16 characters max!

Hello

I think WADA was correct in Comment #1.  You can create a long password (>16 characters) for your account that works for hotmail.fr.  HOWEVER, this is only because hotmail.fr truncates the password to 16 characters (see here http://www.google.com/support/forum/p/gmail/thread?tid=38c1a2b978455098&hl=en).  

If you truncate the password manually in Thunderbird, it should work.

PS - Apologies to WADA and Wayne for not responding to original posts, not sure what happened there.


Bonjour

Je pense que WADA a eu raison de Commentaire #1. Vous pouvez créer un mot de passe long (> 16 caractères) pour votre compte qui fonctionne pour hotmail.fr. Cependant, ce n'est que parce que hotmail.fr tronque le mot de passe de 16 caractères (voir ici http://www.google.com/support/forum/p/gmail/thread?tid=38c1a2b978455098&hl=en).

Si vous tronquer le mot de passe manuellement dans Thunderbird, il devrait fonctionner.
Resolution: INCOMPLETE → WONTFIX

Comment 9

7 years ago
bonjour/hello

Nouveaux essais
Voici ce que j'ai constaté:
1-directement sur le webmail de Homtail on peut entrer un mot de passe de 20 caractères (et plus !)
2-par contre depuis TB seul les 16 premiers  caractères sont requis (sinon on a un message d’erreur) 
3-idem pour se connecter directement sur hotmail on peut mettre QUE les 16 premiers  caractères (même si on à  mis un mot de passe de 20 caractères)

*************
hello
new tests
Here's what I found:
1-directly to the webmail Homtail you can enter a password of 20 characters (and more!)
2-in against TB since only the first 16 characters are required (if it was an error message)
3-ditto to connect directly to hotmail you can put the first 16 characters (even if you put in a password of 20 characters)
(Reporter)

Comment 10

7 years ago
Yes, so it's horrible behaviour on Hotmail's part, and not a problem with Thunderbird.  It's just unfortunate that it looks like horrible behaviour on Thunderbird's part (or another email client) when you first discover it.

Well done for taking the time to do tests!

*******

Oui, il est donc un comportement horrible sur une partie de Hotmail, et non un problème avec Thunderbird. C'est juste dommage que ça ressemble un comportement horrible sur une partie de Thunderbird (ou autre client email) lors de sa première découverte.

Bien fait de prendre le temps de faire des tests!
See also Bug 663022 for Hotmail's horribly nice design/implementation.
You need to log in before you can comment on or make changes to this bug.