github impact display rendered in black-on-black

RESOLVED DUPLICATE of bug 615741

Status

()

defect
RESOLVED DUPLICATE of bug 615741
9 years ago
9 years ago

People

(Reporter: dustin, Unassigned)

Tracking

Trunk
x86
All
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

()

Attachments

(1 attachment)

Posted image screenshot.png
Viewing https://github.com/buildbot/buildbot/graphs/impact with Firefox 4.0b8, I see a black graph on a black background - see attached screenshot.  I expect to see a white background with colored shapes near the top.  The dates and numbers (commit counts) are displayed correctly.

Comment 1

9 years ago
Confirmed on windows too,

D2D  D3D10(9) 
ON   ON     White background, no graph, label only
ON   OFF   White background, no graph, label only
OFF  ON    Black background, no graph, white label only
OFF  OFF   Works

*Regression window(Windows7, enabled D2D and D3D10(9)):
Works:
http://hg.mozilla.org/mozilla-central/rev/f001894b50ea
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b5pre) Gecko/20100817 Minefield/4.0b5pre ID:20100817192012
Fails(White background, no graph, label only):
http://hg.mozilla.org/mozilla-central/rev/984f55359541
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b5pre) Gecko/20100817 Minefield/4.0b5pre ID:20100817214337
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=f001894b50ea&tochange=984f55359541
Regressed by: Bug 549116 - (d2d) Enable Direct2D by default

Graphics:
Adapter Description : ATI Radeon HD 4300/4500 Series
Vendor ID : 1002
Device ID : 954f
Adapter RAM : 512
Adapter Drivers : aticfx64 aticfx64 aticfx32 aticfx32 atiumd64 atidxx64
atiumdag atidxx32 atiumdva atiumd6a atitmm64
Driver Version : 8.791.0.0
Driver Date :
Direct2D Enabled : true
DirectWrite Enabled : true
WebGL Renderer : ATI Technologies Inc. -- ATI Radeon HD 4300/4500 Series     -- 3.3.10317 Compatibility Profile Context
GPU Accelerated Windows : 1/1 Direct3D 10


*Regression window(Window XP, enabled D3D9)
Works:
http://hg.mozilla.org/mozilla-central/rev/b57dda2ee56d
Mozilla/5.0 (Windows NT 5.1; rv:2.0b6pre) Gecko/20100904 Firefox/4.0b6pre ID:20100904212104
Fails(Black background, no graph, white label only):
http://hg.mozilla.org/mozilla-central/rev/fd13b6ce36bd
Mozilla/5.0 (Windows NT 5.1; rv:2.0b6pre) Gecko/20100904 Firefox/4.0b6pre ID:20100904234810
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=b57dda2ee56d&tochange=fd13b6ce36bd
Regressed by: Bug 581212 - (d3d9-layers) [tracking bug] Turn on Direct3D 9 accelerated layers for at least some subset of hardware 

Graphics
Adapter Description : VMware SVGA II
Vendor ID : 15ad
Device ID : 0405 : 
Adapter RAM : Unknown
Adapter Drivers : vmx_fb
Driver Version : 11.6.0.35
Driver Date : 4-21-2010
Direct2D Enabled : fals
DirectWrite Enabled : false
WebGL Renderer : VMware, Inc. -- Gallium 0.3 on SVGA3D; build: RELEASE;  -- 2.1 Mesa 7.7.1-DEVEL
GPU Accelerated Windows : 1/1 Direct3D 9

Updated

9 years ago
Blocks: d2d, d3d9-layers
blocking2.0: --- → ?
OS: Mac OS X → All
D2D can't possibly be causing the problem on Mac.  Dustin, I assume you do see it on Mac?

For what it's worth, in a 2010-12-21 Mac trunk build I don't see a problem on that page...
Component: Canvas: 2D → Graphics
QA Contact: canvas.2d → thebes
(In reply to comment #2)
> D2D can't possibly be causing the problem on Mac.  Dustin, I assume you do see
> it on Mac?

Correct

> For what it's worth, in a 2010-12-21 Mac trunk build I don't see a problem on
> that page...

Sure enough, it looks fine in Minefield (2010-1-3) for me, too.

Unless this remains a D2D problem for Alice in Minefield, this can be RESOLVED WORKSFORME AFAIC.
(In reply to comment #1)
> Confirmed on windows too,
> 
> D2D  D3D10(9) 
> ON   ON     White background, no graph, label only

I'm seeing this too.

> OFF  ON    Black background, no graph, white label only

This is perhaps the most odd, as with D3D9 this Canvas should just be GDI and nothing special should be done drawing. I wonder if multiple Canvases are being overlayed on top of eachother and we're messing up the blending.
So, the Canvas they're creating is 21000 pixels wide, this is causing issues in several steps of the drawing pipeline when HW accel is enabled.
So, this was fixed on Mac recently, the problem here is Canvases that are larger than the maximum texture size (always at least 4096x4096 in the cases where we use acceleration).

There's 3 possible approaches that may or may not be acceptable:

1. Create the largest possible canvas, and expose the actual size, as is done for WebGL.
2. Draw scaled down to a maximum size surface, and then scale up on blending, this would often create upsampling artifacts of course.
3. Create software canvases in these cases and do partial uploading. This has the downside of polluting the code a little and of course providing a canvas with different perf characteristics.

All of these are do-able, although in some cases slightly tricky, approaches I think.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 615741
blocking2.0: ? → ---
You need to log in before you can comment on or make changes to this bug.