Middle click Reload button messed up tabs after using Panorama, Middle click Back/Forward button also messed up tabs.

VERIFIED FIXED

Status

Firefox Graveyard
Panorama
VERIFIED FIXED
8 years ago
2 years ago

People

(Reporter: Alice0775 White, Assigned: ttaubert)

Tracking

({regression})

Trunk
x86
All
regression
Dependency tree / graph

Details

(Whiteboard: [softblocker])

(Reporter)

Description

8 years ago
Build Identifier:
Mozilla/5.0 (Windows NT 5.1; rv:2.0b9pre) Gecko/20110106 Firefox/4.0b9pre
ID:20110106030349

Middle click Reload button messed up tabs after using Panoram.
Existing tab will be hidden in tabstrip. Duplicated tab only appears.

Reproducible: Always

Steps to Reproduce:
1. Start Minefield with new profile
2. Open Tabs
3. Enter Panorama and exit
4. Middle click Reload button 

Actual Results:
 Existing tab will be hidden in tabstrip. Duplicated tab only appears.

Expected Results:
 Existing tab and Duplicated tab should be in the tab strip.

Regression windoe(cached hourly):
Works:
http://hg.mozilla.org/mozilla-central/rev/bddc89a2200c
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b9pre) Gecko/20110105 Firefox/4.0b9pre ID:20110105121028
Fails:
http://hg.mozilla.org/mozilla-central/rev/f453924d5fe1
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b9pre) Gecko/20110105 Firefox/4.0b9pre ID:20110105130215
pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=bddc89a2200c&tochange=f453924d5fe1
(Reporter)

Updated

8 years ago
blocking2.0: --- → ?
(Reporter)

Comment 1

8 years ago
And Middle click Back/Forward button also  messed up tabs after using Panorama
Summary: Middle click Reload button messed up tabs after using Panoram. → Middle click Reload button messed up tabs after using Panorama, Middle click Back/Forward button also messed up tabs.
(Reporter)

Comment 2

8 years ago
This happens on ubuntu10.04 too.
Mozilla/5.0 (X11; Linux i686; rv:2.0b9pre) Gecko/20110106 Firefox/4.0b9pre ID:20110106030349

In local build:
build from f453924d5fe1 : fails
build from 8bb78383bdb6 : works
build from ccfc9d214703 : works
build from b06a94065ef0 : works
build from 2d849e2d302e : works
build from bddc89a2200c : works
Blocks: 617511
OS: Windows 7 → All

Updated

8 years ago
Component: Tabbed Browser → TabCandy
QA Contact: tabbed.browser → tabcandy
(Reporter)

Updated

8 years ago
Duplicate of this bug: 624116
(Assignee)

Updated

8 years ago
Assignee: nobody → tim.taubert
Status: NEW → ASSIGNED
(Assignee)

Updated

8 years ago
Depends on: 624265
(Assignee)

Updated

8 years ago
Blocks: 598154
(Assignee)

Comment 4

8 years ago
This is fixed when the patch for 624265 lands.

Comment 5

8 years ago
bugspam (moving b9 to b10)
Blocks: 608028

Comment 6

8 years ago
bugspam (removing b9)
No longer blocks: 598154
Bug 624998 is also about messed up tabs. Will 624265 fix that too?
(Assignee)

Comment 8

8 years ago
(In reply to comment #7)
> Bug 624998 is also about messed up tabs. Will 624265 fix that too?

Well, I don't think so. Bug 624998 seems rather like a dupe of bug 616729, isn't it?
(In reply to comment #8)
> Bug 624998 seems rather like a dupe of bug 616729,
> isn't it?

Yes.
blocking2.0: ? → final+
Whiteboard: [softblocker]
(Assignee)

Updated

8 years ago
Status: ASSIGNED → RESOLVED
blocking2.0: final+ → ?
Last Resolved: 8 years ago
Resolution: --- → FIXED
(Assignee)

Comment 10

8 years ago
I'm sorry, I accidently removed the blocking+ :/ Can somebody please reset it to blocking+? Thanks!
blocking2.0: ? → betaN+
(Reporter)

Comment 11

8 years ago
Verified on
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b10pre) Gecko/20110114 Firefox/4.0b10pre ID:20110114030359
Status: RESOLVED → VERIFIED
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.