Make our canvases be moz-opaque

RESOLVED FIXED in Firefox 4.0b10

Status

Firefox Graveyard
Panorama
RESOLVED FIXED
7 years ago
2 years ago

People

(Reporter: mitcho, Assigned: ttaubert)

Tracking

({perf})

Trunk
Firefox 4.0b10
Dependency tree / graph

Details

(Whiteboard: [qa-][good first bug])

Attachments

(1 attachment, 3 obsolete attachments)

According to this page [1] canvas in Mozilla can have the dom attribute "dom-opaque"="true" (bug 430906) and this could speed up their rendering.

[1] https://developer.mozilla.org/En/Firefox_3.5_for_developers

Since, I believe all our tab canvases are always opaque, we should be slapping this on all our canvases.
(Reporter)

Comment 1

7 years ago
(In reply to comment #0)
> According to this page [1] canvas in Mozilla can have the dom attribute
> "dom-opaque"="true" (bug 430906) and this could speed up their rendering.

Whoops! Make that "moz-opaque".
(Assignee)

Updated

7 years ago
Assignee: nobody → tim.taubert
Status: NEW → ASSIGNED
(Assignee)

Comment 2

7 years ago
Created attachment 503289 [details] [diff] [review]
patch v1

Do we need a test for this?
Attachment #503289 - Flags: review?(ian)
Comment on attachment 503289 [details] [diff] [review]
patch v1

Looks good to me, bug I'd also like to hear from roc, for verification that this is a good idea.

No test needed.
Attachment #503289 - Flags: review?(ian)
Attachment #503289 - Flags: review+
Attachment #503289 - Flags: feedback?(roc)
(Assignee)

Updated

7 years ago
Attachment #503289 - Flags: approval2.0?
(Assignee)

Updated

7 years ago
Duplicate of this bug: 626284
Someone approve this! It's an easy win.
Attachment #503289 - Flags: approval2.0? → approval2.0+
(Assignee)

Comment 6

7 years ago
Created attachment 504346 [details] [diff] [review]
patch for checkin
Attachment #503289 - Attachment is obsolete: true
(Assignee)

Updated

7 years ago
Keywords: checkin-needed

Updated

7 years ago
Whiteboard: [qa-][good first bug][perf] → [qa-][good first bug]

Comment 7

7 years ago
http://hg.mozilla.org/mozilla-central/rev/653ad2c5782e
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 4.0b10
(Reporter)

Updated

7 years ago
Blocks: 604213
Should've been moz-opaque='', though.

Updated

7 years ago
Depends on: 626945
(In reply to comment #8)
> Should've been moz-opaque='', though.

Why so? 'true' seems to be working.
(In reply to comment #9)
> (In reply to comment #8)
> > Should've been moz-opaque='', though.
> 
> Why so? 'true' seems to be working.

Right, and when someone wants to revert this, they'll use moz-opaque='false' and have a hard time finding out why that doesn't change anything. See <http://www.whatwg.org/html/#boolean-attributes>.
Agree with Ms2ger on ='true' being bug-bait. But shorter's better, so why not use just moz-opaque (no ='' or =anything)?

/be
(Assignee)

Comment 12

7 years ago
Created attachment 505399 [details] [diff] [review]
patch v2, followup
Attachment #504346 - Attachment is obsolete: true
Attachment #505399 - Flags: review?(ian)
(Assignee)

Updated

7 years ago
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Updated

7 years ago
Version: unspecified → Trunk
Comment on attachment 505399 [details] [diff] [review]
patch v2, followup

(In reply to comment #10)
> (In reply to comment #9)
> > (In reply to comment #8)
> > > Should've been moz-opaque='', though.
> > 
> > Why so? 'true' seems to be working.
> 
> Right, and when someone wants to revert this, they'll use moz-opaque='false'
> and have a hard time finding out why that doesn't change anything. See
> <http://www.whatwg.org/html/#boolean-attributes>.

I see! Thanks for setting us straight!
Attachment #505399 - Flags: review?(ian) → review+
(Assignee)

Updated

7 years ago
Attachment #505399 - Flags: approval2.0?

Updated

7 years ago
Attachment #505399 - Flags: approval2.0? → approval2.0+
(Assignee)

Comment 14

7 years ago
Created attachment 506284 [details] [diff] [review]
patch for checkin
Attachment #505399 - Attachment is obsolete: true
(Assignee)

Updated

7 years ago
Keywords: checkin-needed

Comment 15

7 years ago
http://hg.mozilla.org/mozilla-central/rev/32738fd1cdfb
Status: REOPENED → RESOLVED
Last Resolved: 7 years ago7 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.