Last Comment Bug 624329 - Toolbar's context menus do not render and slide down repeatedly
: Toolbar's context menus do not render and slide down repeatedly
Status: RESOLVED FIXED
[testday-20110930]
: regression
Product: Firefox
Classification: Client Software
Component: Menus (show other bugs)
: Trunk
: All Linux
: -- minor with 1 vote (vote)
: Firefox 8
Assigned To: Karl Tomlinson (:karlt)
:
Mentors:
: 642960 666137 (view as bug list)
Depends on: 672103
Blocks: 642960
  Show dependency treegraph
 
Reported: 2011-01-10 01:00 PST by [:Aleksej]
Modified: 2011-09-30 09:19 PDT (History)
11 users (show)
karlt: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Video of a context menu called at the bottom of the screen (452.58 KB, video/ogg)
2011-01-10 01:00 PST, [:Aleksej]
no flags Details
zh-TW UI context menu glitch 1 (226.31 KB, image/png)
2011-06-18 08:22 PDT, jtmh
no flags Details
zh-TW UI context menu glitch 2 (227.06 KB, image/png)
2011-06-18 08:27 PDT, jtmh
no flags Details
zh-TW UI context menu glitch 3 (227.01 KB, image/png)
2011-06-18 08:30 PDT, jtmh
no flags Details
skip NS_MOVE dispatch on ConfigureNotify on override-redirect windows (6.18 KB, patch)
2011-06-23 17:45 PDT, Karl Tomlinson (:karlt)
roc: review+
Details | Diff | Splinter Review

Description [:Aleksej] 2011-01-10 01:00:09 PST
Created attachment 502435 [details]
Video of a context menu called at the bottom of the screen

Mozilla/5.0 (X11; Linux i686; rv:2.0b9pre) Gecko/20110109 Firefox/4.0b9pre

Regressed between 20100929030647 and 20100930031320.

Tried with the window managers xmonad and xfwm4.

Steps to reproduce:
1. Right-click a toolbar near the right edge of the screen (approximately so that the menu has to be shifted to the left to be displayed).

Actual results:
The menu does not render, but is visible as graphics from the place where it is, sliding down quickly and repeatedly (I can catch a menu coming from the top with a click in the middle of the screen).
Comment 1 Henrik Skupin (:whimboo) 2011-01-10 03:32:28 PST
Can you please post changesets for both builds?
Comment 3 Henrik Skupin (:whimboo) 2011-01-10 05:55:07 PST
Check-ins: http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=a60414d076b5&tochange=5a2012482a63

I think that it is caused by enabling webgl by default. Aleksej, can you please disable webgl and try again? IMO it has been regressed by bug 580405.
Comment 4 [:Aleksej] 2011-01-10 07:52:46 PST
I am using video drivers with no 3D acceleration.

The video card is NV5 (NVIDIA RIVA TNT2 Pro).

The kernel module is nvidiafb, the X.Org driver is "fbdev". But I have first encountered the issue when using the "vesa" driver (no acceleration whatsoever, AFAIK).
Comment 5 Henrik Skupin (:whimboo) 2011-01-10 09:42:49 PST
Joe or Bas, does one of you have an idea?
Comment 6 Joe Drew (not getting mail) 2011-01-10 12:45:26 PST
That is very strange-looking! But I have no ideas :(

It's _very strange_ that the the regression range is something that should only have affected OS X.

Karl, any ideas?
Comment 7 Karl Tomlinson (:karlt) 2011-01-10 23:22:53 PST
I can't see anything in that regression range, but this smells like bug 601545 comment 13.
Comment 8 Henrik Skupin (:whimboo) 2011-01-11 09:41:00 PST
Aleksej, are you using multiple screens? We have bug 624757 which sounds similar.
Comment 9 [:Aleksej] 2011-01-12 00:26:58 PST
Single screen in both cases. For Xfce I started a separate X.Org instance.
Comment 10 jtmh 2011-06-18 07:57:25 PDT
(In reply to comment #0)
> Created attachment 502435 [details]
> Video of a context menu called at the bottom of the screen
> 
> Mozilla/5.0 (X11; Linux i686; rv:2.0b9pre) Gecko/20110109 Firefox/4.0b9pre
> 
> Regressed between 20100929030647 and 20100930031320.
> 
> Tried with the window managers xmonad and xfwm4.
> 
> Steps to reproduce:
> 1. Right-click a toolbar near the right edge of the screen (approximately so
> that the menu has to be shifted to the left to be displayed).
> 
> Actual results:
> The menu does not render, but is visible as graphics from the place where it
> is, sliding down quickly and repeatedly (I can catch a menu coming from the
> top with a click in the middle of the screen).

We (5 users from Taiwan) have exactly the same problem, and seem to have new findings:

1. It happens in (probably not limited to) the Chinese (Traditional) localized version, but *not* in the English (US) version.

2. It happens when right-clicking (near the right edge of the screen, just as described by the original reporter) on the menu bar, the tab bar, the navigation toolbar and the add-on bar, but not on the bookmarks toolbar.

3. It happens not only in Firefox 4, but also in Firefox 5 Beta.

The Linux distros we use range from Ubuntu, Gentoo, Kubuntu to Mandriva. Our discussion thread (in Traditional Chinese) can be found at http://forum.moztw.org/viewtopic.php?f=2&t=32371


My user agent strings of Firefox having the problem are:

Mozilla/5.0 (X11; Linux i686; rv:2.0.1) Gecko/20110518 Firefox/4.0.1
Mozilla/5.0 (X11; Linux i686; rv:5.0) Gecko/20100101 Firefox/5.0

And my graphics info copied from Firefox 7 Nightly (English version) is:

  Adapter Description
  NVIDIA Corporation -- GeForce 6150SE nForce 430/PCI/SSE2/3DNOW!

  Driver Version
  2.1.2 NVIDIA 260.19.36

  WebGL Renderer
  NVIDIA Corporation -- GeForce 6150SE nForce 430/PCI/SSE2/3DNOW! -- 2.1.2 NVIDIA 260.19.36

  GPU Accelerated Windows
  0/1


Finally, I'm using a single screen only, too.
Comment 11 jtmh 2011-06-18 08:22:40 PDT
Created attachment 540242 [details]
zh-TW UI context menu glitch 1

This is a snapshot of Firefox immediately after I right-click on the menu bar near the edge of the screen.
Comment 12 jtmh 2011-06-18 08:27:50 PDT
Created attachment 540243 [details]
zh-TW UI context menu glitch 2

This is a second snapshot of Firefox after I right-click on the menu bar near the edge of the screen. We can see the context menu is half-way to the bottom of the screen.
Comment 13 jtmh 2011-06-18 08:30:21 PDT
Created attachment 540244 [details]
zh-TW UI context menu glitch 3

This is a third snapshot of Firefox after I right-click on the menu bar near the edge of the screen. We can see the context menu is down to the bottom of the screen.
Comment 14 Karl Tomlinson (:karlt) 2011-06-19 20:07:26 PDT
(In reply to comment #10)
> 1. It happens in (probably not limited to) the Chinese (Traditional)
> localized version, but *not* in the English (US) version.

Interesting, thanks jtmh.

> 3. It happens not only in Firefox 4, but also in Firefox 5 Beta.
> 
> The Linux distros we use range from Ubuntu, Gentoo, Kubuntu to Mandriva.

Which window managers are in use when this bug happens?
Comment 15 JackieKu 2011-06-20 09:44:21 PDT
(In reply to comment #14)
> > 1. It happens in (probably not limited to) the Chinese (Traditional)
> > localized version, but *not* in the English (US) version.
> 
> Interesting, thanks jtmh.

I can confirm it by disabling zh-TW language pack.

> Which window managers are in use when this bug happens?

I'm using kwin 4.6.3 (but 4.4.5 has the same behavior which I used before). Disable/enable desktop compositing seems to have no difference.
Comment 16 jtmh 2011-06-20 13:20:52 PDT
(In reply to comment #14)
> (In reply to comment #10)
> > 3. It happens not only in Firefox 4, but also in Firefox 5 Beta.
> > 
> > The Linux distros we use range from Ubuntu, Gentoo, Kubuntu to Mandriva.
> 
> Which window managers are in use when this bug happens?

I used kwin 4.4.5 on Mandriva, and am using kwin 4.6.3 on Mageia now.
Comment 17 Karl Tomlinson (:karlt) 2011-06-22 02:57:28 PDT
*** Bug 666137 has been marked as a duplicate of this bug. ***
Comment 18 Jinkyu Yi[:jincreator] 2011-06-22 05:14:22 PDT
I'm using Ubuntu with Korean localized version and get this bug.
But suprisingly, Firefox at Ubuntu repository does not have this bug.
Are developers at Canonical know the solution of this bug?
Comment 19 Karl Tomlinson (:karlt) 2011-06-22 15:48:50 PDT
Thanks, Jinkyu.  Does the context menu look different with the Ubuntu Firefox, such as having additional or different entries?  Which version is the Ubuntu Firefox?
Comment 20 Jinkyu Yi[:jincreator] 2011-06-22 19:20:46 PDT
No, it's same with offical Firefox.
I'm using Firefox 5(5.0 Mozilla Firefox for Ubuntu).
Maybe you can get source code at Launchpad.
https://launchpad.net/ubuntu/natty/+source/firefox/5.0+build1+nobinonly-0ubuntu0.11.04.1

One more thing, this bug is still happening at Kubuntu even installed from Ubuntu repository. Kubuntu 11.04 + Firefox 5(from Ubuntu repository) user report it.
Comment 21 Karl Tomlinson (:karlt) 2011-06-23 17:45:10 PDT
Created attachment 541561 [details] [diff] [review]
skip NS_MOVE dispatch on ConfigureNotify on override-redirect windows
Comment 22 Karl Tomlinson (:karlt) 2011-06-23 22:27:49 PDT
Comment on attachment 541561 [details] [diff] [review]
skip NS_MOVE dispatch on ConfigureNotify on override-redirect windows

This is a major flaw that I'd like to see fixed ASAP so I've gone for a pretty
minimal solution (which is code I had from working on bug 601545).  The full
solution would be to ensure that nsXULPopupManager::PopupMoved doesn't respond
to NS_MOVE events by moving the window again, but that's a fairly major job,
and is further complicated by the awkwardness of how noautohide titlebar
windows currently "work".

The only change not documented in the patch is the mBounds.x/y == aEvent.x/y
shortcut, which is nonsense because it compares coordinates meant to be
different.

NS_MOVE wasn't used before bug 552982 so there is little to lose from not
dispatching it for override-redirect windows.
Comment 23 Robert O'Callahan (:roc) (Exited; email my personal email if necessary) 2011-06-23 22:51:16 PDT
Comment on attachment 541561 [details] [diff] [review]
skip NS_MOVE dispatch on ConfigureNotify on override-redirect windows

Review of attachment 541561 [details] [diff] [review]:
-----------------------------------------------------------------
Comment 26 Karl Tomlinson (:karlt) 2011-07-11 15:17:54 PDT
*** Bug 642960 has been marked as a duplicate of this bug. ***
Comment 27 [:jesup] on pto until 2016/8/1 Randell Jesup 2011-07-17 07:19:00 PDT
Apparent regression: bug 672103
Menus and context menus don't appear - host Ubuntu 8.04, display over remote X to cygwin running startxwin.sh
Comment 28 [:Aleksej] 2011-09-30 09:10:17 PDT
I haven’t seen the issue for some time, but I see with 8.0b1 that, when opening the menu, the Panorama icon appears for a moment about two sizes to the left of its normal location.
Comment 29 [:Aleksej] 2011-09-30 09:19:07 PDT
As for the bug itself, of
7.0b6 eo, ru
8.0b1 en-US, eo, ru
I can reproduce it only with 7.0b6 eo.

Note You need to log in before you can comment on or make changes to this bug.