Update check for default mailer to work the new way (glib >= 2.27.1)

RESOLVED FIXED in Thunderbird 6.0

Status

defect
RESOLVED FIXED
9 years ago
8 years ago

People

(Reporter: vuntz, Assigned: chrisccoulson)

Tracking

Trunk
Thunderbird 6.0
All
Linux
Dependency tree / graph

Firefox Tracking Flags

(blocking-thunderbird5.0 -)

Details

Attachments

(1 attachment)

Reporter

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; fr-fr) AppleWebKit/534.7+ (KHTML, like Gecko) Version/5.0 Safari/534.7+ SUSE/11.4 (2.30.6-97.5) Epiphany/2.30.6
Build Identifier: 

I assume Thunderbird checks if it's the default mail application on start, in the same way Firefox does for the default browser application. This means that most of bug 624338 is valid for Thunderbird too, although.

Starting with glib 2.27.1, the way for an app to declare that it supports opening a URI scheme has changed: it used to be something living in gconf, and now we use the mime system with a mime type like x-scheme-handler/mailto. The old way doesn't work anymore.

glib 2.27/2.28 will be used in all distributions releasing in spring 2011.

See https://bugzilla.gnome.org/show_bug.cgi?id=631433 and the first part of http://www.hadess.net/2010/10/new-control-center-and-you.html for some more background.

Bug 624338 contains detailed steps based on the Firefox code to fix this. I haven't looked at the Thunderbird code, though, so I can't give the same detailed steps, but it should be straight-forward for anyone knowing the code.

Reproducible: Always
Status: UNCONFIRMED → NEW
Ever confirmed: true
Hardware: x86 → All
Version: unspecified → Trunk
Would be nice to have this for 3.3 - so nominating blocker.
blocking-thunderbird5.0: --- → ?
Depends on: 624530
Assignee

Updated

8 years ago
Assignee: nobody → chrisccoulson
Assignee

Updated

8 years ago
Depends on: 611953
No longer depends on: 624530
Assignee

Comment 2

8 years ago
Here is a patch which fixes this (note, that it depends on bug 611953 too)
Attachment #518449 - Flags: review?(mkmelin+mozilla)
Comment on attachment 518449 [details] [diff] [review]
Use GIO for the default mail handler check

Standard8 might be a better reviewer for this.
Attachment #518449 - Flags: review?(mkmelin+mozilla) → review?(bugzilla)
The core changes in bug 611953 missed Aurora for FF 5 where we're intending on release Miramar from, therefore we'll have to wait for these changes until the next release. I'll try and review the patch in a few days though.
blocking-thunderbird5.0: ? → -
Whiteboard: [tbnext+]
Chris, is there a way to test this on ubuntu 11.04? 

I'm trying with and without the patch and I'm not really seeing any difference...
Comment on attachment 518449 [details] [diff] [review]
Use GIO for the default mail handler check

Review of attachment 518449 [details] [diff] [review]:
-----------------------------------------------------------------

Sorry this has taken so long to do. It looks fine now I've been able to test it and go through it in detail. r=Standard8.
Attachment #518449 - Flags: review?(mbanner) → review+
Keywords: checkin-needed
Whiteboard: [tbnext+]
Checked in: http://hg.mozilla.org/comm-central/rev/dfd0157bf4cf
Status: NEW → RESOLVED
Closed: 8 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 3.4
Duplicate of this bug: 659918
You need to log in before you can comment on or make changes to this bug.