Gmail / IMAP: Deleting a message from Thunderbird’s TRASH is only synced to [Gmail]/Trash after compacting Thunderbird’s TRASH

RESOLVED INVALID

Status

Thunderbird
General
RESOLVED INVALID
8 years ago
6 years ago

People

(Reporter: dfghjkjhg, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:2.0b9pre) Gecko/20110106 Firefox/4.0b9pre
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b9pre) Gecko/20110110 Thunderbird/3.3a2pre

Gmail / IMAP:

Deleting a message from Thunderbird’s TRASH is only synced to [Gmail]/Trash AFTER COMPACTING Thunderbird’s TRASH.
There’s no immediate Sync of the deletion from TB’s Trash to [Gmail]/Trash without compacting TB’s Trash.
Without compacting TB’s Trash, TB’s Trash and Gmail’s Webinferface Trash are asynchronous.

Problem only occurs with [Gmail]/Trash.
Cannot reproduce with other folders.

Reproducible: Always

Steps to Reproduce:
1. Delete a message from [Gmail]/Inbox by Thunderbird via Gmail IMAP.
2. Look into Gmail’s Webinterface Inbox: The message has been deleted as expected. So that Sync works well.
3. Open [Gmail]/Trash by Thunderbird via Gmail IMAP and delete that message.
4. Look into Gmail’s Webinterface Trash: The message is still there and has not been deleted.
Thus at this moment Thunderbird and Gmail are asynchronous.
5. Now compact Thunderbird’s Trash folder (--> right-click on TB’s trash --> chose “compact”).
6. Look into Gmail’s Webinterface Trash: Now the message has gone.


Expected Results:  
As soon as a message is deleted from [Gmail]/Trash by Thunderbird via Gmail IMAP,
this should immediately be synced to Gmail – not only after compacting TB’s Trash.
It's by design of IMAP and design/implementation of Gmail.

- Delete a mail in IMAP folder ==
  uid xxx copy [Gmail]/Trash  +  uid xxx store Flag \Deleted,
  if "move to trash" model.
  - When \Deleted flag is stored, 
    - Gmail IMAP keeps \Deleted flag if [Gmail]/Trash or [Gmail]/Spam.
    - Gmail IMAP does do nothing if [Gmail]/All Mail.
    - Gmail IMAP automatically executes expunge for folder
      other than [Gmail]/All Mail, [Gmail]/Trash, ang [Gmail]/Spam,
      if auto-expunging of Gmail IMAP is not disabled.
  - If a mail is copied or moved to [Gmail]/Trash, all Gmail Label added to
    a mail(=IMAP folder name) is removed from the mail.
- Compact of IMAP folder == expunge.
  \Deleted flag is IMAP only attribute of a mail.
  So, mail flagged as \Deleted in [Gmal]/Trash(Trash of Gmail Web)
  is shown as active mail at Web Interface.
You can see above with "Just mark it as deleted" model.

From perspective of IMAP, phenomenon on [Gmail]/Trash is normal, and [Gmail]/Trash is correctly sync'ed.
Please don't confuse it with special phenomenon on Inbox(and other ordinal folder=Gmail Label) due to auto-expunging of Gmail. Inbox case can be called "sync'ed twice", after store of \Deleted flag, and after auto-expunging.

If you want immediate auto-expunging of [Gmail]/Trash, please ask Google instead of mozilla foundation.
Currently, Gmail automatically expunges a mail from [Gmail]/Trash after 30 days, regardless of \Deleted flag.

Comment 2

7 years ago
(In reply to WADA from comment #1)
> If you want immediate auto-expunging of [Gmail]/Trash, please ask Google
> instead of mozilla foundation.
> Currently, Gmail automatically expunges a mail from [Gmail]/Trash after 30
> days, regardless of \Deleted flag.

so this bug is invalid?
This is duplicate of bug 780157

I agree that this is as designed / invalid.

Updated

6 years ago
Duplicate of this bug: 780157

Comment 5

6 years ago
per comment 3
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.