Closed Bug 624691 Opened 11 years ago Closed 2 years ago

[Maemo-only] 'Open' button is disabled for downloaded files with .deb, .install and .pdf extension

Categories

(Firefox for Android Graveyard :: General, defect)

ARM
Maemo
defect
Not set
normal

Tracking

(fennec-)

RESOLVED WONTFIX
Tracking Status
fennec - ---

People

(Reporter: ahoza, Unassigned)

References

Details

(Keywords: regression)

Attachments

(1 file)

Attached image Screenshot
BuildID: Mozilla /5.0 (Maemo;Linux armv7l;rv:2.0b9pre)Gecko/20110111 Firefox/4.0b9pre Fennec /4.0b4pre 
Device: Nokia N900.

Steps to reproduce:

1. Download a .deb file from http://ftp.mozilla.org/pub/mozilla.org/mobile/nightly/latest-mozilla-central-maemo5-gtk/
2. Download a .pdf file
3. Open Download manager and select previously downloaded items.

Expected results:
'Open' is enabled and files can be opened directly from Download Manager.

Actual results:
'Open' is disabled.  

Note: This is not reproducible with Android for .apk files
Keywords: regression
tracking-fennec: --- → ?
tracking-fennec: ? → 2.0-
Duplicate of this bug: 635266
Duplicate of this bug: 635271
This is also happening with .install files as well.
Summary: 'Open' button is disabled for downloaded files with .deb and .pdf extension → 'Open' button is disabled for downloaded files with .deb, .install and .pdf extension
tracking-fennec: 2.0- → ?
Sorry, I'm re-nominating at the scope of this bug now extends to a platform specific filetype (i.e. .install) that should be handled.
Summary: 'Open' button is disabled for downloaded files with .deb, .install and .pdf extension → [Maemo-only] 'Open' button is disabled for downloaded files with .deb, .install and .pdf extension
tracking-fennec: ? → 2.0-
See also bug 610785 (similar bug on Android).
See Also: → 610785
Closing all opened bug in a graveyard component
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.