Last Comment Bug 624740 - Alerts service shouldn't use nsDependentString to convert an nsAString to an nsString
: Alerts service shouldn't use nsDependentString to convert an nsAString to an ...
Status: RESOLVED FIXED
[good first bug][mentor=jdm]
:
Product: Core
Classification: Components
Component: IPC (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla8
Assigned To: Edgar Flores
:
Mentors:
http://mxr.mozilla.org/mozilla-centra...
Depends on:
Blocks: 596498 624738
  Show dependency treegraph
 
Reported: 2011-01-11 08:31 PST by neil@parkwaycc.co.uk
Modified: 2011-08-09 11:52 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
per suggestion changed nsDependentString to PromiseFlatString (1.86 KB, patch)
2011-08-06 00:01 PDT, Edgar Flores
neil: review+
Details | Diff | Splinter Review

Description neil@parkwaycc.co.uk 2011-01-11 08:31:17 PST
It also uses nsAutoString as a conversion, which is probably overkill; nsString or possibly PromiseFlatString should work, depending on how the string is used.
Comment 1 Josh Matthews [:jdm] 2011-04-10 11:31:49 PDT
The relevant code is here:

http://mxr.mozilla.org/mozilla-central/source/toolkit/components/alerts/nsAlertsService.cpp#87

I think using PromiseFlatString should be fine here, since the data just ends up being copied into another nsString inside the AlertObserver constructor.
Comment 2 Edgar Flores 2011-08-06 00:01:16 PDT
Created attachment 551235 [details] [diff] [review]
per suggestion changed nsDependentString to PromiseFlatString
Comment 3 Edgar Flores 2011-08-06 00:30:32 PDT
I have a question. How are reviewers found? Is there a list for a specific section of the repository?
Comment 4 neil@parkwaycc.co.uk 2011-08-06 13:07:54 PDT
Comment on attachment 551235 [details] [diff] [review]
per suggestion changed nsDependentString to PromiseFlatString

Mossop said that I could review this.

Note You need to log in before you can comment on or make changes to this bug.