Note: There are a few cases of duplicates in user autocompletion which are being worked on.

Cannot close tab group if it has certain size because "rename" field pops up and overlays close button

VERIFIED FIXED

Status

Firefox Graveyard
Panorama
P3
normal
VERIFIED FIXED
7 years ago
a year ago

People

(Reporter: florian.neubauer.neuroscience, Assigned: raymondlee)

Tracking

Details

(Whiteboard: [ux][polish][good first bug])

Attachments

(2 attachments, 2 obsolete attachments)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0b8) Gecko/20100101 Firefox/4.0b8
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0b8) Gecko/20100101 Firefox/4.0b8

When a tab group in panorama has a certain size, and you try to close it using the "x" close button, moving the mouse over the close button makes the "rename" field pop up and overlay the close button. Result: You cannot close the group.

Reproducible: Always

Steps to Reproduce:
1. Play with tab group size.
2. Try to close the group.
3. The "rename" field will prevent you from doing so.
Actual Results:  
Rename field has focus and you cannot click the close button.

Expected Results:  
Rename field would respect = not overlay the close button.
(Reporter)

Comment 1

7 years ago
Created attachment 503006 [details]
shows example size for bug - screen res was 1280x1024

Comment 2

7 years ago
Opps.
Blocks: 585689
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P2
Moving to beta 11. Would be great to get a patch for this.
Blocks: 627096
No longer blocks: 585689
Whiteboard: [ux][polish][good first bug]
Depends on: 589132
Priority: P2 → P3
(Assignee)

Comment 4

7 years ago
Created attachment 510522 [details] [diff] [review]
v1

http://tbpl.mozilla.org/?tree=MozillaTry&rev=23ec9ed0bfb0

Builds and logs will be available at http://ftp.mozilla.org/pub/mozilla.org/firefox/tryserver-builds/raymond@raysquare.com-23ec9ed0bfb0
Assignee: nobody → raymond
Status: NEW → ASSIGNED
Attachment #510522 - Flags: review?(ian)
(Assignee)

Comment 5

7 years ago
Tested the builds on Mac, Windows XP and Ubuntu, all work fine.
Comment on attachment 510522 [details] [diff] [review]
v1

This works. f+

+ Gavin for quick review while Ian is out.
Attachment #510522 - Flags: review?(gavin.sharp)
Attachment #510522 - Flags: feedback+
Is there no more efficient selector you can use (avoiding the descendant selector?). Where is this DOM constructed in the code?
(In reply to comment #7)
> Is there no more efficient selector you can use (avoiding the descendant
> selector?).

Right now we're also using .close for the tab close button. We could change them to be .tabClose and .groupClose, for example... do you think that's a worthwhile change?

> Where is this DOM constructed in the code?

http://hg.mozilla.org/mozilla-central/file/tip/browser/base/content/tabview/groupitems.js#l156
Comment on attachment 510522 [details] [diff] [review]
v1

Looks good to me. I look forward to Gavin's response.
Attachment #510522 - Flags: review?(ian) → review+
Gavin, any additional comments on the new patch?
Comment on attachment 510522 [details] [diff] [review]
v1

Let's land this
Attachment #510522 - Flags: review?(gavin.sharp)
(Assignee)

Updated

7 years ago
Attachment #510522 - Flags: approval2.0?
Comment on attachment 510522 [details] [diff] [review]
v1

a=beltzner, simple CSS fix
Attachment #510522 - Flags: approval2.0? → approval2.0+
(Assignee)

Comment 13

7 years ago
Created attachment 513168 [details] [diff] [review]
Patch for check-in
Attachment #510522 - Attachment is obsolete: true
(Assignee)

Updated

7 years ago
Keywords: checkin-needed
This no longer applies cleanly.
Keywords: checkin-needed
Duplicate of this bug: 634998
(Assignee)

Comment 16

7 years ago
Created attachment 513219 [details] [diff] [review]
Patch for check-in

This should be applied cleanly.
Attachment #513168 - Attachment is obsolete: true
(Assignee)

Updated

7 years ago
Keywords: checkin-needed
http://hg.mozilla.org/mozilla-central/rev/400b242a925b
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Keywords: checkin-needed
Resolution: --- → FIXED

Comment 18

7 years ago
Mozilla/5.0 (Windows NT 5.1; rv:2.0b12pre) Gecko/20110220 Firefox/4.0b12pre

Close button accessible when hovering with mouse. Issue verified with latest trunk.
Status: RESOLVED → VERIFIED
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.