Last Comment Bug 625322 - Reorder some items in the History menu
: Reorder some items in the History menu
Status: VERIFIED FIXED
: user-doc-needed, ux-consistency
Product: Firefox
Classification: Client Software
Component: Menus (show other bugs)
: unspecified
: All All
: -- normal with 1 vote (vote)
: Firefox 6
Assigned To: Steffen Wilberg
:
Mentors:
: 592887 (view as bug list)
Depends on:
Blocks: 607226
  Show dependency treegraph
 
Reported: 2011-01-13 03:00 PST by Alex Faaborg [:faaborg] (Firefox UX)
Modified: 2011-06-26 11:37 PDT (History)
11 users (show)
hskupin: in‑litmus?
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (3.75 KB, patch)
2011-02-12 08:37 PST, Steffen Wilberg
dao+bmo: review+
Details | Diff | Review

Description Alex Faaborg [:faaborg] (Firefox UX) 2011-01-13 03:00:44 PST
For consistency with the organization of the Firefox button, the traditional history menu should be slightly reorganized on all platforms:

Show All History
--------------------
Restore Previous Session
Recently Closed Tabs
Recently Closed Windows
--------------------
[user's history items, increased to 15 up from 10]

Back / forward / home will no longer be displayed due to bug 607224, and tabs from other computers is being removed in bug 611571
Comment 1 Alex Faaborg [:faaborg] (Firefox UX) 2011-01-24 11:25:59 PST
The UX team is very eager to get this bug landed over the next few days in order to make Beta 11.  If anyone can get a patch for this bug posted soon, we will push hard for reviews and approval (even though this isn't blocking).

You can view all of the related bugs to clean up the traditional menu bar here: http://areweprettyyet.com/4/traditionalMenu/
Comment 2 :Gavin Sharp [email: gavin@gavinsharp.com] 2011-01-24 23:37:03 PST
This looks pretty closely related to bug 592887...
Comment 3 Steffen Wilberg 2011-02-05 13:44:08 PST
Faaborg, please post a complete ASCII art including Back/Forward/Home, since these appear when the menu is invoked with the keyboard, and also including "Tabs from other computers", since moving that is held back by bug 597308 (Add a keyboard shortcut for All Tabs).

From AWPY, I assume "Clear Recent History" remains in the Tools menu.
Comment 4 Alex Faaborg [:faaborg] (Firefox UX) 2011-02-08 16:35:20 PST
When invoked from the keyboard:

Back
Forward
Home
--------------------
Show All History
--------------------
[Tabs from Other Computers] - if we have to keep it
Restore Previous Session
Recently Closed Tabs
Recently Closed Windows
--------------------
[user's history items, increased to 15 up from 10]
Comment 5 Steffen Wilberg 2011-02-12 08:37:37 PST
Created attachment 511961 [details] [diff] [review]
patch
Comment 6 Steffen Wilberg 2011-04-25 04:55:57 PDT
Dao, this is waiting for review since February 12. Should I ask someone else?
Comment 7 Jim Jeffery not reading bug-mail 1/2/11 2011-04-30 14:30:01 PDT
Wait!  Your removing the 'Clear Recent History' item from the list ?  That leaves the user with the only option is to enter Options, select the Privacy Tab then clear 'Recent History'.  

That menu item should remain for quick access for those that don't use Private Browsing, but still want to clear their Recent History.

For those that have the Menubar hidden, pressing Alt->Tools is not much better than opening the Options panel as stated above.
Comment 8 Steffen Wilberg 2011-04-30 14:38:01 PDT
Jim, this patch is about the traditional menubar, where "Clear Recent History" was and still is located in the Tools menu.

It doesn't touch the Firefox button-menu either, which still has "Clear Recent History" in its History sub-menu.
Comment 10 Henrik Skupin (:whimboo) 2011-05-02 01:17:45 PDT
Verified fixed with Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:6.0a1) Gecko/20110501 Firefox/6.0a1

The Litmus test will be updated once we have a branch for Firefox 6.
Comment 11 [not reading bugmail] 2011-05-02 08:29:51 PDT
(In reply to comment #8)
> Jim, this patch is about the traditional menubar, where "Clear Recent History"
> was and still is located in the Tools menu.
> 
> It doesn't touch the Firefox button-menu either, which still has "Clear Recent
> History" in its History sub-menu.

Filed bug 631805 for this.
Comment 12 Steffen Wilberg 2011-05-02 08:39:16 PDT
*** Bug 592887 has been marked as a duplicate of this bug. ***
Comment 13 Simona B [:simonab](PTO) 2011-05-06 05:14:50 PDT
(In reply to comment #0)
> Back / forward / home will no longer be displayed due to bug 607224, and
> tabs from other computers is being removed in bug 611571

Logged bug 655237 as the options are still showing in Mac.

Note You need to log in before you can comment on or make changes to this bug.