Dropping a tab onto the "undo close group" dialog adds the tab to that group

VERIFIED FIXED

Status

defect
P2
normal
VERIFIED FIXED
8 years ago
3 years ago

People

(Reporter: khanes, Assigned: ttaubert)

Tracking

Firefox Tracking Flags

(blocking2.0 -)

Details

(Whiteboard: [ux])

Attachments

(1 attachment, 3 obsolete attachments)

(Reporter)

Description

8 years ago
- face palm -

Note that this tab goes away when the group gets deleted.
blocking2.0: --- → ?
I am not able to reproduce this on Mac OSX.  Does this happen in other platforms or I miss something?
I can reproduce now.  Just need to put the tab on top of the "undo close group" and wait until the "undo close group" gets removed automatically.
Don't think that's gonna be a common user interaction, doesn't really cause dataloss.
blocking2.0: ? → -
(In reply to comment #3)
> Don't think that's gonna be a common user interaction, doesn't really cause
> dataloss.

Well, the thing is, you just need to drop the tab near the "undo close group" button... It's certainly possible to do by accident, and it does result in the tab being killed.
(Assignee)

Updated

8 years ago
Assignee: nobody → tim.taubert
Status: NEW → ASSIGNED
Posted patch patch v1 (obsolete) — Splinter Review
Pushed to try.
Attachment #504965 - Flags: review?(ian)
Passed try!
Blocks: 627096
No longer blocks: 585689
Whiteboard: [ux]
Comment on attachment 504965 [details] [diff] [review]
patch v1

Beautiful
Attachment #504965 - Flags: review?(ian) → review+
(Assignee)

Updated

8 years ago
Attachment #504965 - Flags: approval2.0?
Comment on attachment 504965 [details] [diff] [review]
patch v1

a=beltzner, thanks for the tests!
Attachment #504965 - Flags: approval2.0? → approval2.0+
Posted patch patch for checkin (obsolete) — Splinter Review
Attachment #504965 - Attachment is obsolete: true
(Assignee)

Updated

8 years ago
Keywords: checkin-needed
http://hg.mozilla.org/mozilla-central/rev/8cfa54285e34
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Backed out: http://hg.mozilla.org/mozilla-central/rev/5a0f46c26d12

Causes orange on windows.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Posted patch patch v2 (obsolete) — Splinter Review
Restructured the test and sent to try.
Attachment #506881 - Attachment is obsolete: true
Attachment #507218 - Flags: review?(ian)
Comment on attachment 507218 [details] [diff] [review]
patch v2

Looks good to me, assuming try likes it.
Attachment #507218 - Flags: review?(ian) → review+
Passed try.
(Assignee)

Updated

8 years ago
Attachment #507218 - Flags: approval2.0?
How did this break before when it landed on mozilla-central after it passed try?  How are we confident that that won't happen again?
Comment on attachment 507218 [details] [diff] [review]
patch v2

a=beltzner
Attachment #507218 - Flags: approval2.0? → approval2.0+
(In reply to comment #16)
> a=beltzner
comment 15?
(In reply to comment #15)
> How did this break before when it landed on mozilla-central after it passed
> try?  How are we confident that that won't happen again?

I believe the test failed because it simulates dragging a tabItem onto a closed group and the group size and position can be affected by previous tests. I modified the test to run in a new window with a clean tabview setup so that the position and size of the groups are not changed by previous tests.
Attachment #507218 - Attachment is obsolete: true
(Assignee)

Updated

8 years ago
Keywords: checkin-needed

Comment 21

8 years ago
Is that mean fixed?
Verified that this is fixed on trunk. Filed a follow up, though: bug 603789.
Status: REOPENED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → FIXED
with nightly build of minefield: 

dropping a tab on an "undo close group" doesn't put it in that group. However if you wait several seconds, the undo close group disappears.  unexpected data loss.  Is that part of any follow ups?
(In reply to comment #23)
> dropping a tab on an "undo close group" doesn't put it in that group. However
> if you wait several seconds, the undo close group disappears.  unexpected data
> loss.  Is that part of any follow ups?

This is expected behavior. Closing groups cannot be undone after waiting 15s. Feel free to open a new bug if you think that should be discussed again :)
verified with minefield build of 20110217
Status: RESOLVED → VERIFIED
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.