[Meta] Panorama bugs for Fx5

RESOLVED FIXED

Status

Firefox Graveyard
Panorama
P3
normal
RESOLVED FIXED
7 years ago
a year ago

People

(Reporter: aza, Unassigned)

Tracking

Details

(Reporter)

Description

7 years ago
Just a holding area for the things we know we want soon, but not for FF 4.
(Reporter)

Updated

7 years ago
Blocks: 588217
(Reporter)

Updated

7 years ago
Priority: -- → P3

Updated

7 years ago
Duplicate of this bug: 606257

Updated

7 years ago
No longer blocks: 588217
Depends on: 588217, 578512

Comment 2

7 years ago
Nominating:

Compositing using OpenGL on Linux? Bug 594876

Complete support for HTML5 forms (or at least very close to 100 %)? Bug 344614

Comment 3

7 years ago
(In reply to comment #2)
> Nominating:
> 
> Compositing using OpenGL on Linux? Bug 594876
> 
> Complete support for HTML5 forms (or at least very close to 100 %)? Bug 344614

Opps, sorry Lars, this bug is for Panorama, specifically. Updating the Title
Summary: [Meta] Features and Fixes We Want "Soon" after Firefox 4 → [Meta] Panorama Features and Fixes We Want "Soon" after Firefox 4
There are much more Panorama feature that is wanted but cannot be complete due to feature freeze and other concerns. I found some of the future bugs.

Nominating : 

Bug 590488, bug 587676, bug 593388, bug 588032, bug 590251, bug 592179, Bug 591771,  Bug 594995, Bug 588058, Bug 589336, Bug 587440 and Bug 586556. 

Hopefully I have found them all and nominated in this comment. But if I find more future bugs, I will nominate them here again.
Sorry found some more additional Future panorama bugs... 

Bug 607383, Bug 624149 ,Bug 620624, Bug 592545, Bug 588899, Bug 588217, Bug 588771, Bug 587874, Bug 577322, Bug 583414, Bug 592874, Bug 604072, Bug 608916, Bug 566754, Bug 577624, Bug 588162, Bug 592932, Bug 594009, Bug 604963, Bug 597767, Bug 590470, Bug 594441, Bug 593938, Bug 593446, Bug 592885, Bug 591775, Bug 590297, Bug 589465, Bug 589401, bug 588849, bug 588110, Bug 587561, bug 578678, bug 611194, bug 587493, bug 587466, bug 600893, Bug 579815, Bug 583435, Bug 587077, Bug 587083, Bug 594434, Bug 568908, Bug 576409, Bug 587010, Bug 593120, Bug 596450, Bug 604916, Bug 586347, Bug 588593, Bug 593283, Bug 595402, Bug 597258, Bug 597324, Bug 604913, Bug 605537, Bug 576427, Bug 599048, Bug 576789, Bug 586355, Bug 587250, Bug 592897, Bug 596504 and Bug 599872 


seems like a long list. and thus this shows that everyone is excited about Panorama.
Depends on: 624720
Is there a post Firefox 4 meta bug filed yet? I want to add some blockers.
This is the post-fx4 meta bug.(In reply to comment #6)
> Is there a post Firefox 4 meta bug filed yet? I want to add some blockers.

This *is* the post-fx4 meta bug. There's no notion of "blocker" for this future release yet, though. Feel free to add dependencies to this bug, for the time being.
how do you add dependencies to this bug, when you are not a reporter to this bug? 

sorry i still don't quite understand how to use bugzilla yet. Sorry.
(In reply to comment #8)
> how do you add dependencies to this bug, when you are not a reporter to this
> bug?

You should be able to edit the "depends on" field above. It takes a comma-separated list of bug id numbers.
Depends on: 625711
Depends on: 621873
No longer depends on: 621873
No longer depends on: 625711
the problem is I can't... and I don't know why.
(In reply to comment #10)
> the problem is I can't... and I don't know why.

I believe only certain people have permissions to add dependencies to bugs. What you've done already - adding a list of bugs in the comments - is great... we'll triage them and add dependencies as appropriate once Fx4 ships. Thank you!
No problem... I am glad I can help you... that will make your job a little bit easier. Hopefully Panorama will be the feature that make Firefox unique and make users think that with Panorama in Firefox now, it is better than the rest of the other browsers.

Updated

7 years ago
Depends on: 610208
Depends on: 630081
Depends on: 630123
Depends on: 630165
Depends on: 595601
Depends on: 631593
Depends on: 631385
Depends on: 630792
Depends on: 585672
Depends on: 632293
Depends on: 632294
Depends on: 589132
Depends on: 589665
Depends on: 590378
Depends on: 591699
Depends on: 598599
Depends on: 627239
Depends on: 628653
Depends on: 616976
Depends on: 616677
Depends on: 623440

Updated

7 years ago
Depends on: 617454
Depends on: 627237
Depends on: 633389
Depends on: 633392
Depends on: 635744
Depends on: 587276
Depends on: 626666
Depends on: 633190
Depends on: 633765
Depends on: 634574
Depends on: 635323
Depends on: 608407
Depends on: 626976
Depends on: 633816
Depends on: 636691
Depends on: 590470
Depends on: 590488
Depends on: 633308

Updated

6 years ago
No longer depends on: 590470

Updated

6 years ago
No longer depends on: 590488

Updated

6 years ago
No longer depends on: 633392

Updated

6 years ago
Depends on: 576409

Updated

6 years ago
Depends on: 590251

Updated

6 years ago
Depends on: 637840
Depends on: 640765

Updated

6 years ago
Depends on: 640062
bugspam

Updated

6 years ago
Blocks: 640594
Depends on: 645964

Comment 14

6 years ago
Renaming to reflect current timeline goals.
Summary: [Meta] Panorama Features and Fixes We Want "Soon" after Firefox 4 → [Meta] Panorama bugs for Fx5

Updated

6 years ago
No longer blocks: 640594
Depends on: 640594

Updated

6 years ago
Depends on: 643392

Updated

6 years ago
Depends on: 644724

Updated

6 years ago
Depends on: 626594

Updated

6 years ago
Blocks: 640592

Updated

6 years ago
Depends on: 621795

Updated

6 years ago
Depends on: 640602

Updated

6 years ago
Depends on: 646813

Updated

6 years ago
Depends on: 645461

Updated

6 years ago
Depends on: 646072

Updated

6 years ago
Blocks: 643293

Updated

6 years ago
Depends on: 646862

Updated

6 years ago
No longer blocks: 643293
Depends on: 643293

Updated

6 years ago
Depends on: 644584

Updated

6 years ago
Depends on: 646523

Updated

6 years ago
Depends on: 645653

Updated

6 years ago
Depends on: 645371
Depends on: 596833
Depends on: 595020
Depends on: 600665

Updated

6 years ago
Depends on: 647962
Depends on: 648294

Updated

6 years ago
Depends on: 649316

Updated

6 years ago
Depends on: 649319

Updated

6 years ago
No longer depends on: 647962

Updated

6 years ago
Depends on: 651311

Updated

6 years ago
Depends on: 650010

Updated

6 years ago
Depends on: 651440
Depends on: 650573
Depends on: 649979
Depends on: 648859
No longer blocks: 640592
Depends on: 640592
bug spam
bug spam
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Depends on: 648294
bug spam
No longer depends on: 640062, 643293, 644584, 651311
(Assignee)

Updated

a year ago
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.