Menu bar bookmarks menu not correctly sized

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
8 years ago
7 months ago

People

(Reporter: betheking, Unassigned)

Tracking

unspecified
x86_64
Windows Vista
Points:
---

Firefox Tracking Flags

(blocking2.0 -)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.0; WOW64; rv:2.0b10pre) Gecko/20110121 Firefox/4.0b10pre
Build Identifier: Mozilla/5.0 (Windows NT 6.0; WOW64; rv:2.0b10pre) Gecko/20110121 Firefox/4.0b10pre

When using the bookmarks menu in the "old" menu bar, the menu isn't correctly sized and re-sized. Some items are needlessly truncated, so that "Bookmark This Page" reads "Bookmark This Pa..." and "Show All Bookmarks" reads "Show All Bookma...".

If you then add a bookmark (in the "menu root"), rather than increasing the height of the menu, up/down scroll arrows are added. Or, if the menu was large enough to show all bookmarks and you delete one, there's now an empty row at the end of the menu.

The bookmarks menu off the new titlebar button doesn't seem to be affected.

This happens with a fresh profile.

The nightly build from 2011-01-17 mostly works (2011-01-18 doesn't), but the bad behavior can be still be triggered by deleting a bookmark via the right-click menu in the bookmarks menu. After doing that, menu items are truncated and scroll arrows are added when new bookmark entries are added.

Reproducible: Always

Comment 1

8 years ago
confirmed
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b10pre) Gecko/20110121 Firefox/4.0b10pre ID:20110121030329
Status: UNCONFIRMED → NEW
blocking2.0: --- → ?
Ever confirmed: true
(Reporter)

Comment 2

8 years ago
The problem starts with this build:
http://hg.mozilla.org/mozilla-central/rev/433213256ed1
Is this a dupe of bug 627824?
betheking: can you please attach a screenshot of the issue?
(Reporter)

Comment 5

8 years ago
Created attachment 507615 [details]
Screenshot showing truncated bookmarks menu text
(Reporter)

Comment 6

8 years ago
Doesn't quite look like a dupe of bug 627824, as it wasn't just a problem of truncated text. The menu height wasn't increased/decreased as bookmarks were added or removed.

However, it is (mostly) fixed in the 2011-01-27 nightly build, perhaps thanks to the backout of bug 562138. Deleting a bookmark menu entry via the right-click menu still triggers it, so I attached a screenshot of what happens when you do that, and then add a new bookmark again.
I don't think this blocks based on the reduced STR in comment 6; feel free to renominate if it begins to happen more frequently.
blocking2.0: ? → -

Comment 9

7 years ago
I was not able to reproduce this bug in Nightly 15.0a1 (2012-04-30). Anyone else?

Comment 10

7 years ago
I cannot reproduce in Firefox10.0ESR and 12.0 and later.
Closing as WFM based on the last two old comments.
Status: NEW → RESOLVED
Last Resolved: 7 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.