If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[ro]Text cut off in Windows master password in Romanian language

RESOLVED FIXED in mozilla25

Status

Mozilla Localizations
ro / Romanian
--
major
RESOLVED FIXED
7 years ago
4 years ago

People

(Reporter: Raul Malea, Assigned: Raul Malea)

Tracking

(Depends on: 1 bug, {reproducible, uiwanted})

unspecified
mozilla25
reproducible, uiwanted
Dependency tree / graph

Firefox Tracking Flags

(firefox6-)

Details

(Whiteboard: [ro][4b10] interface)

Attachments

(1 attachment, 4 obsolete attachments)

(Assignee)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:2.0b10pre) Gecko/20110125 Firefox/4.0b10pre
Build Identifier: Mozilla/5.0 (Windows NT 6.1; rv:2.0b10pre) Gecko/20110125 Firefox/4.0b10pre

1.In Addons Manager , search box text is not visible completed. 
2. After disabled Flash plug-ins , box for missing plug-ins is with incomplete text.

See in attachments.

Reproducible: Always

Steps to Reproduce:
1.Go to Addons manager in romanian localization
2.See text in search addons form
3.Disable flash all plugins
4. Go to in anyone website contains flash
5. Observe button with information about plugin missing
Actual Results:  
Text not visible completed

Expected Results:  
All text is completed visible

Mozilla/5.0 (Windows NT 6.1; rv:2.0b10pre) Gecko/20110125 Firefox/4.0b10pre ID:20110125030335

about:buildconfig
Source
Built from http://hg.mozilla.org/mozilla-central/rev/6a097e294828
Build platform
target
i686-pc-mingw32
Build tools
Compiler 	Version 	Compiler flags
d;D:\mozilla-build\msys\mozilla-build\python25\python2.5.exe -O e;D:\mozilla-build\msys\builds\moz2_slave\cen-w32-ntly\build\build\cl.py cl 	14.00.50727.762 	-TC -nologo -W3 -Gy -Fdgenerated.pdb -DNDEBUG -DTRIMMED -Zi -Zi -UDEBUG -DNDEBUG -GL -wd4624 -wd4952 -O1
d;D:\mozilla-build\msys\mozilla-build\python25\python2.5.exe -O e;D:\mozilla-build\msys\builds\moz2_slave\cen-w32-ntly\build\build\cl.py cl 	14.00.50727.762 	-GR- -TP -nologo -Zc:wchar_t- -W3 -Gy -Fdgenerated.pdb -wd4800 -DNDEBUG -DTRIMMED -Zi -Zi -UDEBUG -DNDEBUG -GL -wd4624 -wd4952 -O1
Configure arguments

--enable-application=browser --enable-update-channel=nightly --enable-update-packaging --enable-jemalloc --enable-tests

Graphics
      
Descrierea adaptorului NVIDIA GeForce 8600 GT 
ID furnizor 10de
ID dispozitiv 0402
RAM pentru adaptor 512
Drivere pentru adaptor nvd3dum nvwgf2um,nvwgf2um
Versiune driver 8.17.12.6099
Dată driver 10-16-2010
Direct2D activat true
DirectWrite activat true (6.1.7600.20830)
WebGL Renderer TransGaming Inc. -- ANGLE -- OpenGL ES 2.0 (git-devel Jan 25 2011 03:42:06)
Accelerare GPU Windows 1/1 Direct3D 10
(Assignee)

Comment 1

7 years ago
Created attachment 507159 [details]
missing text in box for plugins
(Assignee)

Comment 2

7 years ago
Created attachment 507161 [details]
not visible all letter in search box for addons
(Assignee)

Updated

7 years ago
blocking2.0: --- → ?
Keywords: polish, reproducible
Whiteboard: [4b10] interface
Version: unspecified → Trunk
(Assignee)

Updated

7 years ago
See Also: → bug 433730
Component: General → ro / Romanian
Product: Firefox → Mozilla Localizations
QA Contact: general → romanian.ro
Version: Trunk → unspecified
(Assignee)

Comment 3

7 years ago
Luke, this bug is NOT a localisation bug. Translate text is completed and correct. BUT text not visible corect in addons manager search because form dimensions is SMALL.
Also, text for button for missing plugins is translated correct. Button is problem not texts!
Please see in attachments.
Component: ro / Romanian → General
Product: Mozilla Localizations → Firefox
Version: unspecified → Trunk
The plugin issue isn't a bug: that's just the size of that widget, which is large enough that we don't show the infobar, but too small to see the text. Try crashing Flash (by killing the plugin container process) on YouTube to verify, though.

The cutoff in the add ons manager is most likely bug 627824
Status: UNCONFIRMED → RESOLVED
blocking2.0: ? → ---
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 627824
(Assignee)

Updated

7 years ago
Summary: Not see al text in for localized romanian Minefield build → Text cutt off in some windows (romanian build)
(Assignee)

Updated

7 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
(Assignee)

Comment 5

7 years ago
I reopened this bug. See https://bugzilla.mozilla.org/show_bug.cgi?id=627824#c23 and https://bugzilla.mozilla.org/show_bug.cgi?id=627824#c24
(Assignee)

Comment 6

7 years ago
Created attachment 508240 [details]
letter cut in windows password
(Assignee)

Updated

7 years ago
blocking2.0: --- → ?
See Also: → bug 627824
QA Contact: romanian.ro → general
(Assignee)

Comment 7

7 years ago
Anyone confirm this bug?
(Assignee)

Updated

7 years ago
See Also: → bug 627996
Raul: in bug 627824 comment 24 you were told that the string needs to be 32-bytes, and is currently 33 bytes. So this is a l10n issue.
Status: UNCONFIRMED → NEW
blocking2.0: ? → final+
Component: General → ro / Romanian
Ever confirmed: true
Product: Firefox → Mozilla Localizations
QA Contact: general → romanian.ro
Version: Trunk → unspecified
(Assignee)

Comment 9

7 years ago
Thanks Mike.

Alex, can you fix this bug? Please observe string is high in two situations: search form in addons manager and window master password.
Also perhaps verifying string for all translated texts?

Updated

7 years ago
Assignee: nobody → alex
Whiteboard: [4b10] interface → [4b10] interface [hardblocker]
(Assignee)

Comment 10

7 years ago
I proposed new translation for windows master password.
(Assignee)

Comment 11

7 years ago
I proposed new translation for windows master password.

Updated

7 years ago
Keywords: polish
Clearing the flag; Alex, this should probably block your signoff for the romanian locale.
blocking2.0: final+ → ---
(Assignee)

Updated

7 years ago
Blocks: 632886
(Assignee)

Comment 13

7 years ago
In Bulgarian language some problem.
See Also: → bug 635372
the search field in the addons manager is now wider so as to give enough space to all localizations text (bug 630604), so this specific issue in this bug is fixed in nightlies.
(Assignee)

Comment 15

7 years ago

(In reply to comment #14)
> the search field in the addons manager is now wider so as to give enough space
> to all localizations text (bug 630604), so this specific issue in this bug is
> fixed in nightlies.

Yes! Very good. Thanks Pascal and all.

Second part from this bug is resolved. Remaining text in master password windows. (similarly with bug 630604 - need large window).
Depends on: 630604

Comment 16

7 years ago
Clearing hardblocker from the whiteboard since this doesn't have blocking2.0+.
Whiteboard: [4b10] interface [hardblocker] → [4b10] interface
(Assignee)

Comment 17

7 years ago
For resolved this bug need a large windows master password.
Keywords: uiwanted
OS: Windows 7 → All
Hardware: x86 → All
(Assignee)

Updated

7 years ago
Component: ro / Romanian → General
Product: Mozilla Localizations → Firefox
Summary: Text cutt off in some windows (romanian build) → Text cutt off in windows master password
Version: unspecified → Trunk
(Assignee)

Comment 18

7 years ago
Increasing the window size is required for the master password. Abbreviation word translated is NOT a solution(e.g. device=dispozitiv ->disp.)
(Assignee)

Updated

7 years ago
Summary: Text cutt off in windows master password → Text cut off in Windows master password
Summary: Text cut off in Windows master password → Text cut off in Windows master password in Romanian language
(Assignee)

Comment 19

7 years ago
Any news? My suggestion is increasing windows dimensions.
The text field in the add-ons manager should be the same default (if not exactly the same) length as the normal Firefox search field.  Would making the search box that large solve the problem, Raul?
Boriss: it sounds like the search field in the Add-ons Manager has been fixed in bug 630604, and the remaining problem is the appearance of the label in the master password dialog, i.e. the dialog that prompts you to enter your master password.

In English, the label in that dialog says "Please enter the master password for the Software Security Device.", which is a combination of the string "Please enter the master password for the %S." from CertPassPrompt <http://mxr.mozilla.org/mozilla-central/source/security/manager/locales/en-US/chrome/pipnss/pipnss.properties#43> and the string "Software Security Device" from either PrivateTokenDescription <http://mxr.mozilla.org/mozilla-central/source/security/manager/locales/en-US/chrome/pipnss/pipnss.properties#63> or InternalToken <http://mxr.mozilla.org/mozilla-central/source/security/manager/locales/en-US/chrome/pipnss/pipnss.properties#76>.

In Romanian, the former string is translated to "Vă rugăm introduceți parola generală pentru %S." <http://mxr.mozilla.org/l10n-central/source/ro/security/manager/chrome/pipnss/pipnss.properties#43>, and the latter string is translated to "Dispozitiv software de securitate" <http://mxr.mozilla.org/l10n-central/source/ro/security/manager/chrome/pipnss/pipnss.properties#63>, so the label should read "Vă rugăm introduceți parola generală pentru Dispozitiv software de securitate."

But, as shown in attachment 508240 [details], it reads "Vă rugăm introduceți parola generală pentru Dispozitiv software de securitat."  The last "e" in the last word ("securitate") is missing.

This doesn't look like a problem of the window not being wide enough, given that the period after the last word isn't cut off, and because presumably this XUL dialog expands to fit the content it contains.

Instead, it appears that PrivateTokenDescription/InternalToken, which contain 33 ASCII characters, are being truncated to 32 characters, which is exactly what I would expect given the comments in pipnss.properties that those strings must fit into 32 bytes when converted to UTF-8 <http://mxr.mozilla.org/mozilla-central/source/security/manager/locales/en-US/chrome/pipnss/pipnss.properties#44>.

  0        1         2         3   
  123456789012345678901234567890123
  Dispozitiv software de securitate

So the short-term fix for the issue is to reduce the size of the Romanian translation of "Software Security Device" from 33 UTF-8 bytes to 32 or less UTF-8 bytes.

(In the long term, it would be nice if the string didn't have such a length restriction, of course.)
(Assignee)

Updated

7 years ago
tracking-firefox6: --- → ?
It's a nasty l10n requirement, but bug 320231 and bug 90956 comment 21 don't really make it sound like there's much choice.
Assignee: alex → nobody
Component: General → Security: UI
Product: Firefox → Core
QA Contact: romanian.ro → ui
(Assignee)

Updated

7 years ago
Depends on: 320231

Updated

7 years ago
tracking-firefox6: ? → -
(Assignee)

Comment 23

6 years ago
Any news for this bug?

Comment 24

6 years ago
(In reply to comment #23)
> Any news for this bug?

If there is news for this bug, it will show up as a comment, an attachment, or a review in this bug, so you should be able to answer that question for yourself.

Comment 25

6 years ago
I'm pretty sure that the 32 byte limit is hard, Kai, can you confirm that?

If so, the Romanian team will need to make an effort to squeeze their localization into that limit, in those cases, we apparently can't do anything on the platform side. If I understood Kai right.

Comment 26

6 years ago
Hard limit, please sqeeze your translation into 32 bytes, e.g. by using abbreviations.

Other ideas for "software security device" (that might give you a shorter translation):
- Software Key Store
(Assignee)

Comment 27

6 years ago
(In reply to Kai Engert (:kaie) from comment #26)
> Hard limit, please sqeeze your translation into 32 bytes, e.g. by using
> abbreviations.
> 
> Other ideas for "software security device" (that might give you a shorter
> translation):
> - Software Key Store

OK. We try to squeeze this translation.

Alex or Cristi, you have any suggestions?
(Assignee)

Updated

6 years ago
Target Milestone: --- → mozilla8

Comment 28

6 years ago
(regarding comment 21) The string "Vă rugăm introduceți parola generală pentru %S." in Romanian translation should be shorter, i.e. "Introduceți parola generală pentru %S.".

Reason: in Romanian we shall never use the excessively polite form, so the "Vă rugăm" part must be always avoided. There is also a written reference for this here (in Romanian) http://i18n.ro/Ghidul_traducatorului_de_software#Polite.C8.9Bea_excesiv.C4.83

Is this enough to solve the issue raised here ?

As a sidenote I am not sure if „parola generală” is the best translation for „master password”; maybe „parola principală” is a better variant ? (but I do not insist here)

Also in my opinion the string "Dispozitiv software de securitate" should became "dispozitivul software de securitate" because it makes the overall phrase more natural.

Cristi

Comment 29

6 years ago
(In reply to Cristian Secară from comment #28)

> Also in my opinion the string "Dispozitiv software de securitate" should
> became "dispozitivul software de securitate" because it makes the overall
> phrase more natural.

... except if this string is again used elsewhere in standalone form.

Cristi

Comment 30

6 years ago
Replaced 

Vă rugăm introduceți parola generală pentru dispozitivul software de securitate

with

Introduceți parola generală pentru dispozitivul software de securitate

in Firefox Aurora.

and shortned other similar texts in http://hg.mozilla.org/releases/l10n/mozilla-aurora/ro/rev/0b33781d0bd3

Răzvan, please check.
Status: NEW → RESOLVED
Last Resolved: 7 years ago6 years ago
Resolution: --- → FIXED
(Assignee)

Comment 31

6 years ago
(In reply to Alexandru Szasz from comment #30)
> Replaced 
> 
> Vă rugăm introduceți parola generală pentru dispozitivul software de
> securitate
> 
> with
> 
> Introduceți parola generală pentru dispozitivul software de securitate
> 
> in Firefox Aurora.
> 
> and shortned other similar texts in
> http://hg.mozilla.org/releases/l10n/mozilla-aurora/ro/rev/0b33781d0bd3
> 
> Răzvan, please check.

Is very good! Thanks all!
Status: RESOLVED → VERIFIED
(Assignee)

Updated

6 years ago
Target Milestone: mozilla8 → mozilla10
(Assignee)

Comment 32

6 years ago
In Firefox 10 beta this bug is still present. See in photo attached.
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 33

6 years ago
Created attachment 585046 [details]
Letters missing in master password windows
Attachment #507159 - Attachment is obsolete: true
Attachment #507161 - Attachment is obsolete: true
Attachment #508240 - Attachment is obsolete: true
(Assignee)

Comment 34

6 years ago
Alex, 3 letters missing: "ate". Please check.

Comment 35

6 years ago
Shortened the text by droping Enter. It's obvious you need to enter something there. in http://hg.mozilla.org/releases/l10n/mozilla-aurora/ro/rev/b7d78dfe2d6a
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → FIXED
(Assignee)

Comment 36

6 years ago
Sorry , this bug is till present in Mozilla/5.0 (Windows NT 6.1; rv:11.0a2) Gecko/20120112 Firefox/11.0a2 ID:20120112042007
See in attachment.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 37

6 years ago
Created attachment 588153 [details]
Letters missing in master password window in Aurora
Attachment #585046 - Attachment is obsolete: true
(Assignee)

Comment 38

5 years ago
Any suggestions for this?  Now, 3 letters missing: "ate". However, I think the translation is still too long.
Target Milestone: mozilla10 → mozilla20
(Assignee)

Comment 39

5 years ago
Two years! :) Congratulations!
(Assignee)

Updated

4 years ago
Component: Security: UI → ro / Romanian
Product: Core → Mozilla Localizations
Summary: Text cut off in Windows master password in Romanian language → [ro]Text cut off in Windows master password in Romanian language
Whiteboard: [4b10] interface → [ro][4b10] interface
Target Milestone: mozilla20 → mozilla24
Version: Trunk → unspecified
(Assignee)

Comment 40

4 years ago
Resolved in: http://hg.mozilla.org/releases/l10n/mozilla-aurora/ro/rev/410aa81f64a3 by:

Parola generală (eliminated word „pentru„) and „dispozitiv software de securitate”. 
So, is a „Microsoft” translation but ... :(

After verified in Aurora I closed this bug.
Assignee: nobody → raul.malea
Flags: needinfo?(raul.malea)

Comment 41

4 years ago
You could use "pt." instead of removing "pentru". At least, it makes sense for users. "Pt." it's a known abbreviation for "pentru" (eng. "for").

Best Regards,
Cristian Silaghi
(Assignee)

Comment 42

4 years ago
(In reply to Cristian from comment #41)
> You could use "pt." instead of removing "pentru". At least, it makes sense
> for users. "Pt." it's a known abbreviation for "pentru" (eng. "for").
> 
> Best Regards,
> Cristian Silaghi

Voi verifica mâine dacă încap acum textele. Ar trebui să apară așa: „Parola generală dispozitiv software de securitate.”
(Assignee)

Comment 43

4 years ago
Hmm ....last 3 letter „ate” missing. Problem are from „Software Security Device” (dispozitiv software de securitate) because # 32 bytes long after conversion to UTF8

So, I not understanding. In last time missing one letter („e”), see in comment 21.

Also, not understanding where enter something by comment 35.

This bug is still present.

For moment, do not have any idea.
Flags: needinfo?(raul.malea)
Target Milestone: mozilla24 → mozilla25
(Assignee)

Updated

4 years ago
Severity: normal → major
(Assignee)

Comment 44

4 years ago
Now, translate is: „Vă rugăm introduceți parola generală pentru disp. software de securitate”. (commited in http://hg.mozilla.org/releases/l10n/mozilla-aurora/ro/rev/81222a554ed9) 

Any suggestions?
(Assignee)

Comment 45

4 years ago
Closed bug for moment. Thanks all.
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.