drag and drop of groups has become really slow and chunky

RESOLVED WONTFIX

Status

P2
normal
RESOLVED WONTFIX
8 years ago
3 years ago

People

(Reporter: dietrich, Unassigned)

Tracking

({perf, regression})

Trunk
x86
All
perf, regression
Dependency tree / graph

Firefox Tracking Flags

(blocking2.0 -)

Details

(Whiteboard: [needs profiling])

Comment hidden (empty)
(Reporter)

Comment 1

8 years ago
it's delayed enough that things are unusable.
blocking2.0: --- → ?
Keywords: perf, regression
This is on trunk? Nightly? It's working fine for me on Mac...

Do you have a bajillion groups open or something? It was working fine before?
(Reporter)

Comment 3

8 years ago
Yep, trunk nightly.

I only have 3 groups, but probably 70 tabs. I don't know if it was fine before or not, since I don't go into the tabview UI very often (only a lot lately, since my groups keep getting horked and I have to fix them).
Tim, are you seeing the same on linux?
Whiteboard: [WFM?]
Mhhh.. It's okay and usable for me. My machine is not the newest/fastest anymore but for me there's no noticeable regression. Maybe we could get Dietrich to do some profiling to know what his machine is doing while dragging groups around? :)

Comment 6

8 years ago
Mozilla/5.0 (Windows NT 6.1; rv:2.0b10pre) Gecko/20110125 Firefox/4.0b10pre

Moving around groups tends to be bumpy. Tried it on WinXP and Win 7.

Updated

8 years ago
OS: Linux → All
Dietrich: need specs on your hardware; if it's OSX running 10.5, we recently turned off GL, which might be slowing things down there. Either way, I don't think this blocks, but for the purposes of investigation, it'd help.
blocking2.0: ? → -
Priority: -- → P3
(Reporter)

Comment 8

8 years ago
Lenovo T400s, Intel integrated graphics, 4gb RAM.
If someone could do some js and/or shark profiling on this, it would be appreciated. My guess is that either, indeed, we're spending time with graphics and drawing, or we're using cycles in the snapping code.

One way to quickly see whether it's the snapping which is costly is to see if dragging performance improves greatly if you hold down the option key and drag groups around. This turns off the "snapping" to other groups and tabs.

Also, if someone could identify a regression range, that would also be helpful.
Depends on: 610271
(In reply to comment #9)
> hold down the option key and drag
> groups around. This turns off the "snapping" to other groups and tabs.

Sorry, I misspoke. The metaKey... on Mac this is command...
(Reporter)

Comment 11

8 years ago
Video: https://people.mozilla.com/~dietrich/tabview.ogv

Note how the dragging is seconds behind my mouse actions, and the snap lines don't show up ever.

(I'm not holding down ctrl during this. Doing so did not change the behavior.)
(In reply to comment #11)
> Video: https://people.mozilla.com/~dietrich/tabview.ogv

Wow, this strikes me as particularly bad. It is not what I see on my mac with recent builds. :/

Would it be possible to get some profiling?
Dietrich, does this still happen for you with the latest nightly? I'm curious because bug 606148 has landed yesterday.
Dietrich, in the video you're dragging a stacked group... is it the same for unstacked groups?
(Reporter)

Comment 15

8 years ago
Still happening, and happens for any type of group. If you come up with a patch I could apply that would dump out profiling information, I'd be glad to apply it and get that info for you.
Whiteboard: [WFM?] → [WFM?][needs profiling]
The final beta window has essentially closed, but I would be happy if we could do some profiling for this post beta12, though a fix itself (if necessary) most likely can't happen for fx4. :(
Blocks: 585689
No longer blocks: 627096
(Reporter)

Comment 17

8 years ago
If the fix is not large footprint, seems not risky, has great test coverage, then drivers are more likely to take it. I wouldn't let the risk of it not being taken slow any momentum for fixing this.
Whiteboard: [WFM?][needs profiling] → [needs profiling]

Updated

8 years ago
Priority: P3 → P2
No longer blocks: 585689

Comment 18

8 years ago
bugspam
No longer blocks: 603789
bugspam
No longer blocks: 653099
bugspam

(Fx7 was branched, removing open bugs from Fx7 meta bug, we won't create new meta bugs for upcoming Fx versions)
No longer blocks: 660175
We're not going to address this with Panorama being slated for removal.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WONTFIX
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.