[D3D9] Panorama previews are blurry with hardware acceleration enabled

VERIFIED FIXED

Status

()

defect
VERIFIED FIXED
8 years ago
8 years ago

People

(Reporter: marcia, Assigned: bas.schouten)

Tracking

Trunk
x86
Windows XP
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(blocking2.0 final+)

Details

(Whiteboard: [4b10][softblocker])

Attachments

(4 attachments)

Posted image Tab candy on XP
Seen while running Mozilla/5.0 (Windows NT 5.1; rv:2.0b10) Gecko/20100101 Firefox/4.0b10

STR:
1. Load three tabs, with cnn.com, nypost.com and addons.mozilla.org
2. View-> Tab Groups

Compare the screenshot to what you see on Windows 7 with the equivalent build. There is a noticeable difference in clarity of the content inside the tabs
The XP machine I am using was recently re-imaged, so it is relatively clean with the standard Win XP theme. The Windows 7 machine has the Aero theme.
Summary: [WinXP] Tab candy previews are blurry compared to Win 7 → [WinXP] Tab candy previews are blurry with hardware acceleration enabled
Marcia, can you check for a regression range? I was able to see this on my XP test run, but I didn't see it on a Windows2000 machine.
Nominating because this problems makes tabs indistinguishable from one another in Panorama under XP.
blocking2.0: --- → ?
Blocks: 627096
--> Core::Graphics

FWIW, I don't think this blocks for the effects on TabCandy alone, but it may indicate a deeper problem with HW Accel in XP, so over to Graphics for triage!
Component: TabCandy → Graphics
Product: Firefox → Core
QA Contact: tabcandy → thebes
Looks like the XP tab images are drawn using completely wrong colors for the text in many cases - e.g. the title and the Categories sidebar on the Add-ons for Firefox page seems to have painted white text instead of dark blue. (But oddly, the Popular Tags sidebar hasn't done the same thing.)
Blocks: 626527
Assignee: nobody → bas.schouten
Bug 627838 may be a duplicate of this. Do you get the same problem if the thumbnails are large (over 150 pixels wide)? We have a different code path depending on the size.
(Assignee)

Comment 8

8 years ago
This issue reproduces on Windows 7 when Direct2D is disabled and D3D9 layers is used. I will triage this in the coming days.
Status: NEW → ASSIGNED
Summary: [WinXP] Tab candy previews are blurry with hardware acceleration enabled → [D3D9] Tab candy previews are blurry with hardware acceleration enabled
blocking2.0: ? → final+
Whiteboard: [4b10] → [4b10][softblocker]
There hasn't been any activity here lately. :(
(Assignee)

Comment 10

8 years ago
This got delayed a bit because of work on hardblockers. I do still intend to look at this soon.
Summary: [D3D9] Tab candy previews are blurry with hardware acceleration enabled → [D3D9] Panorama previews are blurry with hardware acceleration enabled

Updated

8 years ago
Duplicate of this bug: 627838

Comment 12

8 years ago
Hopefully this can be made a hard blocker, since the complete absence of text content for anything above 150px is a larger issue than just blurriness?
(Assignee)

Comment 13

8 years ago
We're currently ignoring the format of the source surface in CanvasLayerD3D9. This is bad. This patch addresses the issue.
Attachment #511090 - Flags: review?(jmuizelaar)
Attachment #511090 - Flags: review?(jmuizelaar) → review+
(Assignee)

Comment 14

8 years ago
As requested per IRC this lets D3D10 match the style introduced in D3D9.
Attachment #511093 - Flags: review?(jmuizelaar)
Attachment #511093 - Flags: review?(jmuizelaar) → review+
(Assignee)

Comment 15

8 years ago
http://hg.mozilla.org/mozilla-central/rev/d1c5def46796
http://hg.mozilla.org/mozilla-central/rev/8379db2b16d2
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Verified on Build identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0b12) Gecko/20100101 Firefox/4.0b12
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.