Shutdown Crash after playing webm video [@ @0x0 | mozilla::layers::GLTexture::Release ]

RESOLVED FIXED

Status

()

Core
Graphics
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: dholbert, Unassigned)

Tracking

({crash})

Trunk
x86_64
Linux
crash
Points:
---

Firefox Tracking Flags

(blocking2.0 -)

Details

(crash signature, URL)

STEPS TO REPRODUCE:
 0. Enable layers (set layers.acceleration.force-enabled = true)
 1. Load http://webm.html5.org/test.webm
 2. Quit Firefox (Ctrl+Q)

ACTUAL RESULTS:
Crash with signature: [@ @0x0 | mozilla::layers::GLTexture::Release ]
bp-ca4883a4-d3b1-4596-968e-349e52110123
bp-09183938-e10d-499e-ab63-f05322110123
bp-0a8cc87e-443b-4b4c-a9d9-637bc2110123

Mozilla/5.0 (X11; Linux x86_64; rv:2.0b10pre) Gecko/20110121 Firefox/4.0b10pre

I can reproduce this crash 100% of the time on Ubuntu 10.10 on my Thinkpad T510 Laptop, which has an nvidia graphics card and is running the proprietary nvidia graphics driver.
blocking2.0: --- → ?

Comment 1

6 years ago
Same as  bug 604044?
Not sure -- that bug doesn't mention this crash signature at all (nor does any bug, which is why I filed this.)

(though if this is a dupe, please update the summary of the other bug to mention this bug's signature, so that crash reports get auto-linked to the correct bug.)
Component: Video/Audio → Graphics
QA Contact: video.audio → thebes
Sorry, force-enabled crashes don't block.
blocking2.0: ? → -
(Assignee)

Updated

6 years ago
Crash Signature: [@ @0x0 | mozilla::layers::GLTexture::Release ]
I can't reproduce this on nightly, does it still occur for you?
Can't reproduce anymore.  Tracked down fix range:

BROKEN: Mozilla/5.0 (X11; Linux x86_64; rv:8.0a1) Gecko/20110805 Firefox/8.0a1
WORKS: Mozilla/5.0 (X11; Linux x86_64; rv:8.0a1) Gecko/20110806 Firefox/8.0a1

Fix range:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=5684f06138f3&tochange=be090ee1747a

In that range, the only thing to mention "video" or "layers":
> 83fe19966844	Matt Woodrow — Bug 671259 - Disable OpenGL layers on linux when we don't have texture_from_pixmap. r=bjacob

Given the crash signature (mentioning GLTexture::Release), that seems likely to be what fixed this.  Resolving as fixed by that.  (Matt, does that seem right to you?)
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Depends on: 671259
Resolution: --- → FIXED
More likely:

1edc576938dc	Matt Woodrow — Bug 675073 - Release OpenGL textures with the global context if the creating context has been destroyed. r=joe

Which was crashing in the same place, but with a different stack.
Ah, yes, that looks very promising. Thanks for the correction.
Depends on: 675073
No longer depends on: 671259
You need to log in before you can comment on or make changes to this bug.