Make Panorama controls box prettier on glass

RESOLVED WONTFIX

Status

defect
P3
normal
RESOLVED WONTFIX
8 years ago
3 years ago

People

(Reporter: WonderCsabo, Unassigned)

Tracking

({uiwanted})

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b10pre) Gecko/20110121 Firefox/4.0b10pre
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b10pre) Gecko/20110125 Firefox/4.0b10pre

If you don't have a persona, you are using glass and un-maximized window, the Panorama controls box position looks odd. It seems to be floating in nowhere. Check out attachment 506250 [details].

Reproducible: Always
(Reporter)

Updated

8 years ago
Blocks: 591652
Version: unspecified → Trunk
The suggestion I made in the past was to put down a 50% or so opacity background in Panorama, even with Aero Glass, just so it's not *too* transparent.

Comment 2

8 years ago
(In reply to comment #1)
> The suggestion I made in the past was to put down a 50% or so opacity
> background in Panorama, even with Aero Glass, just so it's not *too*
> transparent.

Faaborg and I discussed this, and since we don't have the ability to glass the entire window frame at the moment, we could only "frost" Panorama up to a couple pixels from the side and bottom edges of the window, instead of the entire window. We decided that having this semi-transparent frame inside a transparent frame made the window look too thick.

The controls box itself could be adjusted to look better on glass though, e.g. the top and right borders could be rounded.
No longer blocks: 591652
Status: UNCONFIRMED → NEW
Depends on: 591652
Ever confirmed: true
Summary: Panorama controls box looks odd with glass → Make Panorama controls box prettier on glass
(Reporter)

Comment 3

8 years ago
The really fix would be moving the box to the very edge of the window.
(In reply to comment #3)
> The really fix would be moving the box to the very edge of the window.

Moving to the top edge may also be a good idea, and it matches the mockups as well.
(Reporter)

Comment 5

8 years ago
I meant right edge, but the top edge is fine too, like Fx button. The current floating position is very odd.
We can't draw into the window border yet (bug 590945) so we're probably going
to have this floating in space a little farther into the window.  I'll post
mockups later today.

Same bug causes some problems with trying to frost panorama.  For instance, the
dark effect used to indicate the user is searching/filtering feels odd because
it only darkens part of what should be a seamless surface.

Comment 7

8 years ago
(In reply to comment #5)
> I meant right edge, but the top edge is fine too, like Fx button. The current
> floating position is very odd.

(In reply to comment #6)
> We can't draw into the window border yet (bug 590945) so we're probably going
> to have this floating in space a little farther into the window.  I'll post
> mockups later today.

The panorama button's location in tab view and in the toolbar should ideally be the same, so it appears to be the same button when you toggle tab view. However, if we're going to change the button's appearance in tab view (to be more distinct from the window close button) anyways, it doesn't matter as much. (In other words, moving the box further into the window works for me.)
Blocks: 627096
Priority: -- → P3
Alex, if you have mockups and a proposal for how to make this prettier for fx4, we should get right on it... otherwise, we should punt on this ticket and hopefully revisit it post-fx4, perhaps with bug 590945 in place.
Keywords: uiwanted
>Alex, if you have mockups and a proposal for how to make this prettier for fx4,
>we should get right on it... otherwise, we should punt on this ticket and
>hopefully revisit it post-fx4

This would be solved by bug 630792
http://areweprettyyet.com/4/panorama/
Blocks: 603789
No longer blocks: 627096
Depends on: 630792
Target Milestone: --- → Future

Comment 10

8 years ago
bugspam
Target Milestone: Future → ---
No longer blocks: 603789
bugspam
No longer blocks: 653099
bugspam

(Fx7 was branched, removing open bugs from Fx7 meta bug, we won't create new meta bugs for upcoming Fx versions)
No longer blocks: 660175
Panorama has been removed from Firefox 45, currently in Beta and scheduled for release on March 7th. As such, I'm closing all existing Panorama bugs.

If you are still using Panorama, you will see a deprecation message in Firefox 44, and when 45 is released your tab group data will be migrated to bookmarks, with a folder for each group. There are also a few addons offering similar functionality.

See https://support.mozilla.org/en-US/kb/tab-groups-removal for more info.

We're removing Panorama because it has extremely low usage (about 0.01% of users), and has a large number of bugs and usability issues. The cost of fixing all those issues is far too high to justify, and so we'll instead be focusing our time and energy on improving other parts of Firefox.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.