Sometimes zooming out of a tab does not properly set initial CSS state.

VERIFIED FIXED

Status

Firefox Graveyard
Panorama
P3
normal
VERIFIED FIXED
7 years ago
2 years ago

People

(Reporter: Sean Dunn, Unassigned)

Tracking

Details

(Whiteboard: [visual][polish][good first bug])

(Reporter)

Description

7 years ago
Repro:

1. In browser view create several tabs.
2. Click on a tab to enter tab view
3. Exit tab view
4. Enter tab view

Actual Result:

Tab zooms out from a boundary to the lower right of the destination bounds.

Expected Result:

Tab should zoom out from the same position that it zoomed into when entering browser mode.

Notes:

It looks like the tab's CSS isn't being set correctly before zoom out. If you manually force it to set it correctly (using zoomPrep(true)) it will work as expected.
Is it a dupe of bug 626940?
No, I don't think this is the same as 626940. However, I can vouch that this is fixed when using bug 624931 patches.
Depends on: 624931
Whiteboard: [visual][polish][good first bug]
Blocks: 627096
Priority: -- → P3
Bug 624931 has landed; I believe this is fixed.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
verified with minefield build of 20110217
Status: RESOLVED → VERIFIED
(Assignee)

Updated

2 years ago
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.