Last Comment Bug 628795 - [1.9.1 & 1.9.2] put en-US.xpi under obj-firefox/dist/platform/xpi rather than obj-firefox/dist
: [1.9.1 & 1.9.2] put en-US.xpi under obj-firefox/dist/platform/xpi rather than...
Status: RESOLVED FIXED
[l10n]
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: 1.9.2 Branch
: All All
: -- normal (vote)
: ---
Assigned To: Ben Hearsum (:bhearsum)
:
Mentors:
Depends on: 609878
Blocks: 627271 629398 630562
  Show dependency treegraph
 
Reported: 2011-01-25 14:00 PST by Armen Zambrano [:armenzg] (EDT/UTC-4)
Modified: 2011-03-04 10:14 PST (History)
4 users (show)
bugzillamozillaorg_serge_20140323: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
unaffected
-
.17-fixed
-
.19-fixed


Attachments
[checked in][1.9.1][1.9.2] generate en-US.xpi under dist/linux-i686/xpi (573 bytes, patch)
2011-01-25 14:00 PST, Armen Zambrano [:armenzg] (EDT/UTC-4)
khuey: review+
mbeltzner: approval1.9.2.17+
mbeltzner: approval1.9.1.19+
Details | Diff | Splinter Review

Description Armen Zambrano [:armenzg] (EDT/UTC-4) 2011-01-25 14:00:46 PST
Created attachment 506896 [details] [diff] [review]
[checked in][1.9.1][1.9.2] generate en-US.xpi under dist/linux-i686/xpi

on trunk: Uploading /builds/slave/rel-cen-lnx-bld/build/obj-firefox/dist/linux-i686/xpi/en-US.xpi
on 1.9.2: Uploading /builds/slave/rel-192-lnx-bld/build/obj-firefox/dist/en-US.xpi

Making langpack /builds/slave/rel-192-lnx-bld/build/obj-firefox/dist/en-US.xpi
Making langpack /builds/slave/rel-cen-lnx-bld/build/obj-firefox/browser/locales/../../dist/linux-i686/xpi/en-US.xpi

I believe attachment 479776 [details] [diff] [review] did not ever land on 1.9.1/1.9.2

See also bug 485860, bug 609878 and maybe maybe bug 587984.
Comment 1 Ben Hearsum (:bhearsum) 2011-01-27 12:14:13 PST
I dug into this a little bit and couldn't figure out why this is still happening. In the l10n makefiles $(LANGPACK_FILE) is the same on all branches. $(PKG_LANGPACK_BASENAME) and $(PKG_LANGPACK_PATH) are the same on all branches.

Moving this Core: Build Config, too.
Comment 2 Ben Hearsum (:bhearsum) 2011-01-31 06:13:07 PST
I didn't see your patch when I first commented here, Armen. This looks quite like it's likely to be the fix, I'll test it out today.
Comment 3 Ben Hearsum (:bhearsum) 2011-01-31 08:45:53 PST
Comment on attachment 506896 [details] [diff] [review]
[checked in][1.9.1][1.9.2] generate en-US.xpi under dist/linux-i686/xpi

This is a follow-up to bugs 485860 and 609878. In the latter, we landed the second hunk of the patch from 485860 on all branches. But since the original patch never landed on 1.9.1 and 1.9.2 we ended up uploading en-US.xpi in the wrong place on these branches. This patch is simply the first hunk from bug 485860, which we need on 1.9.1 and 1.9.2 to upload en-US.xpi to the right location.

I tested it on Linux/Windows without issue.
Comment 4 Ben Hearsum (:bhearsum) 2011-02-01 06:06:13 PST
Drivers, this is a extremely low risk patch that's been on trunk for a long time. It only affects where we build en-US.xpi, and landing it allows us to land bug 629398, which is a big improvement to overall end2end time of a release. I'd like to land this on both 1.9.1 and 1.9.2.
Comment 5 Mike Beltzner [:beltzner, not reading bugmail] 2011-02-01 06:53:55 PST
Comment on attachment 506896 [details] [diff] [review]
[checked in][1.9.1][1.9.2] generate en-US.xpi under dist/linux-i686/xpi

a=beltzner for both branches
Comment 6 Ben Hearsum (:bhearsum) 2011-02-01 07:46:20 PST
Comment on attachment 506896 [details] [diff] [review]
[checked in][1.9.1][1.9.2] generate en-US.xpi under dist/linux-i686/xpi

Landed on both branches.
Comment 8 Daniel Veditz [:dveditz] 2011-03-04 10:14:57 PST
The "3.6.15" we're releasing today does not fix this bug, the release containing this bug fix has been renamed to "3.6.16" and the bugzilla flags will be updated to reflect that soon. Today's release is a re-release of 3.6.14 plus a fix for a bug that prevented many Java applets from starting up.

Note You need to log in before you can comment on or make changes to this bug.