Closed Bug 629825 (Win2kRemoval) Opened 9 years ago Closed 8 years ago

Stop support for building on Windows 2000 after Gecko 2.0

Categories

(Firefox Build System :: General, enhancement)

x86
Windows 2000
enhancement
Not set

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 699385

People

(Reporter: sgautherie, Unassigned)

Details

Gecko 2.0 still supports building on Windows 2000 [disabling a few options may be needed] and official optimized [!= official debug] builds still run on Windows 2000.
As one of the last Windows 2000 users on the Internet, I support and am thankful for that :-)

Yet, I can only agree with Ted or other people who would like to drop support for this (10-year old) O.S. asap.
Let's do that after mozilla-2.0 has branched (for good).

***

https://developer.mozilla.org/en/Windows_Build_Prerequisites
{
Hardware Requirements

Windows 2000SP4 or greater (Windows XP or above recommended, so that you can install the Windows Vista SDK)
}

Microsoft has ended (last) support for Windows 2000 on 13 July, 2010.
Alias: Win2kRemoval
Depends on: WinNt4Removal
Blocks: 699247
Summary: Stop support for Windows 2000 after Gecko 2.0 → Stop support for building on Windows 2000 after Gecko 2.0
Blocks: 716449
No longer blocks: 716449
No point keeping this around.
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: RequireWin7SDK
No longer blocks: PSDK2003R2Removal
No longer blocks: 699247
No longer depends on: WinNt4Removal
V.Duplicate
Status: RESOLVED → VERIFIED
Target Milestone: Future → ---
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.