Bug 629827 (PSDK2003R2Removal)

Stop support for building with Windows 2003R2 SDK only (= without Windows Vista/7 SDK) after Gecko 2.0

VERIFIED DUPLICATE of bug 699385

Status

--
enhancement
VERIFIED DUPLICATE of bug 699385
8 years ago
6 months ago

People

(Reporter: sgautherie, Unassigned)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
Gecko 2.0 still supports building with Windows 2003R2 SDK only [though that disables some newer features].
As one of the probably last developers still using Windows 2000, I support and am thankful for that :-)

Yet, I can only agree with Ted or other people who would like to drop (specific) support for this (7-year old) SDK asap.
Let's do that after mozilla-2.0 has branched (for good).

***

https://developer.mozilla.org/En/Windows_SDK_versions
{
Windows Server 2003 R2 Platform SDK

This is your only option if you're on Windows 2000. You'll also need to install this if you are using a free version of Visual C++ and want to build code that uses ATL.
}
I think we should just require the Windows 7 SDK for building Gecko post-2.0, since we're using features from it already anyway.
(Reporter)

Updated

7 years ago
Blocks: 699385
What's the status of this?
Blocks: 717499
(Reporter)

Comment 3

7 years ago
(In reply to Bas Schouten (:bas) from comment #2)
> What's the status of this?

Options seem to be:
1) Continue to support P.SDK 2003R2 for now, as it currently is (supposed to be).
2) Confirm+Do this bug: drop P.SDK 2003R2 support only, as a first step.
3) Land+Complete bug 699385: drop Vista SDK support too, at the same time.
Per comment 1, I think we should just require the Windows 7 SDK. It should be a simple configure change to make that happen, and we can do code cleanup to remove ifdefs as a followup.
(Reporter)

Updated

7 years ago
Blocks: 719389
(Reporter)

Updated

7 years ago
Blocks: 555485
(Reporter)

Updated

7 years ago
Blocks: 716449
(Reporter)

Updated

7 years ago
Alias: PSDK2003R2Removal
(Reporter)

Updated

7 years ago
Blocks: 720071
(Reporter)

Updated

7 years ago
Blocks: 720323
(Reporter)

Comment 5

7 years ago
Fwiw, wrt current 12a1 tree:

Building on Try using "--with-windows-version=502":
*1 bug is fixed.
*2 bugs have attached patches to review.

Building locally with "Windows 2000 + P.SDK 2003R2 + VC8EE":
3 bugs have local patches I haven't attached yet.

With these, builds complete on both environments :-)
(Reporter)

Updated

7 years ago
Blocks: 721182
I think we should dup this bug to bug 699385.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 699385
No longer blocks: 699385
(Reporter)

Updated

7 years ago
No longer blocks: 720071
(Reporter)

Updated

7 years ago
No longer blocks: 719389
(Reporter)

Updated

7 years ago
No longer blocks: 717499
(Reporter)

Updated

7 years ago
No longer blocks: 716449
(Reporter)

Updated

7 years ago
No longer blocks: 721182
(Reporter)

Updated

7 years ago
No longer blocks: 555485
(Reporter)

Updated

7 years ago
No longer blocks: 720323
(Reporter)

Comment 8

7 years ago
V.Duplicate
Status: RESOLVED → VERIFIED
No longer depends on: 629825
Target Milestone: Future → ---

Updated

6 months ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.