Last Comment Bug 630856 - "Open All in Tabs" change a currently selected App Tab with the first URL of the folder
: "Open All in Tabs" change a currently selected App Tab with the first URL of ...
Status: RESOLVED FIXED
[fixed by 440093]
:
Product: Firefox
Classification: Client Software
Component: Tabbed Browser (show other bugs)
: Trunk
: All All
: -- normal with 1 vote (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
: 647609 (view as bug list)
Depends on: 440093
Blocks: 579874
  Show dependency treegraph
 
Reported: 2011-02-02 07:30 PST by Sylvain Falardeau
Modified: 2011-08-12 01:05 PDT (History)
13 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Sylvain Falardeau 2011-02-02 07:30:13 PST
User-Agent:       Mozilla/5.0 (X11; Linux i686; rv:2.0b10) Gecko/20100101 Firefox/4.0b10
Build Identifier: Mozilla/5.0 (X11; Linux i686; rv:2.0b10) Gecko/20100101 Firefox/4.0b10

When you have an App Tab focused (in my case, Google Calendar) and choose "Open All in Tabs" the first bookmark of the folder replaces the current App Tab content instead of opening a new tab like the other bookmarks.


Reproducible: Always

Steps to Reproduce:
1. Create a folder with two bookmarks (ex: https://www.xgold.ca/ and http://www.xsoli.com/)
2. Focus a App Tab (ex: Google Calendar)
3. Click at "Open All in Tabs" of the folder with the two bookmarks.

Actual Results:  
The App Tab get replaced with https://www.xgold.ca.

Expected Results:  
I think the first bookmark should be opened in a new tab, like the others.
Comment 1 Henrik Skupin (:whimboo) [away 09/30 - 10/06] 2011-02-02 09:25:13 PST
Marco, is it a dupe of bug 440093?
Comment 2 Luke Iliffe (Harlequin99) 2011-02-02 09:40:12 PST
This seems to be the same behaviour and cause as  bug 440093, however now we have app tabs the bug's impact is worse. App tabs are meant to be persistent. 

As bug 579872 has been fixed it would seem consistent to prevent this case of a bookmark from overwriting an app tab.

Shouldn't this (or 440093 if this is dupped) really block bug 579874?
Comment 3 Marco Bonardo [::mak] 2011-02-02 10:04:56 PST
(In reply to comment #1)
> Marco, is it a dupe of bug 440093?

similar but with app-tabs that behavior is really not wanted... I think we should have both bugs open.
Comment 4 Henrik Skupin (:whimboo) [away 09/30 - 10/06] 2011-04-03 17:18:49 PDT
*** Bug 647609 has been marked as a duplicate of this bug. ***
Comment 5 Paul O'Shannessy [:zpao] (not reading much bugmail, email directly) 2011-08-11 13:27:22 PDT
Since bug 440093 landed this is WFM.

Note You need to log in before you can comment on or make changes to this bug.