Run unit tests and talos for mozilla-2.0 releases

RESOLVED FIXED

Status

Release Engineering
General
P3
normal
RESOLVED FIXED
7 years ago
4 years ago

People

(Reporter: jhford, Assigned: armenzg)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [unittest])

Attachments

(1 attachment, 2 obsolete attachments)

Not sure why, because the tests are no longer valid on these machines aiui.
(Assignee)

Comment 1

7 years ago
I will look into it before the next beta.
Assignee: nobody → armenzg
Status: NEW → ASSIGNED
Priority: -- → P3
Whiteboard: [unittest]
(Assignee)

Updated

7 years ago
Priority: P3 → P4

Comment 2

7 years ago
Dupe of bug 630940?
(Assignee)

Comment 3

7 years ago
Created attachment 511505 [details] [diff] [review]
[not tested] remove unit test on the builders for ff4 releases

No, this is not a DUP.

This is the patch needed but I would need to test it to make sure that we would still be creating the packaged tests and do the sendchanges.
(Assignee)

Comment 4

7 years ago
It is not necessary to fix it for the next beta but needs to be fixed.
OS: Linux → All
Priority: P4 → P3
Hardware: x86_64 → All
Comment on attachment 511505 [details] [diff] [review]
[not tested] remove unit test on the builders for ff4 releases

This patch was applied as part of bug 630940.

We still need to get unittest packages uploaded and sendchanges going in this bug.
Attachment #511505 - Attachment is obsolete: true
(Assignee)

Comment 6

7 years ago
Created attachment 525080 [details] [diff] [review]
[mozilla-tests/config.py] add release builders for 2.0 plus u

What do you think?

There is much more we can move to DEFAULTS and RELEASE_DEFAULTS but I would like to keep it simple for this patch.
Attachment #525080 - Flags: review?(lsblakk)
Comment on attachment 525080 [details] [diff] [review]
[mozilla-tests/config.py] add release builders for 2.0 plus u

For right now, I would rather see these release-specific values added to mozilla-2.0 instead since bug 633054 is going to look at a whole config merge
Attachment #525080 - Flags: review?(lsblakk) → review-
(Assignee)

Comment 8

7 years ago
Created attachment 525147 [details] [diff] [review]
[mozilla-tests/config.py] add release builders for mozilla-2.0
Attachment #525080 - Attachment is obsolete: true
Attachment #525147 - Flags: review?(lsblakk)
Comment on attachment 525147 [details] [diff] [review]
[mozilla-tests/config.py] add release builders for mozilla-2.0

good stuff, thanks armen
Attachment #525147 - Flags: review?(lsblakk) → review+
(Assignee)

Updated

7 years ago
Summary: Unit tests still run on builders for FF4 releases → Run unit tests and talos for mozilla-2.0 releases
(Assignee)

Comment 10

7 years ago
Comment on attachment 525147 [details] [diff] [review]
[mozilla-tests/config.py] add release builders for mozilla-2.0

Checked in on "default" with:
http://hg.mozilla.org/build/buildbot-configs/rev/b2eddd6ca339
Attachment #525147 - Flags: checked-in+
(Assignee)

Updated

7 years ago
Duplicate of this bug: 641399
That gets you Talos. I think we need to fix 
  releaseConfig['unittestPlatforms']   = ()
in buildbot-configs/mozilla/release-firefox-mozilla-2.0.py to get unit tests too.
(Assignee)

Comment 13

7 years ago
(In reply to comment #12)
> That gets you Talos. I think we need to fix 
>   releaseConfig['unittestPlatforms']   = ()
> in buildbot-configs/mozilla/release-firefox-mozilla-2.0.py to get unit tests
> too.

That switch is if we want unit tests on the builders which we don't want.
Are you sure ? That's not what it looks like from
 http://mxr.mozilla.org/build/source/buildbotcustom/process/release.py#407
 http://mxr.mozilla.org/build/source/buildbotcustom/process/release.py#634
 http://mxr.mozilla.org/build/source/buildbotcustom/process/release.py#750
and generateTestBuilder() generating builders of class UnittestPackagedBuildFactory.
(Assignee)

Comment 15

7 years ago
That is for unit tests on the builders. Test masters don't use process/release.py.
The only thing needed on the builders is to enable_packages which enables the sendchanges for unit tests.
Test masters only use http://mxr.mozilla.org/build/source/buildbotcustom/misc.py#2607
(Assignee)

Comment 16

7 years ago
This got merged to production with:
http://hg.mozilla.org/build/buildbot-configs/rev/70818a09be7e
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Depends on: 659254
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.