Editing details of an add-on awaiting review should not reset its waiting time

VERIFIED FIXED in 5.12.12

Status

P2
major
VERIFIED FIXED
8 years ago
3 years ago

People

(Reporter: krupa.mozbugs, Assigned: kumar)

Tracking

({regression})

5.12.12
regression

Details

(Whiteboard: [ReviewTeam], URL)

(Reporter)

Description

8 years ago
steps to reproduce:
1. Load https://addons.allizom.org/z/en-US/editors/queue/nominated?sort=waiting_time_days
2. Pick an add-on with waiting time = 6 days (example: アドオンをブラウズアドオンをブラウズ1 1.2)
3. Edit the add-on's details @ https://addons.allizom.org/en-US/developers/addon/%E3%82%A2%E3%83%89%E3%82%AA%E3%83%B3%E3%82%92%E3%83%96%E3%83%A9%E3%82%A6%E3%82%BA%E3%82%A2%E3%83%89%E3%82%AA%E3%83%B3%E3%82%92%E3%83%96%E3%83%A9%E3%82%A6%E3%82%BA1/edit 
4. Notice the waiting time for that add-on in the editor tools

observed behavior:
The waiting time gets reset
Assignee: nobody → kumar.mcmillan
Severity: major → normal
Priority: -- → P3
Target Milestone: 5.12.10 → 5.12.11
(Reporter)

Comment 1

8 years ago
Was this caused by Bug 626452? If yes, then we should fix this for 5.12.9
Ah, whoops, this was a regression.

Note to self: It's a little tricky to fix in the pre-save signal unless we go all out with a class decorator like this: http://justcramer.com/2010/12/06/tracking-changes-to-fields-in-django/  Or we could ditch the signal and handle status changes directly where they occur.
Duplicate of this bug: 634740
Priority: P3 → P2
Target Milestone: 5.12.11 → 5.12.12
Blocks: 634740
The nomination queue is now showing extremely low waiting times.
https://addons.mozilla.org/en-US/editors/queue/nominated
Severity: normal → major
Whiteboard: [required amo-editors]
On a related note, I doubt that all 161 add-ons in the queue were edited in the last few hours, so it looks like there's something else resetting the nomination time.
(In reply to comment #5)
> On a related note, I doubt that all 161 add-ons in the queue were edited in the
> last few hours, so it looks like there's something else resetting the
> nomination time.

It could have been due to a cron script since the bug was triggered anytime an addon was updated.


This has been fixed in https://github.com/jbalogh/zamboni/commit/aa53e28b477ab97a409e6254b4d45b2d7fdfbb69

Now we need to monitor future submissions to be sure it worked.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Nominated queue waiting times were just reset again, apparently about 1-2 hours ago.

https://addons.mozilla.org/en-US/editors/queue/nominated
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
I also noticed (already on Friday, and now again) that search engines are now listed after all extensions.
From my memory, the order of the extensions within themselves seems to be ok, and so is the order of search engines within themselves.
But the order all in all does not seem to be correct.

And yes, I made sure, I didn't accidentially order by "Type".

Maybe this helps finding the issue.
This fix hasn't been pushed to production yet. It will happen until the end of this week. We need to wait for that to be sure the fix works.
Status: REOPENED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → FIXED
(Reporter)

Comment 10

8 years ago
When I edited the add-on awaiting full review, it's waiting time was not reset.

Filed bug 638307 for lite reviews.
Status: RESOLVED → VERIFIED
Keywords: regression
(In reply to comment #9)
> This fix hasn't been pushed to production yet. It will happen until the end of
> this week. We need to wait for that to be sure the fix works.

The waiting times are still incorrect. Some add-ons are now waiting more than 1 month. Please notify developers of the incident via blog or email.
(In reply to comment #11)
> (In reply to comment #9)
> The waiting times are still incorrect. Some add-ons are now waiting more than 1
> month. Please notify developers of the incident via blog or email.

I'm pretty sure these will go away when we fix historic versions.  See bug 638307 for details.  Specifically, see https://bugzilla.mozilla.org/show_bug.cgi?id=638307#c2
Reclassifying editor bugs and changing to a new whiteboard flag. Spam, spam, spam, spam...
Whiteboard: [required amo-editors] → [ReviewTeam]
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.