Bug 632234 (mlk2.0)

[meta] potentially blocking leaks and quasi-leaks for Firefox 4.0

VERIFIED FIXED

Status

()

Core
General
VERIFIED FIXED
7 years ago
6 years ago

People

(Reporter: njn, Unassigned)

Tracking

({meta, mlk})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
A bunch of leak-like bugs have been reported recently, many of which look bad.  

I figure it's useful to have a meta-bug because (a) some or all of them may have the same root cause (b) it'll help communicate the extent of the problem(s).  

I've CC'd everyone who was CC'd to any of the dependent bugs.  Please add any other leak-like bugs I might have missed.

Comment 1

7 years ago
Blocking on this to get it onto the radar of drivers (plus its blocking a bunch of blockers).
blocking2.0: --- → final+
Alias: mlk2.0
Keywords: meta, mlk
(In reply to comment #1)
> Blocking on this to get it onto the radar of drivers (plus its blocking a bunch
> of blockers).

Sigh. We need better tools for coordinating this kind of thing. I agree that release drivers should know that we still want to try to crank down memory usage a bit.

But I believe we normally don't block on meta bugs, and personally I think it's weird and confusing to 'block' on bugs that don't have a clear 'fixed' state.

Comment 3

7 years ago
No strong opinion on it. But I do think this is important.
blocking2.0: final+ → ---
(Reporter)

Comment 4

7 years ago
http://hg.mozilla.org/mozilla-central/rev/0a2e06927c31 just landed for bug 630947.  If this helps with any of the other bugs it'd be great to know.

Updated

7 years ago
Depends on: 632357
Might note 620218 dealing with large memory issue also.
(Reporter)

Comment 6

7 years ago
(In reply to comment #5)
> Might note 620218 dealing with large memory issue also.

Thanks for the pointer.  That bug doesn't look leak-related, AFAICT, and so not relevant for this bug.
Duplicate of this bug: 632807
Bug 624186 has a very simple test case which the submitter says leaks 100% of the time.

Updated

7 years ago
Depends on: 633672
(Reporter)

Updated

7 years ago
Depends on: 624186
Depends on: 633738

Updated

7 years ago
Depends on: 633879
(Reporter)

Updated

7 years ago
Depends on: 633382
(Reporter)

Updated

7 years ago
Depends on: 634155
(Reporter)

Updated

7 years ago
Depends on: 634156
(Reporter)

Updated

7 years ago
Depends on: 634855
(Reporter)

Updated

7 years ago
Depends on: 635121

Updated

7 years ago
No longer depends on: 635121

Updated

7 years ago
Depends on: 635121
(Reporter)

Updated

7 years ago
Depends on: 617569
(Reporter)

Updated

7 years ago
Depends on: 636077
(Reporter)

Updated

7 years ago
Depends on: 636220
(Reporter)

Updated

7 years ago
Depends on: 634642
(Reporter)

Updated

7 years ago
Depends on: 638238

Updated

7 years ago
Depends on: 639186

Updated

7 years ago
Depends on: 639626

Updated

7 years ago
Depends on: 639780
(Reporter)

Comment 9

7 years ago
Now that Firefox 4 RC 1 has gone out, I'm closing this bug and copying all the unresolved bugs over to bug 640452, which is about leaks and quasi-leaks in Firefox 5.  Please CC yourself to that bug if you're interested.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED

Comment 10

6 years ago
Marking as Verified Fixed as per comment 9.
Status: RESOLVED → VERIFIED
(Reporter)

Updated

6 years ago
No longer depends on: 634156
(Reporter)

Comment 11

6 years ago
This bug is being decommissioned in favour of the a new collection of       
per-version leak tracking bugs.  All its dependencies have been removed.    
Bug 659855 is the replacement bug.
You need to log in before you can comment on or make changes to this bug.