Last Comment Bug 633072 - [D2D] consistent few-px failures in SVG-as-an-image tests w/ scaled circles, on Windows with D2D
: [D2D] consistent few-px failures in SVG-as-an-image tests w/ scaled circles, ...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: SVG (show other bugs)
: Trunk
: All Windows 7
: -- normal (vote)
: ---
Assigned To: Robert Longson
:
:
Mentors:
: 594815 (view as bug list)
Depends on:
Blocks: 595482 606693 607003 610081
  Show dependency treegraph
 
Reported: 2011-02-09 19:17 PST by Daniel Holbert [:dholbert]
Modified: 2011-05-15 03:58 PDT (History)
0 users
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
crispEdges (8.15 KB, patch)
2011-05-14 14:08 PDT, Robert Longson
dholbert: review+
Details | Diff | Splinter Review

Description Daniel Holbert [:dholbert] 2011-02-09 19:17:57 PST
On Windows with D2D enabled, some SVG-as-an-image tests fail (i.e. don't quite render the same as an equivalent <embed> or inline SVG).

Generally it's just a few pixels of difference, along one edge of a circle, with the difference being very slight (not really noticeable visually).

These tests are currently marked "random-if(d2d)" (soon to be "fails-if(d2d)", after bug 632754 lands, since they seem to reliably fail (and a few reliably pass).

I'm filing this bug on figuring out what's going wrong here and fixing it if possible.
Comment 1 Robert Longson 2011-05-14 14:08:47 PDT
Created attachment 532466 [details] [diff] [review]
crispEdges
Comment 2 Robert Longson 2011-05-14 14:11:38 PDT
Should fix all the other blocked bugs too.
Comment 3 Daniel Holbert [:dholbert] 2011-05-14 14:44:09 PDT
Comment on attachment 532466 [details] [diff] [review]
crispEdges

Awesome, I hope this works! :)
Comment 4 Robert Longson 2011-05-14 14:52:57 PDT
Try server says it the bees knees... http://tbpl.mozilla.org/?tree=Try&rev=f53d142be9b6 the Android reftest failures there are because that version of the patch didn't mark the reftests as passing.
Comment 5 Robert Longson 2011-05-15 03:19:13 PDT
pushed http://hg.mozilla.org/mozilla-central/rev/35de370ddd83
Comment 6 Robert Longson 2011-05-15 03:58:44 PDT
*** Bug 594815 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.