Less smooth tab close animation with Direct2D enabled

NEW
Assigned to

Status

()

defect
9 years ago
2 years ago

People

(Reporter: dao, Assigned: jrmuizel)

Tracking

(Depends on 2 bugs, Blocks 1 bug, {perf})

Trunk
All
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [painting-perf][Snappy:P2])

+++ This bug was initially created as a clone of Bug #593565 +++

bug 593680 comment 3:
> I experience some of this sluggishness although only with D3D, DirectWrite and
> D2D enabled (which is by default for my hardware).

bug 593565 comment 13:
> Adapter Description: Radeon HD 6800 Series
> Vendor ID: 1002
> Device ID: 6739
> Adapter RAM: 1024
> Driver Version: 8.782.1.0
> Direct2D Enabled: true
> DirectWrite Enabled: true
> GPU Accelerated Windows: 1/1 Direct3D 10
> 
> Disabled hardware accel and tested. With hardware accel disabled opening and
> closing blank tabs the animation is far smoother

bug 593565 comment 32/33:
> I can confirm this. I did a side-by-side comparison in beta 10 with two fresh
> profiles, one of which had gfx.direct2d.disabled set to true. Both windows had
> a blank tab and I repeatedly opened and closed one or two more blank tabs.

> Same with the latest nightly and updated drivers, ATI Radeon HD 4650.
blocking2.0: - → ---
Duplicate of this bug: 593565
My animations are generally pretty laggy, especially closing. Not even close to
as smooth as chrome/opera.
http://www.youtube.com/watch?v=oCSJP9nG7Q8
the end half of the video is the best example of the laginess I usually see, at
the beginning ti decided to behave just to spite me.
win7 64 bit
2GHz core2 duo
4gb ram
512MB Gddr3 mobility hd2600

Adapter Description: Radeon HD 6800 Series
Vendor ID: 1002
Device ID: 6739
Adapter RAM: 1024
Driver Version: 8.782.1.0
Direct2D Enabled: true
DirectWrite Enabled: true
GPU Accelerated Windows: 1/1 Direct3D 10

Disabled hardware accel and tested. With hardware accel disabled opening and
closing blank tabs the animation seemed smoother but still occasionally lagged like in the video. It does seem to be worse with d2d enabled though.
Pasted wrong about:support into in previous comment

Adapter Description: ATI Mobility Radeon HD 2600
Vendor ID: 1002
Device ID: 9581
Adapter RAM: 512
Adapter Driver: saticfx64 aticfx64 aticfx32 aticfx32 atiumd64 atidxx64 atiumdag atidxx32 atiumdva atiumd6a atitmm64
Driver Version: 8.762.0.0
Driver Date: 8-3-2010
Direct2D Enabled: true
DirectWrite Enabled: true (6.1.7600.16699, font cache n/a)
WebGL Renderer: Google Inc. -- ANGLE -- OpenGL ES 2.0 (ANGLE 0.0.0.541)
GPU Accelerated Windows: 1/1 Direct3D 10


The bug effects the machine in the comment above the same though.
Seeing this as well.

Specs,
- Radeon 4250M, Athlon II P340
- NV ION, Atom N270
Whiteboard: [painting-perf]
Whiteboard: [painting-perf] → [painting-perf][Snappy]
Assigning this to Jeff in case it needs to be reprioritized.
Assignee: nobody → jmuizelaar
Whiteboard: [painting-perf][Snappy] → [painting-perf][Snappy:P2]
Blocks: 593680
No longer blocks: 596954
Depends on: 692557
Depends on: 824845
You need to log in before you can comment on or make changes to this bug.