Closed Bug 633725 Opened 9 years ago Closed 9 years ago

docload_wnd.xul (and nsRootAcc_wnd.xul) tries to load about:robots which is Firefox specific (atm)

Categories

(Core :: Disability Access APIs, defect)

defect
Not set

Tracking

()

VERIFIED FIXED
mozilla2.0

People

(Reporter: sgautherie, Assigned: sgautherie)

References

(Blocks 2 open bugs, )

Details

Attachments

(1 file)

http://mxr.mozilla.org/mozilla-central/search?string=about%3Arobots&case=1&find=%2Faccessible%2Ftests%2Fmochitest%2F
{
/accessible/tests/mochitest/events/docload_wnd.xul
    * line 229 -- gQueue.push(new loadURIInvoker("about:robots"));
/accessible/tests/mochitest/name/nsRootAcc_wnd.xul
    * line 91 -- tabBrowser.loadURI("about:robots");
}

Do these tests specifically require about:robots (why?),
or could they just use one of the more common pages listed at about:about, like about:logo or about:rights for example?

*****

Atm, this is causing a perma-orange on SeaMonkey:
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1297485532.1297489043.18251.gz
WINNT 5.2 comm-central-trunk debug test mochitest-other on 2011/02/11 20:38:52
{
2143 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/a11y/accessible/events/test_docload.xul | Test timed out.
}
Blocks: SmTestFail
Assuming about:robots has nothing special here.

Ftr, about:robots has 1 icon and 2 images, about: has 1 image (only).
Assignee: nobody → sgautherie.bz
Status: NEW → ASSIGNED
Attachment #515181 - Flags: review?(marco.zehe)
Comment on attachment 515181 [details] [diff] [review]
(Av1) s/about:robots/about:/g, Replace bug 586818 comment with an explicit todo()
[Checked in: Comment 3]

r=me thanks! This is safe to change since none of the checkers test the tree of the actual document (which is where you'd have to account for testing for 1 versus 2 images).
Attachment #515181 - Flags: review?(marco.zehe) → review+
Comment on attachment 515181 [details] [diff] [review]
(Av1) s/about:robots/about:/g, Replace bug 586818 comment with an explicit todo()
[Checked in: Comment 3]

http://hg.mozilla.org/mozilla-central/rev/5ff5318a9b04
Attachment #515181 - Attachment description: (Av1) s/about:robots/about/g, Replace bug 586818 comment with an explicit todo() → (Av1) s/about:robots/about:/g, Replace bug 586818 comment with an explicit todo() [Checked in: Comment 3]
Blocks: 586818
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
status2.0: ? → ---
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → mozilla2.0
Summary: docload_wnd.xul (and nsRootAcc_wnd.xul) tries to load about:robots which is still +/- Firefox specific → docload_wnd.xul (and nsRootAcc_wnd.xul) tries to load about:robots which is Firefox specific (atm)
(Firefox is still green and)

http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1298775209.1298777746.28772.gz
Linux comm-central-trunk debug test mochitest-other on 2011/02/26 18:53:29
{
2242 INFO TEST-END | chrome://mochitests/content/a11y/accessible/events/test_docload.xul | finished in 3502ms
}

V.Fixed
Status: RESOLVED → VERIFIED
Depends on: 637101
Blocks: 728626
Duplicate of this bug: 598142
Blocks: a11ytestdev
You need to log in before you can comment on or make changes to this bug.