Port |Bug 417302 - about:robots| to SeaMonkey

RESOLVED WONTFIX

Status

--
enhancement
RESOLVED WONTFIX
8 years ago
5 years ago

People

(Reporter: sgautherie, Unassigned)

Tracking

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [good first bug])

Attachments

(1 attachment)

38.73 KB, application/x-xpinstall
Details
(Reporter)

Description

8 years ago
about:robots is used in various tests, including /accessible, /toolkit and /suite:
http://mxr.mozilla.org/comm-central/search?string=about%3Arobots&case=on

Unless these tests would be modified to use some other page, SeaMonkey "needs" to have this page too.

Updated

8 years ago
Whiteboard: [good first bug]
(Reporter)

Updated

8 years ago
Blocks: 633725

Comment 1

8 years ago
Do these tests use the mere existence of about:robots or do they check for specific content? I see no point in having the robot page as such...

Comment 2

8 years ago
Awww. It's cute.
(In reply to comment #1)
> Do these tests use the mere existence of about:robots or do they check for
> specific content? I see no point in having the robot page as such...

I agree, lets figure out a way to change the tests that is acceptable to mozilla-* reviewers, and go from there
Status: NEW → RESOLVED
Last Resolved: 7 years ago
status-seamonkey2.1: ? → ---
Resolution: --- → WONTFIX
(In reply to comment #0)
> about:robots is used in various tests, including /accessible, /toolkit and
> /suite:
> http://mxr.mozilla.org/comm-central/search?string=about%3Arobots&case=on
> 
> Unless these tests would be modified to use some other page, SeaMonkey "needs"
> to have this page too.

Maybe test on about:mozilla (which does exist in SeaMonkey)? Or is the purpose (or one of the purposes) of those tests to give an error on "old" browser versions, which already had about:mozilla but not yet about:robots? Or maybe about:mozilla is too "simple" (only plaintext, not enough gadgets and widgets) for the tests in question?

Updated

5 years ago
No longer blocks: 467530

Comment 5

5 years ago
Created attachment 777234 [details]
aboutrobots-1.3-mod.xpi

aboutrobots-1.3-mod.xpi is based on https://addons.mozilla.org/en-us/mobile/addon/aboutrobots/
(Reporter)

Updated

5 years ago
Duplicate of this bug: 908406
You need to log in before you can comment on or make changes to this bug.