Panorama on heavy AJAX sites will return to tab slower

RESOLVED WONTFIX

Status

defect
P2
trivial
RESOLVED WONTFIX
8 years ago
3 years ago

People

(Reporter: coldreactive, Unassigned)

Tracking

Trunk
x86_64
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b11) Gecko/20100101 Firefox/4.0b11
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b11) Gecko/20100101 Firefox/4.0b11

GMail doesn't count, it doesn't update every second to half second. The link provided has an AJAX Shoutbox, among other AJAX features that are updated per second or so. This causes going to and from Panorama rather choppy and slow (especially with Aero Glass.)

Reproducible: Always

Steps to Reproduce:
1. Open Link provided
2. CTRL+SHIFT+E to Panorama.
Actual Results:  
Choppy transition between tab and panorama.

Expected Results:  
Smoother transition like GMail, Wikipedia and Youtube.

This was tested on a machine with the following specifications:

Processor: AMD Phenom II X6 @ 2.6 GHz
Display: NVIDIA GTX 470 @ 266.58 Driver
RAM: 8 GB
Resolution: 1920 x 1080 (PC)
Default Theme(s) Were Used
(Reporter)

Comment 1

8 years ago
Disabling "Hardware Acceleration when Available" may help. This also can speed up resizing Panorama boxes.

Updated

8 years ago
Version: unspecified → Trunk

Comment 2

8 years ago
Let's see if we can investigate sooner rather than later.
Blocks: 627096
Priority: -- → P2

Comment 3

8 years ago
Can't reproduce on Mac, Windows, or Linux.

Ian are you using any add-ons? How many tabs do you have open?
(Reporter)

Comment 4

8 years ago
(In reply to comment #3)
> Can't reproduce on Mac, Windows, or Linux.
> 
> Ian are you using any add-ons? How many tabs do you have open?

I had about ~4 tabs open, three in one group, and the Aeria games website linked in its own. The choppiness only occured when hardware accel. was on, however. It got progressively better after...

A.) Turning off hardware accel.
B.) Doing it several times with that particular tab / site.
(Reporter)

Comment 5

8 years ago
If you don't have aero glass on, I suggest turning it on to see if it's reproduceable. (When you first turn on aero glass, you will need to restart firefox 4 before panorama adheres to aero glass.)
(Reporter)

Comment 6

8 years ago
The add-ons I was using was colorzilla (reported as working via compatibility by me) and Greasemonkey at the very least.

Comment 7

8 years ago
Reproduceable on:
Mozilla/5.0 (Windows NT 6.1; rv:2.0b12pre) Gecko/20110221 Firefox/4.0b12pre

*Note:
Tested on a clean profile with hardware acceleration in windows disabled and aero off (on the basic windows theme)
[bugspam: betaN -> future]

Sounds like this is confirmed, but relatively minor.
Blocks: 603789
No longer blocks: 627096
Status: UNCONFIRMED → NEW
Ever confirmed: true
Target Milestone: --- → Future

Comment 9

8 years ago
bugspam
Target Milestone: Future → ---
No longer blocks: 603789
bugspam
No longer blocks: 653099
bugspam

(Fx7 was branched, removing open bugs from Fx7 meta bug, we won't create new meta bugs for upcoming Fx versions)
No longer blocks: 660175
Panorama has been removed from Firefox 45, currently in Beta and scheduled for release on March 7th. As such, I'm closing all existing Panorama bugs.

If you are still using Panorama, you will see a deprecation message in Firefox 44, and when 45 is released your tab group data will be migrated to bookmarks, with a folder for each group. There are also a few addons offering similar functionality.

See https://support.mozilla.org/en-US/kb/tab-groups-removal for more info.

We're removing Panorama because it has extremely low usage (about 0.01% of users), and has a large number of bugs and usability issues. The cost of fixing all those issues is far too high to justify, and so we'll instead be focusing our time and energy on improving other parts of Firefox.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.