"closing last tab" inconsistency between main browser window and panorama

VERIFIED FIXED

Status

defect
P2
normal
VERIFIED FIXED
9 years ago
3 years ago

People

(Reporter: florian.neubauer.neuroscience, Assigned: raymondlee)

Tracking

({regression})

Dependency tree / graph

Firefox Tracking Flags

(blocking2.0 -)

Details

Attachments

(1 attachment, 3 obsolete attachments)

User-Agent:       Mozilla/5.0 (Windows NT 6.0; rv:2.0b11) Gecko/20100101 Firefox/4.0b11
Build Identifier: Mozilla/5.0 (Windows NT 6.0; rv:2.0b11) Gecko/20100101 Firefox/4.0b11

In the main window the last tab cannot be closed. In panorama the last tab can be closed and the browser closes quite unexpectedly. Behavior of main window should copied over to panorama.

Reproducible: Always

Steps to Reproduce:
1. Try to close last tab in main browser window --> not possible.
2. Try to close last tab in panorama --> possible, and browser closes.

Actual Results:  
browser closes after closing last tab in panorama

Expected Results:  
last tab cannot be closed, as in main window of the browser

Between FF4-beta-9 and beta-11 there was progress towards more consistency between the main window and panorama. E.g. the last tab group cannot be closed in panorama anymore. In this spirit you should stick with the design decision made for the main browser window: One cannot close the last tab. Just copy this decision over 1:1 to panorama and make it impossible to close the last tab. Then the surprising and unexpected event does not happen anymore that the browser closes after closing the last tab.
Reporter

Comment 1

9 years ago
Implementing this behavior in panorama would have a very positive side effect: If the last tab cannot be closed, you do not need to handle the case anymore what should happen if the last tab group is closed - because it simply could not be closed anymore either. Just as it is already implemented for the case that there are app tabs open. In turn, if you stick with the current decision for the case that there are no app tabs open, which means, that the last tab group actually can be closed and this action ends with an empty tab in the main window, then - again for consistency - closing the last group also should be possible in the case that there are app tabs present, in this case one of the app tabs could be the tab you land in, or - for consistency - an empty tab next to the app tabs. However, I really think that not being able to close the last tab group and not being able to close the last tab whether there are app tabs or not would be the most consistent solution.

Updated

9 years ago
Version: unspecified → Trunk

Comment 2

9 years ago
This is a regression.
Blocks: 627096
Severity: enhancement → normal
Status: UNCONFIRMED → NEW
blocking2.0: --- → ?
Ever confirmed: true
Keywords: regression
Priority: -- → P2
Up until recently (I suppose), Panorama would put you into a new blank tab if you closed the last tab. I propose we fix whatever broke that, in the Fx4 time frame. Post Fx4 we can consider the additional UX suggestions in this bug.
Assignee

Updated

9 years ago
Assignee: nobody → raymond
Assignee

Comment 4

9 years ago
Posted patch v1 (obsolete) — Splinter Review
Attachment #513397 - Flags: review?(ian)
Assignee

Comment 5

9 years ago
Posted patch v1 (obsolete) — Splinter Review
Uploaded a wrong patch
Attachment #513397 - Attachment is obsolete: true
Attachment #513398 - Flags: review?(ian)
Attachment #513397 - Flags: review?(ian)
Comment on attachment 513398 [details] [diff] [review]
v1

Looks good, except I think the new tab should go into the closing tab's parent group (if any, otherwise use the logic you have).
Attachment #513398 - Flags: review?(ian) → review-
Status: NEW → ASSIGNED
Assignee

Comment 7

9 years ago
Posted patch v2 (obsolete) — Splinter Review
Attachment #513398 - Attachment is obsolete: true
Attachment #513754 - Flags: review?(ian)
Comment on attachment 513754 [details] [diff] [review]
v2

Thanks!
Attachment #513754 - Flags: review?(ian) → review+
Assignee

Updated

9 years ago
Attachment #513754 - Flags: approval2.0?
Comment on attachment 513754 [details] [diff] [review]
v2

a=beltzner
Attachment #513754 - Flags: approval2.0? → approval2.0+
Attachment #513754 - Attachment is obsolete: true
http://hg.mozilla.org/mozilla-central/rev/9fad1f22f556
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Keywords: checkin-needed
Resolution: --- → FIXED

Comment 13

8 years ago
Mozilla/5.0 (X11; Linux i686; rv:2.0b13pre) Gecko/20110224 Firefox/4.0b13pre

Verified issue and it's no longer present in latest build.
Status: RESOLVED → VERIFIED

Updated

7 years ago
Duplicate of this bug: 633787
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.