Exiting Fullscreen Panorama will break tabs in titlebar

RESOLVED WONTFIX

Status

defect
P2
normal
RESOLVED WONTFIX
8 years ago
3 years ago

People

(Reporter: Ryuji, Unassigned)

Tracking

Trunk
x86
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [4b12])

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b12pre) Gecko/20110205 Firefox/4.0b12pre
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b12pre) Gecko/20110205 Firefox/4.0b12pre

perform STR 

Reproducible: Always

Steps to Reproduce:
1. Enter Panorama
2. Fullscreen by pressing F11
3. press to focus on a tab in a tab group
4. it is still in fullscreen
5. exit fullscreen 
6. You will realised that tabs are no longer in the titlebar
(Reporter)

Updated

8 years ago
Summary: Fullscreen in panorama will break tabs in titlebar → Exiting Fullscreen Panorama will break tabs in titlebar

Comment 1

8 years ago
Mozilla/5.0 (Windows NT 6.1; rv:2.0b12pre) Gecko/20110212 Firefox/4.0b12pre

Confirmed. Tabs are not longer in the title bar after exiting full screen.
Component: Tabbed Browser → TabCandy
QA Contact: tabbed.browser → tabcandy
Version: unspecified → Trunk
Status: UNCONFIRMED → NEW
Ever confirmed: true
Blocks: 627096
Priority: -- → P2

Comment 2

8 years ago
Mozilla/5.0 (Windows NT 6.1; rv:2.0b12pre) Gecko/20110215 Firefox/4.0b12pre

Works For Me. STRs unclear

Comment 3

8 years ago
Jason, Aravidnm: are you still getting this?
I can confirm the problem on the latest Minefield and Win 7. What you should be looking for is where the tab appears in relation to the Firefox/Minefield button. In a normal start, tabs will appear on the same horizontal line (more or less) as the Firefox button, but if you follow the steps in comment #0, the tabs will appear below this line. So you end up having some extra space between tabs and title bar.

Restarting the browser will bring it back to normal.
Whiteboard: [4b12]
(Reporter)

Comment 5

8 years ago
Yes... 

Clearer STR  
1. Enter Panorama View from Normal Firefox browsing
2. Press F11 in Panorama View to enter full screen
3. Press One tab in any of your Panorama group
4. you will realise that it is still full screen in the tab that you have focused on. 
5. exit the full screen mode by pressing F11
6. you will realise that the tabs are no longer in the titlebar.
Component: TabCandy → Tabbed Browser
Priority: P2 → --
Version: Trunk → unspecified
Component: Tabbed Browser → TabCandy
Priority: -- → P2
Version: unspecified → Trunk
Assignee: nobody → tim.taubert
Status: NEW → ASSIGNED
Posted patch patch v1Splinter Review
The problem is: when switching to non-fullscreen-mode after returning from panorama the "sizemode" critieria for TabsInTitleBar.allowedBy() does not change its value and therefore doesn't fire TabsInTitleBar._update().

I implemented another "fullscreen" criteria that is handled in Fullscreen.toggle()

Another possibility would have been to change http://mxr.mozilla.org/mozilla-central/source/browser/base/content/browser.js#5021 to:

TabsInTitlebar.allowedBy("sizemode", sizemode == "maximized");

and http://mxr.mozilla.org/mozilla-central/source/browser/base/content/browser.js#5061 to:

if (!this._initialized)

Unfortunately this seems to fire too early so gNavToolbox's margin-bottom is not calculated correctly.
Attachment #513965 - Flags: review?(dao)
Attachment #513965 - Flags: review?(dao)
[bugspam: betaN -> final]

Should get fixed by patch for bug 626976, which has been set to final. So it's totally up to that bug's fate. If we punt on that one, we punt on this too, though.
Blocks: 585689
No longer blocks: 627096
OS: Windows 7 → Windows XP
OS: Windows XP → Windows 7
Punting, as per IRC discussion with Tim.
Blocks: 603789
No longer blocks: 585689
Target Milestone: --- → Future

Comment 9

8 years ago
bugspam
Target Milestone: Future → ---
No longer blocks: 603789
bugspam
No longer blocks: 653099
bugspam

(Fx7 was branched, removing open bugs from Fx7 meta bug, we won't create new meta bugs for upcoming Fx versions)
No longer blocks: 660175
Assignee: ttaubert → nobody
Panorama has been removed from Firefox 45, currently in Beta and scheduled for release on March 7th. As such, I'm closing all existing Panorama bugs.

If you are still using Panorama, you will see a deprecation message in Firefox 44, and when 45 is released your tab group data will be migrated to bookmarks, with a folder for each group. There are also a few addons offering similar functionality.

See https://support.mozilla.org/en-US/kb/tab-groups-removal for more info.

We're removing Panorama because it has extremely low usage (about 0.01% of users), and has a large number of bugs and usability issues. The cost of fixing all those issues is far too high to justify, and so we'll instead be focusing our time and energy on improving other parts of Firefox.
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.