Zooming into Tab Groups broken upon first invocation

RESOLVED WONTFIX

Status

defect
P3
normal
RESOLVED WONTFIX
8 years ago
3 years ago

People

(Reporter: kdevel, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (X11; Linux x86_64; rv:2.0b12pre) Gecko/20110216 Firefox/4.0b12pre

The first invocation does not correctly scale (zoom) the tab content. 

Reproducible: Always

Steps to Reproduce:
1. open http://www.spiegel.de
2. invoke Group Tabs
3.
Actual Results:  
While "zooming" into panorama screen contains images which do not result from proper scaling of the original tab's content.

Expected Results:  
Scale properly.

The first bad revision is:
changeset:   62431:fa4b85882789
user:        Michael Yoshitaka Erlewine <mitcho@mitcho.com>
date:        Fri Feb 11 14:24:51 2011 -0500
summary:     Bug 631747 - Minimize DOM manipulation on startup/TabItem-creation [r=ian, a=dietrich]
(Reporter)

Comment 1

8 years ago

Comment 2

8 years ago
Do you have HW acceleration enabled?

Updated

8 years ago
Blocks: 627096
Priority: -- → P3
(Reporter)

Comment 3

8 years ago
Yes. Behaves identical when disabled.

Comment 4

8 years ago
Mozilla/5.0 (X11; Linux i686; rv:2.0b12pre) Gecko/20110218 Firefox/4.0b12pre

I can confirm that when loading for the first time Panorama, last opened thumbnail has the behavior  presented in the Description - appears broken, but then in a matter of a second or two it refreshes and displays what it should.
Status: UNCONFIRMED → NEW
Ever confirmed: true
This _could_ be fixed with the patch from bug 635737 as this is also a regression of bug 631747. Stefan, could you please try to apply the patch?
Bug 635737 landed. Can someone confirm?

Otherwise: [bugspam betaN -> future]
Blocks: 603789
No longer blocks: 627096
Depends on: 635737
Target Milestone: --- → Future

Comment 7

8 years ago
bugspam
Target Milestone: Future → ---
No longer blocks: 603789
bugspam
No longer blocks: 653099
(Reporter)

Comment 10

8 years ago
(In reply to comment #5)
> This _could_ be fixed with the patch from bug 635737 as this is also a
> regression of bug 631747. Stefan, could you please try to apply the patch?

In the meantime the stripes visible in the screenshots became big squares when entering tab groups for the first time.

I had to apply the patch from bug 635737 manually, despite of 
https://bugzilla.mozilla.org/show_bug.cgi?id=635737#c11
the code is not in my repository.

The patch does not change the issue.
bugspam

(Fx7 was branched, removing open bugs from Fx7 meta bug, we won't create new meta bugs for upcoming Fx versions)
No longer blocks: 660175
Panorama has been removed from Firefox 45, currently in Beta and scheduled for release on March 7th. As such, I'm closing all existing Panorama bugs.

If you are still using Panorama, you will see a deprecation message in Firefox 44, and when 45 is released your tab group data will be migrated to bookmarks, with a folder for each group. There are also a few addons offering similar functionality.

See https://support.mozilla.org/en-US/kb/tab-groups-removal for more info.

We're removing Panorama because it has extremely low usage (about 0.01% of users), and has a large number of bugs and usability issues. The cost of fixing all those issues is far too high to justify, and so we'll instead be focusing our time and energy on improving other parts of Firefox.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.