Stop build (incl. cancellator and self-serve) prevents machines from rebooting

RESOLVED FIXED

Status

Release Engineering
General
P2
normal
RESOLVED FIXED
6 years ago
4 years ago

People

(Reporter: catlee, Assigned: catlee)

Tracking

({buildapi})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [buildbot][self-serve])

(Assignee)

Description

6 years ago
A recent buildbot upgrade changed alwaysRun steps to instead be almostAlwaysRunExceptWhenStopBuildUsed.

This means that when builds or tests are stopped via the 'Stop Build' button, which can happen manually, via cancellator, or self-serve, the machines don't run the reboot step at the end of the job.

This is particularly bad for test jobs, since extra processes are often left running that interfere with future tests.

I recommend changing cancellator and self-serve to not stop running tests for the moment. I believe stopping running builds is mostly safe.
Do you know what change affected that?
(Assignee)

Comment 2

6 years ago
(In reply to comment #1)
> Do you know what change affected that?

https://github.com/buildbot/buildbot/commit/e0d4533f962a51c60456a5a4fd1a5b4d6dee3c1d

Curse the guy who committed that!
(Assignee)

Updated

6 years ago
Depends on: 634605
Duplicate of this bug: 634535
(Assignee)

Updated

6 years ago
Whiteboard: [buildbot][self-serve]
(Assignee)

Updated

6 years ago
Duplicate of this bug: 649424
(Assignee)

Updated

6 years ago
Duplicate of this bug: 649421
(Assignee)

Comment 6

6 years ago
Test jobs are now killable again
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED

Updated

5 years ago
Keywords: buildapi
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.