Closed Bug 634620 Opened 9 years ago Closed 9 years ago

In Compose Window: Renaming an attached file removes its displayed file size

Categories

(Thunderbird :: Message Compose Window, defect)

x86
Windows 7
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 3.3a3

People

(Reporter: dfghjkjhg, Assigned: squib)

References

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:2.0b12pre) Gecko/20110214 Firefox/4.0b12pre
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b12pre) Gecko/20110216 Thunderbird/3.3a3pre

As soon as you rename an attached file in the compose window, 
the attached file's originally displayed file size disappears.

Reproducible: Always

Steps to Reproduce:
1. Open a new compose Window
2. Attach a file (the file size will be displayed immediately)
3. Rename the attachment (right-click on the attached file - choose "rename")
4. File gets renamed, but its file size disappears
Taking this since it's my fault and it's really easy to fix, though any changes here will probably be rendered irrelevant by bug 630759.
Assignee: nobody → squibblyflabbetydoo
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attached patch Fix thisSplinter Review
Not much to say here. This fixes the issue and adds a mozmill test to check it. :Bienvenu, I asked you for review since you reviewed the patch that caused this issue (bug 195702). Feel free to pass it on to someone else if need be.
Attachment #512957 - Flags: review?(bienvenu)
Comment on attachment 512957 [details] [diff] [review]
Fix this

thx, Jim.
Attachment #512957 - Flags: review?(bienvenu) → review+
Adding checkin-needed
Keywords: checkin-needed
Checked in: http://hg.mozilla.org/comm-central/rev/d99a6acbe0a9
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 3.3a3
Flags: in-testsuite+
Version: unspecified → Trunk
No longer blocks: 636185
You need to log in before you can comment on or make changes to this bug.