Fx4 back button context menu allows right-click, causes duplicate menu

RESOLVED DUPLICATE of bug 631954

Status

()

--
minor
RESOLVED DUPLICATE of bug 631954
8 years ago
8 years ago

People

(Reporter: cab26715, Unassigned)

Tracking

({regression})

Trunk
x86
Windows 7
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b12pre) Gecko/20110220 Firefox/4.0b12pre
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b12pre) Gecko/20110220 Firefox/4.0b12pre

A duplicate previous tabs list appears if I right-click one of the entries within the Back Button.

Reproducible: Always

Steps to Reproduce:
1. Browse the Internet in the same tab.
2. Click and hold the left mouse button on the Back Button until you get the previous tabs list.
3. Right-click one of the tab entries.
4. A duplicate menu will appear, containing the exact same entries as the current menu.  See screenshot.
Actual Results:  
Duplicate menu appears.

Expected Results:  
Nothing should happen with a right-click command.
(Reporter)

Comment 1

8 years ago
Created attachment 513884 [details]
Duplicate Menu Appears
(Reporter)

Updated

8 years ago
Summary: Duplicate previous tabs list appears during right-click action → Duplicate previous tabs list appears during right-click action within Back Button

Comment 2

8 years ago
Confirmed with Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b12pre) Gecko/20110220 Firefox/4.0b12pre ID:20110220030351

Not possible to do the same in 3.6.13.

Note: Inbetween steps 2 and 3 in comment 0, don't release the left mouse button before right clicking.
Status: UNCONFIRMED → NEW
Component: General → XP Toolkit/Widgets: Menus
Ever confirmed: true
Keywords: regression
Product: Firefox → Core
QA Contact: general → xptoolkit.menus
Version: unspecified → Trunk

Updated

8 years ago
URL: N / A
(Reporter)

Comment 3

8 years ago
(In reply to comment #2)
> Confirmed with Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b12pre) Gecko/20110220
> Firefox/4.0b12pre ID:20110220030351
> 
> Not possible to do the same in 3.6.13.
> 
> Note: Inbetween steps 2 and 3 in comment 0, don't release the left mouse button
> before right clicking.

Ed,

This also occurs if I release the mouse between steps 2 and 3, like so:

2. Click and hold the left mouse button on the Back Button until you get the
previous tabs list.
2a. Release mouse button.
3. Right-click one of the tab entries.

Comment 4

8 years ago
Actually yes, you're right, you can release the left mouse button as long as you don't move downwards before doing so.

Regression range...

Last good nightly: 2010-10-18 
First bad nightly: 2010-10-19

Pushlog: 
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=cfd18201f49b&tochange=c9df0c5cbf8c

Bug 582485 - Remove history dropdown arrow behind back button r=gavin a=sdwilsh
http://hg.mozilla.org/mozilla-central/rev/664dc9adfcf5

Left clicking and holding the old dropdown (that existed prior to bug 582485) doesn't let you create the second context menu. Only the new implementation does.
Blocks: 582485
Severity: normal → minor
Summary: Duplicate previous tabs list appears during right-click action within Back Button → Fx4 back button dropdown allows right-click, causes double dropdown

Updated

8 years ago
Summary: Fx4 back button dropdown allows right-click, causes double dropdown → Fx4 back button context menu allows right-click, causes duplicate menu

Updated

8 years ago
Component: XP Toolkit/Widgets: Menus → General
Product: Core → Firefox
QA Contact: xptoolkit.menus → general
No longer blocks: 582485
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 631954

Comment 6

8 years ago
Whoops sorry, forgot to check bug 582485's dependencies for similar items.
You need to log in before you can comment on or make changes to this bug.