Closed Bug 582485 Opened 9 years ago Closed 9 years ago

Remove history dropdown arrow behind back button

Categories

(Firefox :: General, defect, trivial)

x86_64
Windows 7
defect
Not set
trivial

Tracking

()

RESOLVED FIXED
Tracking Status
blocking2.0 --- -

People

(Reporter: imradyurrad, Assigned: Margaret)

References

(Depends on 1 open bug)

Details

(Keywords: ux-minimalism)

Attachments

(1 file, 2 obsolete files)

User-Agent:       Mozilla/5.0 (Windows; Windows NT 6.1; rv:2.0b3pre) Gecko/20100727 Minefield/4.0b3pre
Build Identifier: Mozilla/5.0 (Windows; Windows NT 6.1; rv:2.0b3pre) Gecko/20100727 Minefield/4.0b3pre

The mockups don't have it and you can also access the same function by right-clicking on the back/forward button

Reproducible: Always
Keywords: ux-minimalism
Hardware: x86 → x86_64
Version: unspecified → Trunk
Blocks: 578025
Blocks: 544823
No longer blocks: 578025
Is there data on how much this button is used?
https://heatmap.mozillalabs.com/mozmetrics/?data=perc&colorscheme=hsl&skill=all&os=all

mmm if I'm right in guessing it's "Recent Pages Drop Down", it's used a lot.
So UX people: should this be removed or kept?
Hm, no data from the most recent study: https://heatmap.mozillalabs.com/index.html

I'm actually not sure, we'll need to start tracking this.
Should we add a parity-ie (for IE9) in the whiteboard ?
(In reply to comment #4)
> Hm, no data from the most recent study:
> https://heatmap.mozillalabs.com/index.html
> 
> I'm actually not sure, we'll need to start tracking this.

I think it is "28% Recent History Drop Down".  The coloring just isn't shown in the image.  There are two 28% in the list on the right and the list all tabs is the only 25% shown in the image.
we can have Chrome like functionality , hold click on back to get the drop down menu , what say?
This is also what happens in IE9.
There's already the right click.
All browsers do this, and we should too. I thought we already were doing this, but maybe it's just on OS X for now?

This has always been the intention as part of the theme update.
We're only doing it for OS X right now.
Yeah I concur, let's remove it (sorry for the lack of clarity, I was originally very aggressively trying to remove it for Firefox 3, and then waffled a bit in comment #4).  The timer for press and hold in IE9 feels way too long, so we'll need to get that right.  Also do we need to consider situations where a page redirect makes it impossible to go back?
(In reply to comment #12)
> Also do we need to consider situations where a page
> redirect makes it impossible to go back?

I can't see a reason to ever display redirects in the back button history. You didn't visit that page, the browser did it for you.
No, I mean change the behavior of hitting back in the case of a redirect.  What I'm worried about is users who don't know the history list exists (haven't discovered right click or press and hold), and then they have this behavior:

hit back, redirect forward
hit back, redirect forward
hit back, redirect forward
[start thrashing back button]
[possibly get back twice before the redirect triggers]
(In reply to comment #14)
> No, I mean change the behavior of hitting back in the case of a redirect.  What
> I'm worried about is users who don't know the history list exists (haven't
> discovered right click or press and hold), and then they have this behavior:
> 
> hit back, redirect forward
> hit back, redirect forward
> hit back, redirect forward
> [start thrashing back button]
> [possibly get back twice before the redirect triggers]

Right, redirects shouldn't be entries in the history in any way. Clicking the back button and hitting a redirect shouldn't be possible, it shouldn't be in the stack at all.

(Or am I still not getting what you're trying to explain? :)
> Right, redirects shouldn't be entries in the history in any way. Clicking the
> back button and hitting a redirect shouldn't be possible, it shouldn't be in
> the stack at all.


Is there a bug already filed for this?
Summary: Remove history dropdown arrow behind back button. → Remove history dropdown arrow behind back button
Assignee: nobody → margaret.leibovic
Attached patch patch (obsolete) — Splinter Review
This gets rid of the history dropmarker on both windows and linux.
Attachment #481372 - Flags: review?(dolske)
Rather than just hiding it, why not remove back-forward-dropmarker entirely? That would make the BrowserToolboxCustomizeDone code unnecessary, and you can keep its menupopup outside and give it an ID so that the SetClickAndHoldHandlers code continues to work.
Attached patch patch v2 (obsolete) — Splinter Review
Got rid of the dropmarker element, as per gavin's suggestion.
Attachment #481372 - Attachment is obsolete: true
Attachment #481677 - Flags: review?(gavin.sharp)
Attachment #481372 - Flags: review?(dolske)
The popup should probably move to mainPopupSet.
Also note that there's already a "backForwardMenu".
Flags: in-litmus?
Some rando-comments:
- the backForwardMenu.tooltip string is now unused
- I wonder whether we can just have the cloning code use backForwardMenu instead. It seems to work OK on Mac, but not sure whether the position="after_start" is needed on other platforms (I don't think context="" has any effect on menupopups...). If we do that the event.stopPropagation(); could probably move into gotoHistoryIndex(), or just be copied over to backForwardMenu
Attached patch patch v3Splinter Review
Using backForwardMenu works. I didn't add position="after_start", but the menu is working without it (testing on Windows 7). I'll test on Linux to make sure that works as well.
Attachment #481677 - Attachment is obsolete: true
Attachment #481944 - Flags: review?(gavin.sharp)
Attachment #481677 - Flags: review?(gavin.sharp)
blocking2.0: --- → ?
Whiteboard: [needs review gavin]
Attachment #481944 - Flags: review?(gavin.sharp) → review+
Whiteboard: [needs review gavin] → [can land]
Attachment #481944 - Flags: approval2.0+
Whiteboard: [can land] → [needs checkin]
http://hg.mozilla.org/mozilla-central/rev/664dc9adfcf5
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Whiteboard: [needs checkin]
Also pushed a test bustage fix: http://hg.mozilla.org/mozilla-central/rev/bc113afb29a8
this is not easily discoverable... I had to find the bug...
can I suggest editing the tooltip to say hold for list or something
Holding down or right-clicking is not properly discoverable...

I could understand if the menu was just a time-saving feature, but what happens when an inexperienced user needs to go back two pages to skip a page with postdata or a poorly-done redirect? They'll likely give up and be very frustrated.
Holding down or right-clicking is not properly discoverable...

I could understand if the menu was just a time-saving feature, but what happens
when an inexperienced user needs to go back two pages to skip a page with
postdata or a poorly-done redirect? They'll likely give up and be very
frustrated.

Exactly.
Please don't spam a fixed bug. If you feel that such a tooltip should be added, please file a new bug and mark it as a dependency of this one.
Please consider Bug 606878, this is a big deal for some theme authors as well as users.
Depends on: 606888
blocking- on this already-fixed bug. if it were re-opened today, i don't think the ui-minimalism-win is big enough that we should hold the entire release on it.
blocking2.0: ? → -
I also cannot say that I am a fan of the change implemented by this bug.

If using a laptop touchpad on Windows and have it set so that tapping performs a click, then simply tapping on the drop-down arrow was an easy and ergonomic way to access the recent history. Now you either have to long-click (non-discoverable, slow, and difficult if just using a touchpad) or right-click (less discoverable, less ergonomic as requires you to reach and press **** a physical button below the touchpad).
"Clicking the
back button and hitting a redirect shouldn't be possible, it shouldn't be in
the stack at all."

You're kidding!  This happens all the time.  Is there a bug for it?  Blaming it on poorly written HTML doesn't solve the problem.

The tooltip still says "Go back one page".  Not very helpful for a button that is now supposed to incorporate multi-page history traversal.  Do I have to raise a bug because this change wasn;t made properly?
>You're kidding!  This happens all the time.  Is there a bug for it?  Blaming it
>on poorly written HTML doesn't solve the problem.

No one's blaming it on poorly written HTML, we need to follow up with a bug to make sure that we don't place pages that redirect into the stack.
Depends on: 614932
follow up bug 615306 for fixing the redirect problem
Depends on: 619930
Depends on: 635631
No longer depends on: 635631
I have to say that this Feature Removal, has created a bug in itself.
The third button from the left, ie the history dropdown is one of the most used buttons in firefox.   It is KEY to navigation.

Since some websites use redirects or whatnot, sometime the only way to go backwards is to skip several levels of the back button.   

Yes I understand that you can use the right click and or click and hold.  Both of these options are slower for all, and a burden to both laptop users and people with disabilities using non-hand based mousing.

This button should be retained as an available icon.  As the third poster TAZ says, this button is used a lot.  It is similar to a reverse gear in a car, its used a lot.

By removing this ICON-button, themes no longer support, making corrective add-ons...not easily THEMEABLE

---
You had heavily used functionality working properly, instead of adding features, you removed features.   This is the classic, if its NOT BROKEN DON'T FIX it.   This solution is a problem...and should be reopened quickly so people don't waste time building themes that need to be updated again.

Add-on is not a solution to the havoc this "bug" created, it needs to be replaced in the default standard Firefox build.
(In reply to comment #36)
> Yes I understand that you can use the right click and or click and hold.  Both
> of these options are slower for all, and a burden to both laptop users and
> people with disabilities using non-hand based mousing.

In Chrome, you can pull down the Back/Forward history by clicking and dragging the Back or Forward button, without any need to hold first. This behaviour should probably be adopted.

Should I file a bug on this issue (if there isn’t one already)?
(In reply to comment #37)
> (In reply to comment #36)
> > Yes I understand that you can use the right click and or click and hold.  Both
> > of these options are slower for all, and a burden to both laptop users and
> > people with disabilities using non-hand based mousing.
> 
> In Chrome, you can pull down the Back/Forward history by clicking and dragging
> the Back or Forward button, without any need to hold first. This behaviour
> should probably be adopted.

Please do


> 
> Should I file a bug on this issue (if there isn’t one already)?
Depends on: 647886
(In reply to comment #38)
> Please do

Done. I’ve filed bug 647886 (my first bug!).
Please consider reopening this bug and reverting to the old behavior. You can see on the regular Firefox Support Forums (mostly non-techie users) that the removal of this feature caused quite a bit of concern and hassle. Even though it now "matches Chrome" ... is this a GOOD thing? Wasn't the point of Phoenix/Firebird/Firefox to be DIFFERENT (and BETTER) than other browsers? It seems as though this was not properly checked to see if it was a feature other users needed/wanted before being arbitrarily wiped out. If you read your own comments above, it appears that possibly 28% used this feature... wiping it out makes for MANY unhappy users.

If this is something that normal users could change back by a setting in a .css file or about:config, I would appreciate hearing how to do so, because it is a large annoyance to me personally as well.
or ... if the single combined dropmarker is no longer to be supplied, revert to separate context menus for the back and forward buttons.  The correspondence between back/forward navigation buttons and the up/down list was tenuous at best, confusing at worst.  The infrequent use of this feature means there is little opportunity to become familiar with the current complex listing.  Since the menus are now tied solely to either the back button or the forward button, they should now show either the back history or the forward history leading to less confusion.
>Wasn't the point of
>Phoenix/Firebird/Firefox to be DIFFERENT (and BETTER) than other browsers?

Phoenix was a fork to drastically slim down the browser and reduce UI clutter that accumulated over time in the Mozilla Suite, primarily due to the process by which design decisions were made.  Going rogue was the only way for Phoenix to achieve a simple and elegant interface aimed and mainstream users in an environment were it was otherwise impossible to remove features.

So while I get that you find this change frustrating, the exact example of Phoenix isn't necessarily the best argument here.

Now that Firefox 4 has launched mainstream users are having no trouble with this change, and there is very little chance of us reopening the bug.
(In reply to comment #42)

> Now that Firefox 4 has launched mainstream users are having no trouble with
> this change, and there is very little chance of us reopening the bug.

Not entirely true IMHO,many(clearly,less tech-inclined folks)have been asking on various support boards\mailing lists what happened to this feature and why they now can go back "only one page at time"-if such a change was to be adopted,why not add the tooltip right from the start,just like Chrome?
I'm technical, and I use it a lot. At the minimum, give the users a choice of 2 buttons under Customize Toolbar--with extra features or without. It's worth the extra 3 pixels for me. I don't want to wait 1 second for the long-press to bring it up, and right-click was not intuitive--i had to google it.(In reply to comment #43)
> (In reply to comment #42)
> 
> > Now that Firefox 4 has launched mainstream users are having no trouble with
> > this change, and there is very little chance of us reopening the bug.
> 
> Not entirely true IMHO,many(clearly,less tech-inclined folks)have been asking
> on various support boards\mailing lists what happened to this feature and why
> they now can go back "only one page at time"-if such a change was to be
> adopted,why not add the tooltip right from the start,just like Chrome?
> 
> Now that Firefox 4 has launched mainstream users are having no trouble with
> this change, and there is very little chance of us reopening the bug.

That logic is pure fallacy.  Just because something has launched does not mean users are not having issues with it.  Users are not a homogenous blob.  There is something called early-adopters, which you are hearing feedback from now.  

You have no clue to how many users upgraded and downgraded, how many people are not upgrading until the 5th update of version.  Historically the first several updates of a new version of Firefox and bug laden, and many don't upgrade until later.

The history dropdown was not a bug, it was a designed feature, which was the third button from left, and one of the most used buttons on Firefox by far.  Probably 25 times used more than the Home button.

It is error to remove working designed functionality via a bug sheet.  The removal of the button was ill-conceived and done over the objects raised in the bug sheet itself.  

Going Rogue a problem, in this case it short circuits the entire software development process.   

It bad enough to use a bugsheet to remove working functionality....its far worse to insist that since its been done, that its now not a problem, then have other developers suggest that people use workaround patches, and then its ultimate the worst for developers to make changes in isolation, then after those changes, declare that the issue is not to be revisited, or opening up the bug again.

The only explanation of can come up for why this cluster is being forced upon users, is that ego is preventing the self-admission of error, and making all sorts of justifications for why its not an error at all.   Its in a tuxedo, that bug is a feature.
>Users are not a homogenous blob.  There
>is something called early-adopters, which you are hearing feedback from now.  

Trying to form the conclusion that 31 people cc'd to a bug (or some limited tech press coverage) is in anyway representative of 400 million people is more of a logical fallacy.

>The only explanation of can come up for why this cluster is being forced upon
>users, is that ego is preventing the self-admission of error

When we make an error for hundreds of millions of users, it's honestly really obvious.  This simply wasn't an instance of that.
I have to say this is dumb. The long-press is not part of the UI lexicon on Windows at least, and so this behaviour is by definition counter to expectations, and counter to the behaviour of other commonly used applications with similar controls. Even within Firefox, most button actions happen when you release the button, regardless of how long you hold it down for; this is the expected behaviour. I frequently press the back button down while still reading a page, then release it when I'm done to go back quickly; now that doesn't happen in Firefox 4. By all means add the feature, but for Christ's sake add an option to turn the behaviour off without having to kludge it.
I've been using Firefox for years now, and completely ditched IE - which I originally used as a total newbie to computers - Have just signed up specifically to comment on this "bug" - realise it's Status is now "Resolved".

Just wanted to totally 100% agree with Furtrader's comment (45) - 

"The history dropdown was not a bug, it was a designed feature, which was the third button from left, and one of the most used buttons on Firefox by far.  Probably 25 times used more than the Home button.

It is error to remove working designed functionality via a bug sheet.  The removal of the button was ill-conceived and done over the objects raised in the bug sheet itself."

Thinking of trying Chrome - just to see the differences now!
Depends on: 700975
IMO removing the dropdown arrow is totally no sense... no chance the dropdown arrow can be added back as an optional separate toolbar control that users may add by using "customize toolbar"?
I concur. This is beyond a minor annoyance. 

I created this account specifically to express my frustration for the lack of the recent pages menu. A script running on a site I was on cleared my forward history after I tried clicking my back button to get away from the running script. All my search results and research in the order I was researching was lost. I'm running multiple browsers each with multiple tabs open. Being forced to navigate history (ctrl-H) when I could have simply clicked the drop down menu in older versions of ff is a real pain.

Why post so late after the thread had been started? Because today I reluctantly upgraded to ff 12.0 from 3.6.x only because an add-on I used needed to be upgraded. Otherwise I would have stuck with 3.6.x version. I had upgraded to 4.0 back when 4.0 was released but uninstalled it and reinstalled and older version because of incompatibility issues. Now I'm stuck with no choice but to endure a couple features that make ff not as useful today as it was yesterday :(

On top of that frustration, now there is no clear advantage to using ff since it no longer supports the add-ons I use daily.

Yeah, I'm a business power user and one of an estimated 800,000 MCPs, not the pock-faced kid next door who uses the web to surf games and youtube vids.

Please bring back this feature. When the history is cleared by a web script, long holding the back button doesn't work and manually going into the history (ctl-h) is a pain for serious power users.

Oh. I do like the speed improvement in v 12. Hugely noticeable difference. But the incompatibility issues (crashes) with certain now disable add-ons and the lack of a 'recent pages' button does not give ff any advantage over other browsers like Comodo Dragon and Dell Kace, both of which I think are built on firefox 3.6 platforms.

Please please bring back the feature we seriously notice is missing.

thx
ff 12.0. Win7-64. Dell XPS Studio 1647
(In reply to dawgd5926 from comment #50)
> Please please bring back the feature we seriously notice is missing.

The feature you are missing can be found now as an Add-on and is named:
Back/forward dropmarker 1.0

This is the URL:
https://addons.mozilla.org/en-us/firefox/addon/backforward-dropmarker/

Hope that helps!
Cheers
I am aware of drop marker.   There are some skins that account for it, most do not, and even more that once did, no longer support it as the never ending Firefox new releases hit every 6 weeks.

The problem is that this was a main button that was removed for invalid reasons.  Programmers who refuse to admit they removed an essential function (again they removed the option to surf with a single finger easily) refuse to add a toggle to put the feature back.

Many people say this is an essential feature, others say they is a kluge of a work around.   

Right mouse and scroll down does not work with a single finger, it removes point and click functionality.

Hold button down, does not work with a trackpad only.   You need to use more buttons.   And it takes 5 times as long for that function.  

Nobody has ever provided a reason why a toggle should not be standardized into Firefox.   Look at all the tab toggles.
(In reply to futraders from comment #52)
I completely agree with you.
My opinion, the simplest solution to see this feature as an option the user could decide himself to enable it or not.
If an Add-on can do the "trick", why not Mozilla?

The problem will be to convice them.
Hopefully a developer is still reading.

Well, I personally think the main reason why this feature has been retired, is a new behaviour of big brother browser Microsoft Internet Explorer 9.
New features aren't always improvements...
I think when the Chrome start eating s-h-i-t, Mozilla will eat also. After all, we all have to follow the leader.
========================
I think when the Chrome start eating ****, Mozilla will eat also. After all, we all have to follow the leader.
Changing the GUI every couple months makes FF a perpetual Alpha product. This is one of those changes. Bring back the drop down.
You need to log in before you can comment on or make changes to this bug.