Closed Bug 636176 Opened 9 years ago Closed 9 years ago

Sync should not sync general.autoScroll

Categories

(Firefox :: Preferences, defect, trivial)

defect
Not set
trivial

Tracking

()

RESOLVED FIXED

People

(Reporter: philip.chee, Assigned: philip.chee)

References

Details

(Whiteboard: [fixed in fx-sync][fixed in services])

Attachments

(1 file)

(NB: Beltzner said to file a bug and CC philIKON)

<http://mxr.mozilla.org/comm-central/search?string=general.autoScroll>
<http://mxr.mozilla.org/comm-central/source/mozilla/browser/app/profile/firefox.js#227>
<http://mxr.mozilla.org/comm-central/source/suite/browser/browser-prefs.js#762>

The default for general.autoScroll is different on *nix.

Suggestion: Sync should not sync general.autoScroll

Reason: unexpected platform behaviour if the user has set up sync on
Linux as well as a Mac.

I'm picking Firefox::Preferences since this isn't SyncUI nor Sync::Backend.
(In reply to comment #0)
> The default for general.autoScroll is different on *nix.

Sigh I wish we had done bug 582536.

> Suggestion: Sync should not sync general.autoScroll
> 
> Reason: unexpected platform behaviour if the user has set up sync on
> Linux as well as a Mac.

Fair enough. Care to round up a patch?

> I'm picking Firefox::Preferences since this isn't SyncUI nor Sync::Backend.

Correct.
(In reply to comment #1)
> Sigh I wish we had done bug 582536.

That seems like the best fix...
(In reply to comment #2)
> (In reply to comment #1)
> > Sigh I wish we had done bug 582536.
> 
> That seems like the best fix...

Maybe. It's not trivial to do, though, whereas not whitelisting general.autoScroll is a pretty trivial patch.
So should I fix this in mozilla-central or in fx-sync or in both repositories?
Picking a reviewer at random.
Assignee: nobody → philip.chee
Status: NEW → ASSIGNED
Attachment #514757 - Flags: review?(philipp)
Attachment #514757 - Flags: review?(philipp) → review+
Duplicate of this bug: 636599
Comment on attachment 514757 [details] [diff] [review]
Patch Fx1.0 Firefox patch.

Not a blocker but nice to have paper-cut stuff.
Risk. None that I can see.
Gain. Reduced load on Firefox support having to answer additional questions from confused users.
Attachment #514757 - Flags: approval2.0?
Comment on attachment 514757 [details] [diff] [review]
Patch Fx1.0 Firefox patch.

a=beltzner
Attachment #514757 - Flags: approval2.0? → approval2.0+
Pushed to s-c: http://hg.mozilla.org/services/services-central/rev/d7961dc7e5f4
Will merge to m-c shortly
Whiteboard: [fixed in services]
Landed the equivalent in fx-sync for the add-on (Firefox 3.5/3.6): https://hg.mozilla.org/services/fx-sync/rev/4cee17375a8d
Whiteboard: [fixed in services] → [fixed in fx-sync][fixed in services]
Merged to m-c: http://hg.mozilla.org/mozilla-central/rev/d7961dc7e5f4
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.