Closed Bug 636463 Opened 9 years ago Closed 9 years ago

Language list doesn't scroll up/down in Preferences

Categories

(Firefox for Android Graveyard :: General, defect)

ARM
Android
defect
Not set

Tracking

(fennec2.0+)

VERIFIED FIXED
Tracking Status
fennec 2.0+ ---

People

(Reporter: ioana.chiorean, Assigned: vingtetun)

References

Details

(Keywords: regression)

Attachments

(3 files, 1 obsolete file)

Attached image screenshot
Build id : Mozilla/5.0 (Maemo;Linux armv7l;rv:2.0b12pre)Gecko/20110224
Firefox/4.0b12pre Fennec /4.0b6pre
Device: Sony Ericsson Xperia X10
OS: Android 2.1 update 1

Steps to reproduce:
1. Open Fennec app
2. Tap on device Settings button > Preferences
3. Tap on Language button
4. Scroll up/down the list

Expected result:
- The language list will scroll up/down if its length oversize the device screen display.

Actual result:
- The language list doesn't scroll at all. Above the "Auto-detect" entry there is an empty cell in the list.

Note:
- please see screenshot
Attached file alogcat file
This is similar to an old bug 606492.
Vivien touched the code that handles displaying the <select> ui, which also drives the <menulist> ui
Assignee: nobody → 21
tracking-fennec: --- → 2.0+
(In reply to comment #3)
> Vivien touched the code that handles displaying the <select> ui, which also
> drives the <menulist> ui

I will fix that soon.
Blocks: 622578
Keywords: regression
Attached patch Patch (obsolete) — Splinter Review
Attachment #515036 - Flags: review?(mark.finkle)
Attached patch Patch v0.2Splinter Review
14:29 <@mfinkle> vingtetun, ping
14:30 < vingtetun> mfinkle: pong
14:30 <@mfinkle> bug 636463
14:30 < vingtetun> yep
14:31 <@mfinkle> there are 2 <label id="menulist-title"
14:31 <@mfinkle> ?
14:31 < vingtetun> ...
14:31 <@mfinkle> <label id="menulist-title" ... flex="0"
14:31 < vingtetun> how could i have missed that...
14:31 <@mfinkle> <label id="menulist-title" ... flex="1"

shame...
Attachment #515036 - Attachment is obsolete: true
Attachment #515036 - Flags: review?(mark.finkle)
Attachment #515052 - Flags: review?(mark.finkle)
Attachment #515052 - Flags: review?(mark.finkle) → review+
http://hg.mozilla.org/mobile-browser/rev/5d257f348005
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
the scroll works fine now. 

Build id : Mozilla/5.0 (Android ;Linux armv7l;rv:2.0b13pre)Gecko/20110228
Firefox/4.0b13pre Fennec /4.0b6pre

but now the selection is made at every touch of the list.. Is this change intended or is a new bug?
Status: RESOLVED → VERIFIED
(In reply to comment #9)
> but now the selection is made at every touch of the list.. Is this change
> intended or is a new bug?

I think this will be fixed by bug 637215.
(In reply to comment #10)
> (In reply to comment #9)
> > but now the selection is made at every touch of the list.. Is this change
> > intended or is a new bug?
> 
> I think this will be fixed by bug 637215.

Confirmed - the selection changing on touch is fixed by bug 637215 which is already checked in.  (The fix will be in tomorrow's nightly.)
You need to log in before you can comment on or make changes to this bug.