Figure out/provide a better Persona-preview icon for the "Recommended for You" section

RESOLVED FIXED in 6.0.0

Status

P2
normal
RESOLVED FIXED
8 years ago
3 years ago

People

(Reporter: stephend, Assigned: cvan)

Tracking

unspecified
6.0.0
Dependency tree / graph

Details

(Whiteboard: [post-freeze+])

Attachments

(2 attachments)

chowse, fligtar asks that we come up with a better preview icon for Personas, than what's currently showing up in https://bug636527.bugzilla.mozilla.org/attachment.cgi?id=514854, in the "Recommended for You" section.
And anywhere else personas show up, like bug 636239.
Blocks: 636239
Target Milestone: 5.12.12 → 6.0.0
Created attachment 516054 [details]
Personas in the Disco Pane

Here's what I'd recommend (sample attached):

* Personas show up in the same style of box as other add-ons. Same dimensions,
  colors, borders, shadows, etc.

* The thumbnail used is the same 200x67px image used on GetPersonas.
  If the box is not wide enough to contain the thumbnail, crop from the
  left (i.e. the rightmost edge should always be visible). If the box is wider
  than 200px, center the thumbnail. Make sure the padding around the box is
  preserved (i.e. don't let the thumbnail grow to the edges of the box).

* The title is the same style as add-on titles, except that the name
  is truncated after 3 lines rather than 1.

* No description, even if the author provided one.
Is that the style for the st. patricks day personas in comment 1 too?
(In reply to comment #3)
> Is that the style for the st. patricks day personas in comment 1 too?

I suppose it is. Mine crops the thumbnail rather than letting it overflow (or is it supposed to be wrapping around the box?). Why don't we just go with the St. Patrick's Day style for now.
(Assignee)

Comment 5

8 years ago
We have the Persona styles for the "St. Patrick's Day Personas" promo. We need to apply this same style for Personas that appear within the Recommended add-ons module. This requires adding a flag to the `api.utils.addon_to_dict` for identifying the add-on by type. In the `discovery_pane.js`, we need to add an additional `template` for personas (there's currently one called `addon_item`). The template should add `class="persona-feature"` to the `li` and inside it should contain an anchor with the following:

    <h3>{{ addon.name }}</h3>
    {{ disco_persona_preview(addon.persona, linked=False) }}

potch? gkoberger?
chowse is done here and we need someone to take this. Currently these Personas can't even be previewed.
Assignee: chowse → nobody
cvan is working on it
Assignee: nobody → cwiemeersch
Priority: -- → P2
Whiteboard: [post-freeze+]
(Assignee)

Comment 8

8 years ago
https://github.com/jbalogh/zamboni/commit/e4ffddd
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Doesn't look like the overflow protection is working; reopening.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
overflow protection?
(In reply to comment #11)
> overflow protection?

See comment 4; you did look at the screenshot, right?
(In reply to comment #12)
> (In reply to comment #11)
> > overflow protection?
> 
> See comment 4; you did look at the screenshot, right?

I did, I don't know what the problem is.  It looks exactly like the mockups...?
Misunderstanding (as usual); Wil was talking about Sean's mocks in http://mozilla.seanmartell.com/engagement/addons-pane-promoz.jpg, not comment 2.
Status: REOPENED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → FIXED
Depends on: 640289
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.