Firefox 4.0 should have a square shaped Address bar.

RESOLVED WORKSFORME

Status

()

Firefox
Theme
--
enhancement
RESOLVED WORKSFORME
8 years ago
7 years ago

People

(Reporter: rajsudhakaran@gmail.com, Unassigned)

Tracking

Trunk
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:2.0b13pre) Gecko/20110303 Firefox/4.0b13pre
Build Identifier: Mozilla/5.0 (Windows NT 6.1; rv:2.0b13pre) Gecko/20110303 Firefox/4.0b13pre

The latest pre build 4.0 on 4th March 2011, has new tab shape by being more square and sharp edges, which look fantastic and is a great improvement. We would also like to see the address bar shape changed to square shape and font size increased by one point, "Screenshot attached". which would be more clean and enhanced. let me know if the enhancement is appealing and worth implementing.   

Reproducible: Always

Actual Results:  
Address bar shape improvement request

Expected Results:  
Address bar shape improvement request

Address bar shape improvement request
(Reporter)

Comment 1

8 years ago
Created attachment 516817 [details]
Address bar square shape screenshot

Address bar shape improvement request
(Reporter)

Comment 2

8 years ago
Created attachment 516833 [details]
Proposed screenshot appearance

The address bar in the screenshot is a little more spacious and prominent with increased font size,the edges are round here but it should have square edges to keep it tidy and the outline of Firefox 4.0 window is more slimmer to make it look lighter
Component: Location Bar → Theme
QA Contact: location.bar → theme
Version: unspecified → Trunk

Updated

8 years ago
Blocks: 638526
Depends on: 625742
Duplicate of bug 603790.
Bug 603790 reduced the radii, but not to zero. Not sure if that's what this bug is asking for.
It shouldn't be squared, we aren't using squared GUI anywhere.
(Reporter)

Comment 6

7 years ago
I am attaching a new UI address bar screenshot, which tells about the square edges address bar
(Reporter)

Comment 7

7 years ago
Created attachment 522978 [details]
Squared Address Bar Screenshot
We aren't IE9 and hopefully never will be. Everything is perfect as it is (after landed bug 603790 that is).
No longer depends on: 625742
Well, we have squared tabs, so this should be sqaured too.
(In reply to Peter Henkel [:Terepin] from comment #9)
> Well, we have squared tabs, so this should be sqaured too.

But it look weird as shown in the Squared Address Bar Screenshot. It look worse than IE9.
Bug 686671 solved this. This bug may be RESOLVED DUPLICATE.
For a sharper look try http://userstyles.org/styles/46277
(Reporter)

Comment 12

7 years ago
Used a addon Stratiform 1.2.1
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.