Fennec crash [@ js::RegExp::executeInternal ] on Samsung Continuum

RESOLVED FIXED

Status

()

--
critical
RESOLVED FIXED
8 years ago
7 years ago

People

(Reporter: Logan, Assigned: mbrubeck)

Tracking

({crash, mobile})

unspecified
Other
Other
crash, mobile
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(fennec2.0+)

Details

(Whiteboard: [has patch][has review], crash signature)

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b13pre) Gecko/20110303 Firefox/4.0b13pre
Build Identifier: 20110304042311

Relevant crashes:
https://crash-stats.mozilla.com/report/index/b19c98d5-1e50-46ff-b1a2-ba7572110304
https://crash-stats.mozilla.com/report/index/bp-7e01861a-462c-4814-ac7c-145942110304

They both are RegExp crashes, and it happens intermittently, but usually the first time loading a website when opening Fennec.

Reproducible: Sometimes

Steps to Reproduce:
1. Get a Samsung Continuum.
2. Download Fennec.
3. Install Fennec.
4. Open Fennec.
5. Load a website.
Actual Results:  
Fennec crashes with a JS error.

Expected Results:  
It should load the website.
(Assignee)

Updated

8 years ago
tracking-fennec: --- → ?
Keywords: crash, mobile

Comment 1

8 years ago
Can you specify which website?   does it reproduce on any page?
Also, please add the buildID of fennec.  (goto about:fennec, scroll to the bottom)
Summary: Fennec crashes due to JS errors on Samsung Continuum → Fennec crash [@ js::RegExp::executeInternal ] on Samsung Continuum
(Assignee)

Comment 2

8 years ago
This device is in the Galaxy S class, and is running Android 2.1 with Linux 2.6.29, just like the other Galaxy S phones that experienced JIT crashes.

We might need to extend the JIT blacklist to this device (SCH-I400).
(Assignee)

Updated

8 years ago
Depends on: 603624, 601222
(Reporter)

Comment 3

8 years ago
It crashes on techcrunch.com, for example.

Build: Mozilla/5.0 (android; Linux armv7l; rv:2.0b13pre) Gecko/20110304
Firefox/4.0b13pre Fennec/4.0b6pre
Instead of continuing to inflame this ugly pustule, I wonder if it's time to cut our losses and start refusing to install on the 2.1 galaxy s***.  Skype is already doing this (dunno why though).  If not now, when ...  I had hoped to fix bug 604774 around November.

Samsung and the carriers have just totally dropped the ball.

(Yes, I have a galaxy s*** still running 2.1.)
(Assignee)

Comment 5

8 years ago
Created attachment 517037 [details] [diff] [review]
patch: add Continuum to JIT blacklist
Assignee: general → mbrubeck
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
(Assignee)

Updated

8 years ago
Attachment #517037 - Flags: review?(dvander)
(Assignee)

Comment 6

8 years ago
There is a test build with this patch at:
http://people.mozilla.com/~mbrubeck/fennec-4.0b6pre-mbrubeck-continuum.apk
Attachment #517037 - Flags: review?(dvander) → review+
(Assignee)

Comment 7

8 years ago
Comment on attachment 517037 [details] [diff] [review]
patch: add Continuum to JIT blacklist

Requesting approval2.0: Trivial patch that fixes a crash by adding a new device to the JIT blocklist.
Attachment #517037 - Flags: approval2.0?
(Assignee)

Updated

8 years ago
Whiteboard: [has patch][has review][needs approval]
Attachment #517037 - Flags: approval2.0? → approval2.0+
(Assignee)

Updated

8 years ago
Whiteboard: [has patch][has review][needs approval] → [has patch][has review]
(Assignee)

Comment 8

8 years ago
http://hg.mozilla.org/mozilla-central/rev/4e771e65764a
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Crash Signature: [@ js::RegExp::executeInternal ]
tracking-fennec: ? → 2.0+
You need to log in before you can comment on or make changes to this bug.