Closed Bug 63950 Opened 20 years ago Closed 18 years ago

onclick doesn't fire on middle click

Categories

(Core :: DOM: UI Events & Focus Handling, defect)

x86
Windows ME
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla0.9.1

People

(Reporter: bugzilla, Assigned: bugzilla)

References

Details

(Keywords: regression)

Attachments

(2 files)

onclick is no longer firing on middle click.  This is a recent regression, like 
bug 63073.
we really should fix this for beta1, since it breaks middle-click paste and 
middle-click to open in new window.
Keywords: nsbeta1, regression
sorry, don't have a recent build --but, how does this look on linux? unless it's
win32-only... thx!
middle click is working fine on Linux as far as I can tell.
*** Bug 66471 has been marked as a duplicate of this bug. ***
Reassigning QA Contact for all open and unverified bugs previously under Lorca's
care to Gerardo as per phone conversation this morning.
QA Contact: lorca → gerardok
I'll look into this although my first bet would be that someone who's not 
supposed to is eating the event.
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla0.9.1
Taking...
Assignee: joki → blakeross
Status: ASSIGNED → NEW
saari/rods, can you take a look at this?
Status: NEW → ASSIGNED
looks like an excellent patch - r=rods
sr=alecf then - I'm not 100% qualified to review this, but it sure looks correct
to me, and rods gives it the ok :)
Fix checked in.
Status: ASSIGNED → RESOLVED
Closed: 19 years ago
Resolution: --- → FIXED
Cheers for Blake Ross!  You have given me a reason to browse with Mozilla again!
QA contact updated
QA Contact: gerardok → madhur
verified fixed on win2k buildid: 2001062004
Status: RESOLVED → VERIFIED
CODE SAMPLE
-----------
<html>
 <head></head>
 <body>
  <form method=get>
   <input type=checkbox name=a />
   <a href="/" onClick="document.forms[0].a.checked='true'" target="_blank">a</a>
  </form>
 </body>
</html>
-----------

PROBLEM
-----------
When left clicking, check box becomes checked, target opens in new window.  When
middle-clicking, check box does not check but link opens in new tab.

Tested with 2002051013 (RC2/Linux).
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
still happening in Moz. 1.0 both Windows 2k and Linux; would like to add
'mozilla1.0.1' keyword and change OS to 'all' but have insufficient privileges
Should we change the Target Milestone to some real value, since 0.9.1 was
released looong-looong ago?
Making this untargeted to get this back on radar.
Target Milestone: mozilla0.9.1 → ---
This bug was fixed a long time ago and Pete's bug does not have the same
symptoms.  This bug affected built-in browser functions, but Pete's only affects
content.  Re-resolving.

Pete, you can file a new bug for your problem, but your bug and bug 151142 can't
both be fixed.
Status: REOPENED → RESOLVED
Closed: 19 years ago18 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla0.9.1
was a new bug filed regarding comment 16 and comment 17 ?
Bug number ??
Yes, bug 156137 has been closed as WONTFIX.  This may do what you'd like,
however: http://white.sakura.ne.jp/~piro/xul/_tabextensions.html.en 
Just FYI, thanks to Firefox, the onClick event on <href> tags is now USELESS.

Many Firefox users navigate exclusively by clicking the middle mouse better
(NEVER the left button). Onclick events are never executed when the user clicks
middle mouse button. 

This breaks DHTML pages and hinders navigation because the user asks himself
"why the hell this doesn't do anything but open a blank page."
Right mouse button should never trigger onclick. But middle mouse button is actually a "wrapped" left mouse button functionality, so it MUST fire onclick.

Left mouse button: onclick="if (critical_error) return false;"
result: navigation cancelled

Middle mouse button: onclick="if (critical_error) return false;"
result: navigation not cancelled even though a critical error occurred.

The middle mouse functionality actually EMULATES left mouse button plus doing
additional convenience stuff.
Component: Event Handling → User events and focus handling
You need to log in before you can comment on or make changes to this bug.