Last Comment Bug 640132 - Status/link panel gets in way (obscures a find result at bottom-right side of page)
: Status/link panel gets in way (obscures a find result at bottom-right side of...
Status: RESOLVED FIXED
fixed by bug 171237
: regression
Product: Firefox
Classification: Client Software
Component: General (show other bugs)
: Trunk
: x86 All
: -- normal with 2 votes (vote)
: Firefox 12
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
: 641307 643178 647986 (view as bug list)
Depends on: 171237
Blocks: 541656 631250 631270
  Show dependency treegraph
 
Reported: 2011-03-09 02:57 PST by Alice0775 White
Modified: 2012-02-19 06:19 PST (History)
19 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
sample.html (6.00 KB, text/html)
2011-03-09 02:57 PST, Alice0775 White
no flags Details

Description Alice0775 White 2011-03-09 02:57:56 PST
Created attachment 518019 [details]
sample.html

The Bug 631270 is not fixed in case the link positioned at bottom-right side.

Reproducible: Always

Steps to Reproduce 1:
1. Start Minefield with new profile
2. Open attached html
3. Press Ctrl + F
4. Type "Firefox" in findbar
5. Click contents area
6. Press F3 and repeat


Steps to Reproduce 2:
1. Start Minefield with new profile
2. Open attached html
3. keypress / (Start quick find)
4. keypress minefield

Actual Results:  
 Status panel gets in way / obscures a Find result

Expected Results:  
 Shuld not.
Comment 1 j.j. 2011-03-13 19:42:18 PDT
*** Bug 641307 has been marked as a duplicate of this bug. ***
Comment 2 Alice0775 White 2011-03-19 17:03:21 PDT
*** Bug 643178 has been marked as a duplicate of this bug. ***
Comment 3 Onur Safak 2011-03-30 22:06:27 PDT
I agree. I think a horizontal approach would be a more appropriate solution, like in this presentation:

http://www.youtube.com/watch?v=YmgYspOx-Aw

- I assume what's annoying to people is the status text, displayed by a script or page load info. I don't think link target displays are the problem, as one can simply move the mouse cursor away from the link. Please correct me if I'm missing something.

- Horizontal replacement makes confusion and it's hard to read right aligned text. I didn't know it was because of the find bar, and was trying to get used to link targets being displayed on the right, but it was tiring.

In the presentation above:

- Find operation tries to center the result, OR a safe region (probably just the bottom border) is defined and bring-to-display operations use that region.

- When the current frame is the main frame, it can be scrolled a little more, bringing a padding in the bottom. This may look like an empty status bar, without the screen real-estate disadvantage of a persistent status bar.

In Opera Mobile, the top buttons go away and come into the display with the page's top when one scrolls. The padding area in the bottom is a similar idea.
Comment 4 Markus Fischer 2011-03-31 00:12:39 PDT
(In reply to comment #3)
> - I assume what's annoying to people is the status text, displayed by a script
> or page load info. I don't think link target displays are the problem, as one
> can simply move the mouse cursor away from the link. Please correct me if I'm
> missing something.

For me it started with the mouse over link. There are cases when you e.g. use find i page, find a text which is a link which is the last line of the page and the link is the left then the found text was obscured by the destination link.

> - Horizontal replacement makes confusion and it's hard to read right aligned
> text. I didn't know it was because of the find bar, and was trying to get used
> to link targets being displayed on the right, but it was tiring.

I agree to that. What's more confusing that the destination link is overlapping content is when it's not clear where you can expect the destination link to be shown.

Browsers have for a decade shown the status/destination link at the bottom, at the same place. It's hard/next to impossible for me to get rid of this habit. I'm just glad there's an extension which does that already.
Comment 5 Jo Hermans 2011-04-06 06:52:48 PDT
*** Bug 647986 has been marked as a duplicate of this bug. ***
Comment 6 David Balažic 2011-09-30 06:15:15 PDT
Which extension?
Comment 7 Ruben 2011-11-02 09:34:54 PDT
the problem is even worse: for example, if you have a chat popup-window open with not much width and the chat-inputfield is right at the bottom, then the tooltip always stays on top of that input-field.

example: cgi-irc: http://www.spacetrace.org/irc-portal.php
Comment 8 David E. Ross 2011-11-02 09:56:27 PDT
Is this not a Core bug instead of a Firefox bug?
Comment 9 j.j. 2011-11-02 10:14:27 PDT
It's a Firefox UI
Comment 10 Siddhartha Dugar [:sdrocking] 2012-02-02 00:44:44 PST
This bug still happens when the searched text is on the bottom right corner of the page. But that's a rare use case.
Comment 11 YUKI "Piro" Hiroshi 2012-02-02 00:58:36 PST
Is it really rare? In RTL pages, text can be shown on the bottom right corner. For example:
http://ar.wikipedia.org/wiki/%D8%AA%D8%B5%D9%86%D9%8A%D9%81:%D9%88%D9%8A%D9%83%D9%8A%D8%A8%D9%8A%D8%AF%D9%8A%D8%A7
Comment 12 David Balažic 2012-02-02 05:53:10 PST
It happens elsewhere too.
Examples:
 - http://www.microsoft.com/en-us/default.aspx "© 2012 Microsoft" at the bottom right corner
 - on this page <https://bugzilla.mozilla.org/show_bug.cgi?id=640132> "Top of page", also at the bottom right corner
 - most Wikipedia pages (that have text to the right edge of browser window), not only at bottom but on the entire page. Example: http://en.wikipedia.org/wiki/Lum_Invader
 - and many more (these are the first four pages I tried. One was google.com where the text is mostly left aligned, so this issue does not happen. Oh wait, it does, if the link is long enough, like the "cached" links. That is: every second link on the page does create the issue.)
Comment 13 Ruben 2012-02-02 11:00:36 PST
an easy solution would, if firefox would check, if you have the bottom status bar enabled and if so, then use this bar for the link instead of showing it inside the page.
this would solve the problem for all users, that like a status bar at the bottom.
if the status bar is disabled (like in default) then we would need another solution:
firefox should check, if there is something important there (like input-fields, etc...), where it intends to show the link. if so show it on the other side - if there is something important too, or the window is so narrow, that the link would reach to the other side and conceil something there, then just "dont show the link" anywhere, show a spinning wheel instead or something

Note You need to log in before you can comment on or make changes to this bug.