Closed Bug 64314 Opened 21 years ago Closed 11 years ago

xpinstall wizard doesn't support IPv6

Categories

(Core Graveyard :: Installer: XPInstall Engine, enhancement)

enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: colin, Unassigned)

References

(Blocks 1 open bug)

Details

The network code in xpinstall/wizard does not use NSPR. This means that it is 
IPv4 only, and doesn't take advantage of all the IPv6 support that's already
in NSPR.
The wizard doesn't use NSPR because the whole point of the wizard is to keep 
the stub as small as possible. Still, I guess we'll have to support this one 
way or another eventually
Assignee: dveditz → sgehani
Severity: normal → enhancement
Component: Installer: XPInstall Engine → Installer
Summary: xpinstall wizard is IPv4 only → [RFE]xpinstall wizard doesn't support IPv6
Over to Syd for installer bug triage
Assignee: sgehani → syd
Target Milestone: --- → M1
Target Milestone: M1 → Future
is this installer or xpi install?
Its the code in xpinstall/wizard, whatever that is.
Blocks: IPv6
Summary: [RFE]xpinstall wizard doesn't support IPv6 → xpinstall wizard doesn't support IPv6
->xpinstall
Assignee: syd → ssu
Component: Installer → Installer: XPInstall Engine
QA Contact: jimmylee → gbush
Assignee: ssu0262 → nobody
QA Contact: agracebush → xpi-engine
Target Milestone: Future → ---
bug 387450 killed this code
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → WONTFIX
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.