xpinstall wizard doesn't support IPv6

RESOLVED WONTFIX

Status

--
enhancement
RESOLVED WONTFIX
18 years ago
3 years ago

People

(Reporter: colin, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
The network code in xpinstall/wizard does not use NSPR. This means that it is 
IPv4 only, and doesn't take advantage of all the IPv6 support that's already
in NSPR.
The wizard doesn't use NSPR because the whole point of the wizard is to keep 
the stub as small as possible. Still, I guess we'll have to support this one 
way or another eventually
Assignee: dveditz → sgehani
Severity: normal → enhancement
Component: Installer: XPInstall Engine → Installer
Summary: xpinstall wizard is IPv4 only → [RFE]xpinstall wizard doesn't support IPv6

Comment 2

18 years ago
Over to Syd for installer bug triage
Assignee: sgehani → syd

Updated

17 years ago
Target Milestone: --- → M1

Updated

17 years ago
Target Milestone: M1 → Future

Comment 3

17 years ago
is this installer or xpi install?
(Reporter)

Comment 4

17 years ago
Its the code in xpinstall/wizard, whatever that is.

Updated

17 years ago
Blocks: 136898

Updated

17 years ago
Summary: [RFE]xpinstall wizard doesn't support IPv6 → xpinstall wizard doesn't support IPv6

Comment 5

16 years ago
->xpinstall
Assignee: syd → ssu
Component: Installer → Installer: XPInstall Engine
QA Contact: jimmylee → gbush
Assignee: ssu0262 → nobody
QA Contact: agracebush → xpi-engine
Target Milestone: Future → ---
bug 387450 killed this code
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WONTFIX
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.