If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

xpinstall wizard doesn't support IPv6

RESOLVED WONTFIX

Status

Core Graveyard
Installer: XPInstall Engine
--
enhancement
RESOLVED WONTFIX
17 years ago
2 years ago

People

(Reporter: Colin Blake, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
The network code in xpinstall/wizard does not use NSPR. This means that it is 
IPv4 only, and doesn't take advantage of all the IPv6 support that's already
in NSPR.
The wizard doesn't use NSPR because the whole point of the wizard is to keep 
the stub as small as possible. Still, I guess we'll have to support this one 
way or another eventually
Assignee: dveditz → sgehani
Severity: normal → enhancement
Component: Installer: XPInstall Engine → Installer
Summary: xpinstall wizard is IPv4 only → [RFE]xpinstall wizard doesn't support IPv6

Comment 2

16 years ago
Over to Syd for installer bug triage
Assignee: sgehani → syd

Updated

16 years ago
Target Milestone: --- → M1

Updated

16 years ago
Target Milestone: M1 → Future

Comment 3

16 years ago
is this installer or xpi install?
(Reporter)

Comment 4

16 years ago
Its the code in xpinstall/wizard, whatever that is.

Updated

15 years ago
Blocks: 136898

Updated

15 years ago
Summary: [RFE]xpinstall wizard doesn't support IPv6 → xpinstall wizard doesn't support IPv6

Comment 5

15 years ago
->xpinstall
Assignee: syd → ssu
Component: Installer → Installer: XPInstall Engine
QA Contact: jimmylee → gbush
Assignee: ssu0262 → nobody
QA Contact: agracebush → xpi-engine
Target Milestone: Future → ---
bug 387450 killed this code
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WONTFIX
(Assignee)

Updated

2 years ago
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.