Closed Bug 643177 Opened 9 years ago Closed 9 years ago

Memory leak after some hours

Categories

(Firefox :: General, defect, critical)

x86
Windows 7
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 659855

People

(Reporter: brunolm7, Unassigned)

Details

(Keywords: memory-leak)

User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0) Gecko/20100101 Firefox/4.0

Memory leak after some hours. With only 5 tabs the memory goes above 1GB. Closing tabs doesn't release memory.

With MemCleaner I can release 500mb+ only from Firefox.

Addons: Firebug

Reproducible: Always

Steps to Reproduce:
1. Open Firefox
2. Open 15 tabs
3. Close 10 tabs
Actual Results:  
Memory isn't released (leak)

Expected Results:  
Memory to be released (unused) Shouldn't keep memory that is not going to be used or is lost.

Windows 7 x64
Firefox 4 RC2 x86
Tabs: GMail, Facebook, Twitter, StackOverflow, Bugzilla, Google
(In reply to comment #0)
> Memory leak after some hours. With only 5 tabs the memory goes above 1GB.
> Closing tabs doesn't release memory.

How long did you wait? Several Seconds/Minutes?

Can you provide the Urls to those 15 Tabs?
Version: unspecified → Trunk
Blocks: mlk-fx5+
Keywords: mlk
Hardware: x86_64 → x86
URLs:
- mail.google.com
- facebook.com
- twitter.com
- stackoverflow.com
- redimob.com.br
- redimob.com.br
- redimob.com.br
- redimob.com.br
+ random URLs opened during the day.

5 hours later memory at 1,100,000
I can confirm at least a slow memory rise over a number of hours. I do not see the same values as given above likely because I am using my own general urls so it seems to have more widespread background. My rise is about 100MB per 8 hours of part idle part active use.

brunolm7: I think providing a copy of about:memory when its using lots of memory may help in finding the problem or at least say that something needs to be done with bug 633653.
No longer blocks: mlk-fx5+
This report does not have enough details to be acted upon usefully.  I'm marking it as a duplicate of bug 659855, which is the tracking bug for all memory leaks in Firefox 4 betas.

Also, Firefox 5 has better memory behaviour than Firefox 4 (http://blog.mozilla.com/nnethercote/2011/05/25/firefox-5-has-fewer-leaks-than-firefox-4/).  You can get a beta version of Firefox 5 from http://beta.mozilla.org.
Blocks: mlk-fx5+
No longer blocks: mlk-fx4
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: mlk-fx4-beta
No longer blocks: mlk-fx5+
You need to log in before you can comment on or make changes to this bug.